Pagina 1 di 1

Trovare elementi da colonna e elencarli in un'altra

MessaggioInviato: sabato 13 luglio 2019, 16:53
da stesf
Buongiorno a tutti.
E' da giorni che provo a risolvere questo problema:

ho una colonna che contiene delle formule per il richiamo di valori da altri fogli dello stesso documento Calc.
come da immagine allegata, questa colonna è la A.
In un'altra colonna (B da immagine) vorrei accorpare i risultati in modo da non avere le caselle (di A) che contengono la formula e che non hanno come risultato il richiamo di un valore; ovvero, vorrei quindi avere solo le caselle con il risultato elencate una sotto l'altra.

Sono riuscito ad avere come valore il primo risultato ("CIAO" da immagine) grazie alla formula
=SE(CODICE(A2)>0;A2;SE(CODICE(A3)>0;A3;SE....
ma non riesco a trovare la soluzione per le caselle sottostanti.

Vi ringrazio,
Stefano.

Re: Trovare elementi da colonna e elencarli in un'altra

MessaggioInviato: sabato 13 luglio 2019, 17:00
da gioh66
Ciao allega il file e non un'immagine con cui non ci si fa niente.

Re: Trovare elementi da colonna e elencarli in un'altra

MessaggioInviato: sabato 13 luglio 2019, 17:34
da charlie
Ciao @stesf e benvenuto/a sul forum.
Se intanto ti vuoi presentare puoi farlo in questa sezione -> https://forum.openoffice.org/it/forum/viewforum.php?f=16
Per una panoramica delle regole del forum puoi consultare il Manuale di sopravvivenza -> http://forum.openoffice.org/it/forum/viewtopic.php?f=1&t=2

Buon proseguimento

Re: Trovare elementi da colonna e elencarli in un'altra

MessaggioInviato: sabato 13 luglio 2019, 18:03
da stesf
gioh66 ha scritto:Ciao allega il file e non un'immagine con cui non ci si fa niente.


chiedo scusa, ecco il file

Re: Trovare elementi da colonna e elencarli in un'altra

MessaggioInviato: sabato 13 luglio 2019, 22:03
da gioh66
Allora in B2 prova la seguente formula matriciale
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(VAL.ERRORE(INDICE($E$2:$E$18;PICCOLO(SE(($D$2:$D$18<0)*(VAL.TESTO($E$2:$E$18));RIF.RIGA($E$2:$E$18)-1);RIF.RIGA(A1))));"";INDICE($E$2:$E$18;PICCOLO(SE(($D$2:$D$18<0)*(VAL.TESTO($E$2:$E$18));RIF.RIGA($E$2:$E$18)-1);RIF.RIGA(A1))))

Se non lo sai, per inserire una formula matriciale, fai così: ti posizioni sulla cella, dai F2 per aprirla in modalità modifica incolli la formula, la confermi con la combinazione di tasti CTRL+MAIUSCOLO+INVIO (non con il solo invio) e la copi e incolli nelle celle sottostanti.

Re: Trovare elementi da colonna e elencarli in un'altra

MessaggioInviato: mercoledì 11 settembre 2019, 13:13
da stesf
Scusate il ritardo, volevo ringraziarvi per le risposte: così, ho risolto il problema. Grazie!

Re: Trovare elementi da colonna e elencarli in un'altra

MessaggioInviato: mercoledì 11 settembre 2019, 13:28
da gioh66
Grazie a te del riscontro! :super: