Pannello di Controllo Moderatore ]

formattazione condizionale di più' valori e celle

Discussioni sull'applicazione per i fogli di calcolo

Re: formattazione condizionale di più' valori e celle

Messaggioda diego68 » mercoledì 17 luglio 2019, 8:36

non va bene, secondo me bisogna usare la formula fine.mese.
se febbraio ha 29 giorni o 28 giorni anche se ho 31 celle della data, deve fermarsi a 28 o 29 altrimenti nelle celle successive mi riporta anche 1 marzo 2 2 marzo, stesso discorso per i mesi con 30 giorni perché' mi riporta il primo giorni del mese successivo ed al calcolo delle ore della busta paga viene sempre conteggiato un giorni in più' se questo giorno non e' festivo
quindi nella colonna A dove ho 31 celle della data, quando arriva alla fine del mese le restanti celle devono essere vuote.
ho trovato questo foglio dove nelle date e' calcolato come intendo io ma non ho capito la formula che ha usato.
comunque ho capito come si fa, se ho il mese da 30 cancello la 31 riga se ne ho 28 nella 29 riga scrivo =SE(ANNO.BISESTILE(A7);(A34+1);"") dato che il calendario mi parte da A7
più' facile di quello che pensavo
ma una domanda.
io ho messo tutte le formule.
Se cancello una riga con il tasto elimina riga tutte le formule mi si spostano automaticamente di una riga sopra compreso la formattazione condizionale?
grazie
Allegati
ore_lavoro_1.01g.ots
(98.35 KiB) Scaricato 7 volte
OpenOffice 3.1 su Windows Vista
diego68
 
Messaggi: 59
Iscritto il: venerdì 12 luglio 2019, 10:56

Re: formattazione condizionale di più' valori e celle

Messaggioda gioh66 » mercoledì 17 luglio 2019, 13:04

Uauh, vedo che hai cambiato la struttura del file e che non c'è rimasto niente di quello che avevamo fatto finora. Bene ormai puoi continuare da solo. Ciao!
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: formattazione condizionale di più' valori e celle

Messaggioda diego68 » mercoledì 17 luglio 2019, 14:10

no questo e' un file di esempio che ho scaricato da internet, il mio file 'e sempre lo stesso, ti ho allegato il file per farti vedere cosa intendevo.
comunque grazie molto per il tuo aiuto, ora sono praticamente al termine del lavoro e riesco a fare il resto da solo. Senza il tuo aiuto sarebbe stato impossibile.
grazie ancora.
OpenOffice 3.1 su Windows Vista
diego68
 
Messaggi: 59
Iscritto il: venerdì 12 luglio 2019, 10:56

Re: formattazione condizionale di più' valori e celle

Messaggioda gioh66 » mercoledì 17 luglio 2019, 17:00

Ah ok! Vedendo quel file avevo creduto di aver sprecato il mio tempo.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: formattazione condizionale di più' valori e celle

Messaggioda diego68 » mercoledì 17 luglio 2019, 17:10

Ma figurati anzi sei stato più' che disponibile e gentile, senza il tuo aiuto ero nella m...
comunque per ora riesco a portarlo avanti da solo. Dovrò' poi fare un foglio per la contabilità' ed ho alcune domande sul calcolo dell'iva ma devo ancora arrivarci sto impaginando meglio il foglio orari e spostando le formule e facendo dei controlli ma ci vuole un sacco di tempo. voglio pero' fare una cosa che sia poi' definitiva.
OpenOffice 3.1 su Windows Vista
diego68
 
Messaggi: 59
Iscritto il: venerdì 12 luglio 2019, 10:56

Re: formattazione condizionale di più' valori e celle

Messaggioda gioh66 » mercoledì 17 luglio 2019, 17:34

Bene, per non fare un minestrone per il foglio contabilità apri un nuovo 3D. Nel frattempo buon lavoro.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: formattazione condizionale di più' valori e celle

Messaggioda diego68 » venerdì 19 luglio 2019, 18:15

scusa volevo un secondo ritornare su questa formula che va benissimo ma dovrei fare una piccola modifica
=SE(E(O(GIORNO.SETTIMANA($A99;2)>5;VAL.NUMERO(CONFRONTA($A99;$AH$7:$AH$17;0)));D7="malattia");"malattia";SE(E(O(GIORNO.SETTIMANA($A99;2)>5;VAL.NUMERO(CONFRONTA($A99;$AH$7:$AH$17;0)));D7="ferie");"ferie";SE(O(GIORNO.SETTIMANA($A99;2)>5;VAL.NUMERO(CONFRONTA($A99;$AH$7:$AH$17;0)));"riposo";SE(ORA(D7)<=5;ORARIO(5;0;0);SE(E(ORA(D7)>5;ORA(D7)<=13);ORARIO(13;0;0);SE(E(ORA(D7)>13;ORA(D7)<=17);ORARIO(17;0;0);SE(VAL.TESTO(D7);D7)))))))
mi calcola le ore partendo sempre dai turni 5-13 13-21 e 17-1 quindi se parte per esempio dalle 16 mi scrive sempre 17
ma avrei bisogno anche che insieme a questa formula se per esempio il turno parte dalle 18 fino alla 1 mi mantenesse le ore 18
ovvero partenza ore 16 scriva 17 partenza ore 18 oppure ore 19 mi scrivesse l'orario giusto.
idem partenza alle 14 mi scrivesse ore 14 mentre se parte alle 12 mi scriva sempre dalle 13 come gia' impostato.ed anche per le ore 5 di mattina
se parte alle 6 mi scriva alle 6
e' troppo complicato? se e' un casino lascia stare poi li modifico volta per volta a mano ma se riesci ne sono felice.
poi in teoria dovrei avere finito il foglio.
grazie
OpenOffice 3.1 su Windows Vista
diego68
 
Messaggi: 59
Iscritto il: venerdì 12 luglio 2019, 10:56

Re: formattazione condizionale di più' valori e celle

Messaggioda gioh66 » venerdì 19 luglio 2019, 21:34

Sto guardando l'ultimo file che hai allegato nell'altra discussione ma non trovo più dove sta la formula...senza riferimenti mi è difficile capire come modificarla.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Precedente

Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti