Pagina 1 di 1

[Risolto] Problema con cerca.vert

MessaggioInviato: martedì 21 maggio 2019, 17:42
da motoranocchio
vi metto l'allegato per far capire la stranezza del comando cerca.vert perchè è più facile da capire che spiegare.
nel listino che trovate nella cartella dati vi sono delle voci che finisco per un numero se io non metto il punto finale calc mi restituisce una cella errata.
a qualcuno è capitato è un bug o cosa?

Re: problema con cerca.vert

MessaggioInviato: martedì 21 maggio 2019, 21:30
da Gaetanopr
Cambia in questo modo
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(A11="";"";CERCA.VERT(A11;$dati.A$1:E$1048576;2;0))
aggiungi zero all'ultimo parametro del cercaverticale

Re: problema con cerca.vert

MessaggioInviato: martedì 21 maggio 2019, 21:41
da motoranocchio
grazie sembra funzionare , mi chiedo come mai la funzione automatica non mi avverta dell'errore e sopratutto come mai funziona sulle voci che non finisco per numeri

Re: problema con cerca.vert

MessaggioInviato: martedì 21 maggio 2019, 22:05
da gioh66
Ciao, la formula non ti avverte dell'errore perchè anche senza ordinato è corretta. Il problema sorge perchè tu vuoi che la formula ti dia un risultato determinato e senza che ci sia un ordine nei dati e questo lo indichi mettendo come valore dell'ordinato (il quarto argomento della funzione CERCA.VERT) zero.
Se lo ometti di default è uno, ma questo richiede che i dati siano in ordine crescente e di solito si usa per cercare un valore approssimativo, cioè un numero che sta tra un valore minimo ed uno massimo.

Re: problema con cerca.vert

MessaggioInviato: martedì 21 maggio 2019, 22:08
da motoranocchio
grazie gentilissimo la prossima volta farò attenzione a questi particolari ;)

Re: problema con cerca.vert

MessaggioInviato: martedì 21 maggio 2019, 22:09
da gioh66
Di nulla!