Pannello di Controllo Moderatore ]

[Risolto] Problema con cerca.vert

Discussioni sull'applicazione per i fogli di calcolo

[Risolto] Problema con cerca.vert

Messaggioda motoranocchio » martedì 21 maggio 2019, 17:42

vi metto l'allegato per far capire la stranezza del comando cerca.vert perchè è più facile da capire che spiegare.
nel listino che trovate nella cartella dati vi sono delle voci che finisco per un numero se io non metto il punto finale calc mi restituisce una cella errata.
a qualcuno è capitato è un bug o cosa?
Allegati
foglio_per_consuntivo_prova.ods
(13.9 KiB) Scaricato 6 volte
Ultima modifica di charlie il giovedì 23 maggio 2019, 8:31, modificato 1 volta in totale.
Motivazione: Inseriti [Risolto] e spunta verde
libreoffice 6.1 su debian
motoranocchio
 
Messaggi: 8
Iscritto il: domenica 19 maggio 2019, 20:04

Re: problema con cerca.vert

Messaggioda Gaetanopr » martedì 21 maggio 2019, 21:30

Cambia in questo modo
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(A11="";"";CERCA.VERT(A11;$dati.A$1:E$1048576;2;0))
aggiungi zero all'ultimo parametro del cercaverticale
Openoffice 4.1 su windows xp
Gaetanopr
Volontario
Volontario
 
Messaggi: 2686
Iscritto il: mercoledì 21 novembre 2012, 21:07

Re: problema con cerca.vert

Messaggioda motoranocchio » martedì 21 maggio 2019, 21:41

grazie sembra funzionare , mi chiedo come mai la funzione automatica non mi avverta dell'errore e sopratutto come mai funziona sulle voci che non finisco per numeri
libreoffice 6.1 su debian
motoranocchio
 
Messaggi: 8
Iscritto il: domenica 19 maggio 2019, 20:04

Re: problema con cerca.vert

Messaggioda gioh66 » martedì 21 maggio 2019, 22:05

Ciao, la formula non ti avverte dell'errore perchè anche senza ordinato è corretta. Il problema sorge perchè tu vuoi che la formula ti dia un risultato determinato e senza che ci sia un ordine nei dati e questo lo indichi mettendo come valore dell'ordinato (il quarto argomento della funzione CERCA.VERT) zero.
Se lo ometti di default è uno, ma questo richiede che i dati siano in ordine crescente e di solito si usa per cercare un valore approssimativo, cioè un numero che sta tra un valore minimo ed uno massimo.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 704
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: problema con cerca.vert

Messaggioda motoranocchio » martedì 21 maggio 2019, 22:08

grazie gentilissimo la prossima volta farò attenzione a questi particolari ;)
libreoffice 6.1 su debian
motoranocchio
 
Messaggi: 8
Iscritto il: domenica 19 maggio 2019, 20:04

Re: problema con cerca.vert

Messaggioda gioh66 » martedì 21 maggio 2019, 22:09

Di nulla!
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 704
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti