Pannello di Controllo Moderatore ]

[Risolto] Aggirare singolo criterio di ricerca per somma.se

Discussioni sull'applicazione per i fogli di calcolo

[Risolto] Aggirare singolo criterio di ricerca per somma.se

Messaggioda Francesco90 » domenica 19 maggio 2019, 15:29

Salve ragazzi. Nel file che vi allego ci sono due fogli. Nel Foglio 1 abbiamo cinque tabelle con dei valori. Nel foglio 2 c'è una tabella che somma tutti i valori relativi a una persona delle cinque tabelle e li riporta nella tabella del Foglio 2.
Come potete notare ho utilizzato la formula somma.se che però mi permette di inserire un solo criterio, quindi per riuscire a cercare sia per cognome che per nome ho utilizzato la colonna A, in entrambi i fogli per concatenare nome e cognome.
Vorrei sapere se esiste un metodo più efficiente o fatto apposta per questa esigenza

Grazie mille

tabelle_per_forum.ods
(20.9 KiB) Scaricato 12 volte
Ultima modifica di charlie il giovedì 23 maggio 2019, 8:33, modificato 2 volte in totale.
Motivazione: Aggiunta spunta verde
Openoffice 3.1 su windows8.1
Francesco90
 
Messaggi: 67
Iscritto il: mercoledì 2 agosto 2017, 23:33

Re: Aggirare singolo criterio di ricerca per somma.se

Messaggioda gioh66 » domenica 19 maggio 2019, 19:45

Ciao, prova con SOMMA.PIÙ.SE: in C3 di Foglio2 metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SOMMA.PIÙ.SE(Foglio1!C$3:C$45;Foglio1!$A$3:$A$45;$A3;Foglio1!$B$3:$B$45;$B3)

e trascina a destra e in basso.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 845
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Aggirare singolo criterio di ricerca per somma.se

Messaggioda Francesco90 » lunedì 20 maggio 2019, 11:23

Me lo sentivo che il mio era un pesante rattoppo... grande :)
Openoffice 3.1 su windows8.1
Francesco90
 
Messaggi: 67
Iscritto il: mercoledì 2 agosto 2017, 23:33

Re: [Risolto] Aggirare singolo criterio di ricerca per somma

Messaggioda gioh66 » lunedì 20 maggio 2019, 12:58

Di nulla :D
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 845
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 16 ospiti