Pannello di Controllo Moderatore ]

[Risolto] Copiare in automatico lo stile

Discussioni sull'applicazione per i fogli di calcolo

[Risolto] Copiare in automatico lo stile

Messaggioda Charc7is » mercoledì 8 maggio 2019, 17:06

ho un elenco di celle con stili differenti (B2:B101)
ho una casella che ne prende casualmente uno e vorrei che mantenesse anche lo stile a cui fa riferimento
se sceglie casualmente la cella B50 vorrei che oltre alla parola "grigio" che ci sia anche lo sfondo di colore nero e la parola scritta in colore verde
il tutto mi serve per avere ogni volta (basta fare copia e incolla della formula nella casella C1) una parola con uno stile differente
Allegati
Test scritte colori.xls
(13 KiB) Scaricato 12 volte
Ultima modifica di Charc7is il giovedì 9 maggio 2019, 16:54, modificato 1 volta in totale.
OpenOffice 4.1.1 su Windows 8
Charc7is
 
Messaggi: 38
Iscritto il: martedì 6 agosto 2013, 2:10

Re: Copiare in automatico lo stile

Messaggioda Gaetanopr » giovedì 9 maggio 2019, 9:53

Charc7is ha scritto:ho un elenco di celle con stili differenti (B2:B101)

Non è così..tu hai un elenco di celle con formattazioni diverse, lo stile è per tutte lo stesso ..quello predefinito.
Con formule non puoi ottenere quello che vuoi, ma occorrerebbe una macro.
In alternativa puoi fare in questo modo:
Creare tanti stili quante sono le formattazioni, assegnare ad ogni cella il proprio stile e usare una colonna adiacente indicando il nome dello stile applicato.
Ho modificato il tuo esempio, creando n.03 stili "Nero_Bianco", "Bianco_Nero", "Bianco_Rosso" dove il primo colore indica lo sfondo e il secondo il colore del carattere.
La formula diventa la seguente
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT(C1;A1:B100;2;0)&T(STILE(CERCA.VERT(C1;A1:C100;3;0)))
funziona fino a riga 31, cioè per i primi 3 stili, inserisci manualmente un numero nella cella C1 e vedi come cambia.
Allegati
Test scritte colori.ods
(11.89 KiB) Scaricato 10 volte
Openoffice 4.1 su windows xp
Gaetanopr
Volontario
Volontario
 
Messaggi: 2722
Iscritto il: mercoledì 21 novembre 2012, 21:07

Re: Copiare in automatico lo stile

Messaggioda Charc7is » giovedì 9 maggio 2019, 16:58

Gaetanopr ha scritto:puoi fare in questo modo:
Creare tanti stili quante sono le formattazioni, assegnare ad ogni cella il proprio stile e usare una colonna adiacente indicando il nome dello stile applicato.
Ho modificato il tuo esempio, creando n.03 stili "Nero_Bianco", "Bianco_Nero", "Bianco_Rosso" dove il primo colore indica lo sfondo e il secondo il colore del carattere.
La formula diventa la seguente
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT(C1;A1:B100;2;0)&T(STILE(CERCA.VERT(C1;A1:C100;3;0)))
funziona fino a riga 31, cioè per i primi 3 stili, inserisci manualmente un numero nella cella C1 e vedi come cambia.
Perfetto! :bravo:
Ho aggiunto gli stili mancanti e funziona
Basta copia'incollare la casella C1 su se stessa e la casella D1 cambia ogni volta :lol:

Grazie Mille
Allegati
Test scritte colori.ods
(17.08 KiB) Scaricato 7 volte
OpenOffice 4.1.1 su Windows 8
Charc7is
 
Messaggi: 38
Iscritto il: martedì 6 agosto 2013, 2:10


Torna a Calc

Chi c’è in linea

Visitano il forum: sergiobrzs81 e 18 ospiti