Pagina 1 di 1

[Risolto] Problema con cerca.vert

MessaggioInviato: domenica 18 agosto 2019, 17:11
da GabrieleT
Salve a tutti.
Premetto che sono alle primissime armi con l'uso di un foglio elettronico, ma volendo comunque realizzare un piccolo programma di gestione magazzino di un negozio di abbigliamento, ho riscontrato un problema con la funzione cerca.vert.

Nella colonna "Giacenza minima" (foglio "Scarico), vorrei richiamare il numero di pezzi in giacenza individuato nella colonna "Quantità" del foglio "Magazzino".
Tuttavia, utilizzando la funzione cerca.vert,
- se imposto ordinamento = 0, fornisce il risultato N/D
- se imposto ordinamento = 1, fornisce un risultato sbagliato, che si riferisce all'ultimo dei prodotti della tabella del "Magazzino".

Non riesco a capire dove sbaglio.
Allego il file

Re: Problema con cerca.vert

MessaggioInviato: domenica 18 agosto 2019, 20:24
da lucky63
.
Allega file senza password o ci dici la password ...

password.png
password.png (8.62 KiB) Osservato 312 volte

.

Re: Problema con cerca.vert

MessaggioInviato: martedì 20 agosto 2019, 19:55
da GabrieleT
chiedo scusa :knock:

Re: Problema con cerca.vert

MessaggioInviato: martedì 20 agosto 2019, 20:30
da gioh66
Salve la tua formula non funziona perchè la colonna su cui fai la ricerca in base al criterio deve essere la prima a a sinistra della tabella. Nel tuo caso devi usare INDICE e CONFRONTA. In H4 prova
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE(MAGAZZINO!$A$4:$A$10;CONFRONTA(B4;MAGAZZINO!$B$4:$B$10;0))

Ps.: per far funzionare la formula correttamente, i codici devono essere univoci altrimenti la corrispondenza si ferma al primo dato trovato (questo vale anche per il cerca verticale).

Re: Problema con cerca.vert

MessaggioInviato: martedì 20 agosto 2019, 20:39
da GabrieleT
gioh66 ha scritto:Salve la tua formula non funziona perchè la colonna su cui fai la ricerca in base al criterio deve essere la prima a a sinistra della tabella. Nel tuo caso devi usare INDICE e CONFRONTA. In H4 prova
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE(MAGAZZINO!$A$4:$A$10;CONFRONTA(B4;MAGAZZINO!$B$4:$B$10;0))

Ps.: per far funzionare la formula correttamente, i codici devono essere univoci altrimenti la corrispondenza si ferma al primo dato trovato (questo vale anche per il cerca verticale).


Grazie! problema risolto!
(unica cosa, per indicare il foglio in valore assoluto mi richiede di scrivere, ad esempio: " $Magazzino. " e non Magazzino!)

Re: [Risolto] Problema con cerca.vert

MessaggioInviato: martedì 20 agosto 2019, 20:48
da GabrieleT
però non capisco una cosa: la colonna su cui faccio la ricerca è già la prima a sinistra della tabella (a4 del Magazzino)..... o no?

Re: [Risolto] Problema con cerca.vert

MessaggioInviato: martedì 20 agosto 2019, 21:47
da Attilafdd
GabrieleT ha scritto:la colonna su cui faccio la ricerca è già la prima a sinistra della tabella (a4 del Magazzino)..... o no?

No, fai la ricerca per codice EAN che si trovano in colonna B (non A) e vuoi come risposta i valori di A (quantità).

Se usi il cerca.vert il valore che ricerchi deve essere nella prima colonna, quindi o inverti i valori di colonna A e B nel foglio "Magazzino" o devi cambiare formula (Indice e confronta come suggerito da @gioh66)

Re: [Risolto] Problema con cerca.vert

MessaggioInviato: martedì 20 agosto 2019, 22:01
da gioh66
Scusami per la formula. Io uso il sistema ExcelA1 per compatibilità con excel appunto.
Tu invece sicuramente hai impostate le formule con il sistema CalcA1, per cui la formula corretta è così
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE($MAGAZZINO.$A$4:$A$10;CONFRONTA(B4;$MAGAZZINO.$B$4:$B$10;0))


Per quanto riguarda la colonna, a sinistra deve stare la colonna in cui cercare il criterio. Cioè nel tuo caso a sinistra, del foglio Magazzino, dovrebbe esserci "Codice EAN prodotto", visto che tu fai la ricerca in base al codice che si trova in B4 del foglio "Scarico".
Questo per usare il CERCA.VERT ma usando INDICE e CONFRONTO scavalchi questa condizione.