Pannello di Controllo Moderatore ]

[Risolto] Attribuire un numero "classifica"

Discussioni sull'applicazione per i fogli di calcolo

[Risolto] Attribuire un numero "classifica"

Messaggioda gomoca » martedì 13 agosto 2019, 17:23

Ciao a tutti è da molto che ottengo soluzioni grazie al vostro aiuto ma questa volta, forse sbaglio anche i criteri di ricera, non ne vengo fuori....

Vorrei attribuire un numero da 1 a X (x= numero variabile in base alla colonna ) in base ad un range di numero che andrò a immettere nella cella precedente

Es
[COLONNA A] [COLONNA B]
[ ____275___ ] [ _da 1 a X__ ]


Ringrazio già chi mi aiuterà !!!
Ultima modifica di gomoca il lunedì 26 agosto 2019, 14:54, modificato 3 volte in totale.
openoffice 4.1.6. su MacOs Mojave 10.14.6
gomoca
 
Messaggi: 10
Iscritto il: martedì 13 agosto 2019, 17:04

Re: Attribuire un numero "classifica"

Messaggioda gioh66 » martedì 13 agosto 2019, 18:29

Prova così in A1 metti il numero e in B1 metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CASUALE.TRA(1;A1)

Ps.: il numero in A1 deve essere maggiore o uguale a 1.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Attribuire un numero "classifica"

Messaggioda charlie » martedì 13 agosto 2019, 19:12

Ciao @gomoca e benvenuto/a sul forum.
Se intanto ti vuoi presentare puoi farlo in questa sezione -> https://forum.openoffice.org/it/forum/viewforum.php?f=16
Per una panoramica delle regole del forum puoi consultare il Manuale di sopravvivenza -> http://forum.openoffice.org/it/forum/viewtopic.php?f=1&t=2

Buon proseguimento.
charlie
macOS 10.12 Sierra: Open Office 4.1.7 - LibreOffice 6.2.1.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 6021
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: Attribuire un numero "classifica"

Messaggioda gomoca » martedì 13 agosto 2019, 20:37

gioh66 ha scritto:Prova così in A1 metti il numero e in B1 metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CASUALE.TRA(1;A1)

Ps.: il numero in A1 deve essere maggiore o uguale a 1.

Grazie Gioh66 .... ovviamente non mi sono spiegato bene per amor di sintesi ....
provo sperando di non esser troppo prolisso

in A1 (e in altre celle ) dovrò inserire una cifra (fatturato) e in casella B1 vorrei si autocompilasse un punteggio.
per esempio in A1 se inserisco fatturati che vanno da 0 a 3.000 viene dato in B1 il punteggio come numero 0 ,
se inserisco da 3001 a 5000 viene dato il numero 1
da 5.000 a 13.000 il numero 2.....

In altre celle non ci saranno i fatturati ma altri fattori come richieste mensili o pezzi in magazzino ......
Graciis
openoffice 4.1.6. su MacOs Mojave 10.14.6
gomoca
 
Messaggi: 10
Iscritto il: martedì 13 agosto 2019, 17:04

Re: Attribuire un numero "classifica"

Messaggioda gioh66 » martedì 13 agosto 2019, 20:51

Ciao, allora è meglio se alleghi un file d'esempio col risultato inserito a mano :super:
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Attribuire un numero "classifica"

Messaggioda gomoca » martedì 13 agosto 2019, 21:09

Nell'esempio ho inserito solo 3 parametri ... ma ne dovrò aggiungere molti altri e nel tempo sempre di più.... alla fine dovrò sommare i risultati deii vari score (ma almeno quello so farlo !! )
Allegati
Esempio.ods
(14.24 KiB) Scaricato 6 volte
openoffice 4.1.6. su MacOs Mojave 10.14.6
gomoca
 
Messaggi: 10
Iscritto il: martedì 13 agosto 2019, 17:04

Re: Attribuire un numero "classifica"

Messaggioda gioh66 » martedì 13 agosto 2019, 21:36

Allora, modificando le tabelle e dividendo i valori limite su due colonne distinte, si potrebbe fare così:
in D2
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT(B2;B5:D500;3;1)

in H2
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT(F2;F5:H500;3;1)

e in L2
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT(J2;J5:L500;3;0)


Io nell'esempio ho indicato un range fino alla cella 500, se serve di più lo puoi aumentare, inoltre ti basterà aggiungere i nuovi valori nelle tabelle (fino alla riga 500) che verranno automaticamente conteggiati dalla formula.
Allegati
Esempio (bis_1).ods
(12.01 KiB) Scaricato 9 volte
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Attribuire un numero "classifica"

Messaggioda gomoca » martedì 13 agosto 2019, 22:11

Grazie mille !!!! Ora devo studiare le due funzioni così da essere autonomo !!!
Probabilmente ti scomoderò ancora
Graze ancora
openoffice 4.1.6. su MacOs Mojave 10.14.6
gomoca
 
Messaggi: 10
Iscritto il: martedì 13 agosto 2019, 17:04

Re: Attribuire un numero "classifica"

Messaggioda gioh66 » martedì 13 agosto 2019, 22:16

Grazie a te del riscontro. Ricordati di segnare la discussione come risolta, quando e se la ritieni tale. :super:
viewtopic.php?f=9&t=5661
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: [Risolto] Attribuire un numero "classifica"

Messaggioda gomoca » sabato 24 agosto 2019, 13:40

Ciao a tutti, "riapro" questa discussione, in quanto mi sono arenato su un attribuzione ...... In questo caso la scelta non è tra un range di numeri, ma da una scelta da un menù a tendina..... allego il file in questione con le attribuzioni evidenziate in rosso sia in foglio 1 che in foglio 2 (foglio struttura)


Grazie in anticipo a chi mi aiuterà !!!
Allegati
VALUTAZIONE PRODOTTO openoffice forum.ods
(22.92 KiB) Scaricato 9 volte
openoffice 4.1.6. su MacOs Mojave 10.14.6
gomoca
 
Messaggi: 10
Iscritto il: martedì 13 agosto 2019, 17:04

Re: Attribuire un numero "classifica"

Messaggioda gioh66 » sabato 24 agosto 2019, 20:14

Salve forse era meglio se aprivi una nuova discussione, comunque in foglio2 modifica in G22 così
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT(AE22;AE25:AG520;3;1)

In foglio1 invece spiega meglio cosa non torna.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Attribuire un numero "classifica"

Messaggioda gomoca » sabato 24 agosto 2019, 20:38

Su foglio 1 casella E7 ho fatto un menù a tendina.... volevo che ad ogni valore venisse dato un punteggio (stelle) in F7.... su foglio due ci sono i parametri da "copiare".... per esempio se scelgo "in discesa" su E7, vorrei che su F7 uscisse uno 0.... (ho usato il foglio 2 per le tutti i range delle attribuzioni, rimandando i valori da una cella di un foglio all'altro per mantenere il più pulito foglio 1 quando stampo...)
openoffice 4.1.6. su MacOs Mojave 10.14.6
gomoca
 
Messaggi: 10
Iscritto il: martedì 13 agosto 2019, 17:04

Re: Attribuire un numero "classifica"

Messaggioda gioh66 » domenica 25 agosto 2019, 13:56

Buondì, non mi è ben chiaro il discorso delle stelle, ma per ora se vuoi richiamare in F7 del Foglio1, in base al valore di E7, i valori della tabella del foglio "Struttura", prova
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT(E7;Struttura!AE25:AG29;3;1)
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Attribuire un numero "classifica"

Messaggioda gomoca » lunedì 26 agosto 2019, 10:39

Non riesco a spiegarmi bene.... in Foglio 1 cella E7, ho creato un menu a tendina con 5 varianti (In discesa, casuale, stabile, in crescita, in alta crescita) e vorrei che in base alla scelta che viene effettuata, nella cella F7 (sempre di Foglio 1) venga attribuito un numero (0 per "In discesa" ,2 per "casuale", 4 per "stabile",8 per "in crescita" ,10 per "in alta crescita") il foglio struttura mi serviva per richiamare le celle e avere Foglio1 il più "pulito" possibile
openoffice 4.1.6. su MacOs Mojave 10.14.6
gomoca
 
Messaggi: 10
Iscritto il: martedì 13 agosto 2019, 17:04

Re: Attribuire un numero "classifica"

Messaggioda gioh66 » lunedì 26 agosto 2019, 13:41

Ah ok! Allora va bene la formula che ti ho proposto nel mio messaggio precedente...con una correzione
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT(E7;Struttura!AE25:AG30;3;0)

Ho cambiato il valore dell'ordinato (il quarto argomento del CERCA.VERT) da 1 a 0 in quanto tu cerchi un valore in base a un criterio preciso e non approssimativo.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Attribuire un numero "classifica"

Messaggioda gomoca » lunedì 26 agosto 2019, 14:11

Ho incollato la formula in Foglio struttura, cella AG 22, ma mi dà errore (#NOME?)..... lo stesso se incollo la formula in foglio 1 cella e7...
openoffice 4.1.6. su MacOs Mojave 10.14.6
gomoca
 
Messaggi: 10
Iscritto il: martedì 13 agosto 2019, 17:04

Re: Attribuire un numero "classifica"

Messaggioda gioh66 » lunedì 26 agosto 2019, 14:21

Cavolo mi dimentico sempre che io uso libreoffice con la sintassi della formula per excel... :crazy:
Prova così
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT(E7;$Struttura.AE25:AG30;3;0)
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 848
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Attribuire un numero "classifica"

Messaggioda gomoca » lunedì 26 agosto 2019, 14:47

selezionando da Foglio 1 il menu a tendina E7 , il risultato viene copiato in Foglio struttura cella AE 22, la formula corretta da inserire in AG22 (Foglio struttura ) è
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT(AE22;$Struttura.AE25:AG30;3;0)

Che poi verra riportato in foglio 1 F7 .

Grazie mille !!!! Se passi a Budapest ti devo un po' di taj di blanc
openoffice 4.1.6. su MacOs Mojave 10.14.6
gomoca
 
Messaggi: 10
Iscritto il: martedì 13 agosto 2019, 17:04


Torna a Calc

Chi c’è in linea

Visitano il forum: paoletto75 e 11 ospiti