Pagina 1 di 1

Evitare la copia degli zeri da cella con formula

MessaggioInviato: martedì 13 agosto 2019, 0:15
da Francesco90
Salve ragazzi.
Ho un problema. Ho una tabella di lavorazione con tre colonne. NOME COGNOME e NOTE. I dati dei nomi e cognomi vengono presi da un'altra tabella sorgente.
Spesso e volentieri i nomi e cognomi dalla tabella sorgente non sono tanti quanti ne può ospitare la tabella di lavorazione.
Ciò genera degli zeri che si inseriscono nelle celle vuote. Gli zeri nella tabella di lavorazione non mi danno in alcun modo fastidio, so come fare per nasconderli alla vista.
PROBLEMA:
Il problema si presenta quando io seleziono la tabella di lavorazione e la copio nella tabella n°3. Per fare questa copia farò: tasto dx "incolla speciale" - "incolla speciale" - (metto la spunta su) "testo", "numeri", "data e ora", "formattazioni", "senza", "non spostare" - "ok".
A questo punto gli zeri saranno copiati. Questi zeri MI DANNO fastidio in quanto se qui provo a fare un ordinamento in modo crescente il risultato è che tutti gli zeri si posizionano prima di tutti i nomi e cognomi.

DOMANDA 1) Come posso fare per evitare che si copino gli zeri dalla tabella di lavorazione alla tabella n°3?
DOMANDA 2) Come evito che nell'ordinamento dei dati si spostino anche i bordi della tabella andando a finirci in mezzo? (guardate esattamente al bordo superiore di ALberto Franchini, alla tabella n°3)

test_per_forum.ods
(13.12 KiB) Scaricato 15 volte


Codice: Seleziona tutto   Espandi visualeStringi visuale
Rattoppo che ho trovato agli zeri non graditi nella tabella n°3:
Faccio un "trova e sostituisci" spuntando la casella "celle intere" e mettendo sul box "trova" il numero zero e lasciando vuoto il box "sostituisci". In questo modo tutti gli zeri che sono da soli in una cella vengono sostituiti col niente e risolvo.

Re: Evitare la copia degli zeri da cella con formula

MessaggioInviato: mercoledì 14 agosto 2019, 17:27
da lucky63
Nella tabella in lavorazione utilizza formule condizionali che verificano la cella iniziale in modo che se questa è vuota restituisca stringa nulla altrimenti visualizza il contenuto della cella.
Esempio per cella D3:

Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(A3="";"";A3)

Copiando i dati da tabella 2 e incollandoli con incolla speciale (no formule) in Tabella 3 non avrai gli zeri.
.

Re: Evitare la copia degli zeri da cella con formula

MessaggioInviato: mercoledì 14 agosto 2019, 18:58
da Francesco90
Grande! non ci avevo pensato al SE()
Grazie mille!

Re: Evitare la copia degli zeri da cella con formula

MessaggioInviato: giovedì 15 agosto 2019, 11:16
da lucky63
Francesco90 ha scritto:Grazie mille!

Guarda questo link: viewtopic.php?f=2&t=5661