Pannello di Controllo Moderatore ]

Funzione =SE() restituisce FALSO

Discussioni sull'applicazione per i fogli di calcolo

Funzione =SE() restituisce FALSO

Messaggioda m4nu85 » lunedì 12 agosto 2019, 5:51

Salve a tutti e grazie in anticipo a chi mi darà una mano...

credo di avere un problema simile a questo utente: viewtopic.php?f=9&t=3478#p16103
 Editato: link aggiunto da Admin 


Magari sto sbagliando, anzi sicuramente, qualcosa...

In pratica ecco cosa vorrei fosse il mio risultato:

due fogli
Foglio 1 "fattura da compilare", ma vorrei che alcuni campi venissero estratti dal Foglio 2 "elenco"

Es.
CODICE NOME SERVIZIO DESCRIZIONE QUANTITA' (ore) Sub. TOT.

il campo CODICE editabile con #001 o #002 o #003.
Il campo NOME SERVIZIO dovrebbe estrarre dal foglio "elenco" il relativo "nome servizio" della riga corrispondente al "CODICE #001"... stessa cosa il campo DESCRIZIONE.


Se non fosse chiaro ciò per il quale sono qui a scrivere e ciò di cui necessito... sono pronto a fornire screenshot!

Grazie ancora a chiunque voglia aiutarmi.
Ultima modifica di charlie il lunedì 12 agosto 2019, 7:08, modificato 2 volte in totale.
Motivazione: Argomento reso autonomo
OpenOffice 4.1 su MacOS
m4nu85
 
Messaggi: 2
Iscritto il: lunedì 12 agosto 2019, 5:40

Re: Funzione =SE() restituisce FALSO

Messaggioda charlie » lunedì 12 agosto 2019, 7:08

Ciao e benvenuto/a sul forum.
Se intanto ti vuoi presentare puoi farlo in questa sezione -> https://forum.openoffice.org/it/forum/viewforum.php?f=16
Per una panoramica delle regole del forum puoi consultare il Manuale di sopravvivenza -> http://forum.openoffice.org/it/forum/viewtopic.php?f=1&t=2

Buon proseguimento.
charlie
macOS 10.12 Sierra: Open Office 4.1.5 - LibreOffice 6.0.7
Windows 7 pro (VirtualBox): Open Office 4.1.5 - LibreOffice 5.4.4.2
Ubuntu 17.04 LTE (VirtualBox): LibreOffice 5.1.6.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 6003
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: Funzione =SE() restituisce FALSO

Messaggioda gioh66 » lunedì 12 agosto 2019, 13:27

Buondì allega un file senza dati sensibili su cui si possa lavorare...non uno screenshot con cui non ci fai niente! :D
Ps.: da quello che capisco dalla spiegazione non ti serve una funzione SE ma un CERCA.VERT o un INDICE e CONFRONTA.
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 845
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Funzione =SE() restituisce FALSO

Messaggioda m4nu85 » lunedì 12 agosto 2019, 14:25

gioh66 ha scritto:Buondì allega un file senza dati sensibili su cui si possa lavorare...non uno screenshot con cui non ci fai niente! :D
Ps.: da quello che capisco dalla spiegazione non ti serve una funzione SE ma un CERCA.VERT o un INDICE e CONFRONTA.


Ti invio qui il file, ma non devo "confrontare" piuttoto far in modo che a l'inserimento del dato "CODICE #XXX" si popolino i campi che mi servono...

http://gofile.me/4gbEk/qf89sUI4q (link di condivisione che scadrà stanotte alle 00.00)

Grazie
OpenOffice 4.1 su MacOS
m4nu85
 
Messaggi: 2
Iscritto il: lunedì 12 agosto 2019, 5:40

Re: Funzione =SE() restituisce FALSO

Messaggioda gioh66 » lunedì 12 agosto 2019, 14:51

No infatti devi estrarre dei dati. Se ho ben inteso in B10 del foglio fattura metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT($A10;LISTINO!$A$2:$D$40;CONFRONTA(B9;LISTINO!$A$1:$D$1;0);0)

e copia a destra.
Per i dati del cliente, inserito il nome in G1, con INDICE e CONFRONTA ricavo l'indirizzo. In G2
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE('RUBRICA CLIENTI'!D2:D40;CONFRONTA(G1;'RUBRICA CLIENTI'!B2:B40;0))


Ps.: per file piccoli come quello che hai postato non ti serve usare servizi esterni, ti basta usare il pulsante "Invia allegato" che c'è sotto il campo per inserire la risposta.
Allegati
Prova gest01.ods
(12.03 KiB) Scaricato 6 volte
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 845
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti