Pagina 1 di 1

[Risolto] Sempre gli ultimi 5!

MessaggioInviato: venerdì 2 agosto 2019, 11:26
da Kripsnark
Salve a tutti,
sono ancora io che mi propongo una nuova ed entusiasmante situazione da risolvere.

Supponiamo di giocare al lotto, ipotizziamo che ci saranno 30 estrazioni e a noi interessi sapere la media aritmetica delle ultime 5 estrazioni fatte. Che funzione si può utilizzare per fare in modo che ad ogni nuovo numero estratto inserito nella tabella, automaticamente la media agisca prendendo in considerazione sempre gli ultimi 5?

Allego un file che potrebbe aiutare a capire,
Grazie

Re: Sempre gli ultimi 5!

MessaggioInviato: venerdì 2 agosto 2019, 13:47
da lucky63
Formula Cella AI3:

Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(CONTA.NUMERI(D3:AG3)=0;"";SE(CONTA.NUMERI(D3:AG3)<6; MEDIA(INDIRETTO(INDIRIZZO(RIF.RIGA();29) & ":" &INDIRIZZO(RIF.RIGA();33)));MEDIA(INDIRETTO(INDIRIZZO(RIF.RIGA();34-CONTA.NUMERI(D3:AG3))&":"&INDIRIZZO(RIF.RIGA();38-CONTA.NUMERI(D3:AG3))))))


Replicabile in basso nella stessa colonna ove serve utilizzando copia/incolla.
Fai test

Re: Sempre gli ultimi 5!

MessaggioInviato: venerdì 2 agosto 2019, 14:04
da gioh66
Buondì! Prova così
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SOMMA(SCARTO(D3;;CONTA.NUMERI(D1:AG1)-CONTA.NUMERI(D3:AG3);;5))/5

Io ho messo la formula nella colonna AL

Re: Sempre gli ultimi 5!

MessaggioInviato: venerdì 2 agosto 2019, 14:34
da Kripsnark
grazie mille ad entrambi

Re: [Risolto] Sempre gli ultimi 5!

MessaggioInviato: venerdì 2 agosto 2019, 14:37
da gioh66
Giusto per gioco aggiungo un'altra formula con il sistema R1C1
Codice: Seleziona tutto   Espandi visualeStringi visuale
=MEDIA(INDIRETTO("r3c"&CONTA.VUOTE(A3:AG3)+2&":r3c"&CONTA.VUOTE(A3:AG3)+6;0))


Ps.: per la seconda riga di estrazioni va sostituito r3 con r16.