Pagina 1 di 1

[Risolto] Cerca in tabella (no macro)

MessaggioInviato: mercoledì 31 luglio 2019, 17:21
da patel
Ho una tabella di questo tipo
ITALIA FRANCIA
roma parigi
milano lione
napoli marsiglia


città milano
stato formula da inserire

quale formula posso utilizzare ?

allego file

Re: Cerca in tabella (no macro)

MessaggioInviato: mercoledì 31 luglio 2019, 21:44
da Gaetanopr
Puoi usare questa formula matriciale
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(SOMMA(SE(A2:B4=B7;RIF.COLONNA(A2:B4);""))=0;"Valore non presente";INDICE(A1:B1; ;SOMMA(SE(A2:B4=B7;RIF.COLONNA(A2:B4);""))))

Re: Cerca in tabella (no macro)

MessaggioInviato: mercoledì 31 luglio 2019, 22:15
da gioh66
Buonasera! A me vengono in mente due metodi. Il primo con formula matriciale (ctrl+maiuscolo+invio per confermarla)
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE(A1:B1;PICCOLO(SE(A2:B4=B7;RIF.COLONNA(A1:B1));1))

e l'altro non matriciale
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE(A1:B1;SE(VAL.NUMERO(CONFRONTA(B7;A2:A4;0));1;2))

Re: Cerca in tabella (no macro)

MessaggioInviato: mercoledì 31 luglio 2019, 22:26
da gioh66
...o anche
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE(A1:B1;MATR.SOMMA.PRODOTTO((A2:B4=B7)*(RIF.COLONNA(A1:B1))))

o se hai libreoffice (si potrebbe fare anche con openoffice...ma è meno "pratico")
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE(A1:B1;SE.ERRORE(VAL.NUMERO(CONFRONTA(B7;A2:A4;0));VAL.NUMERO(CONFRONTA(B7;B2:B4;0)+1)))


...scusate ma stì quesiti qua mi divertono troppo :mrgreen:

Re: Cerca in tabella (no macro)

MessaggioInviato: giovedì 1 agosto 2019, 9:56
da patel
Grazie a tutti, mi rincuora vedere formule piuttosto complesse, credevo di essere rinco...