Pannello di Controllo Moderatore ]

[Risolto] Cerca in tabella (no macro)

Discussioni sull'applicazione per i fogli di calcolo

[Risolto] Cerca in tabella (no macro)

Messaggioda patel » mercoledì 31 luglio 2019, 17:21

Ho una tabella di questo tipo
ITALIA FRANCIA
roma parigi
milano lione
napoli marsiglia


città milano
stato formula da inserire

quale formula posso utilizzare ?

allego file
Allegati
Cerca1.ods
(10.24 KiB) Scaricato 15 volte
Ultima modifica di charlie il giovedì 1 agosto 2019, 18:02, modificato 2 volte in totale.
Motivazione: Aggiunta spunta verde
-------------------
OpenOffice 4.1 e Libre Office 6.o.7.3 su Windows 10
allega un file di esempio, guadagnerai tempo tu e lo farai risparmiare a chi ti aiuta
patel
Volontario attivo
Volontario attivo
 
Messaggi: 3292
Iscritto il: venerdì 30 aprile 2010, 8:04
Località: Livorno

Re: Cerca in tabella (no macro)

Messaggioda Gaetanopr » mercoledì 31 luglio 2019, 21:44

Puoi usare questa formula matriciale
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(SOMMA(SE(A2:B4=B7;RIF.COLONNA(A2:B4);""))=0;"Valore non presente";INDICE(A1:B1; ;SOMMA(SE(A2:B4=B7;RIF.COLONNA(A2:B4);""))))
Allegati
Cerca1.ods
(10.48 KiB) Scaricato 7 volte
Openoffice 4.1 su windows xp
Gaetanopr
Volontario
Volontario
 
Messaggi: 2722
Iscritto il: mercoledì 21 novembre 2012, 21:07

Re: Cerca in tabella (no macro)

Messaggioda gioh66 » mercoledì 31 luglio 2019, 22:15

Buonasera! A me vengono in mente due metodi. Il primo con formula matriciale (ctrl+maiuscolo+invio per confermarla)
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE(A1:B1;PICCOLO(SE(A2:B4=B7;RIF.COLONNA(A1:B1));1))

e l'altro non matriciale
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE(A1:B1;SE(VAL.NUMERO(CONFRONTA(B7;A2:A4;0));1;2))
Allegati
Cerca1 (bis.1).ods
(11.83 KiB) Scaricato 8 volte
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 846
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Cerca in tabella (no macro)

Messaggioda gioh66 » mercoledì 31 luglio 2019, 22:26

...o anche
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE(A1:B1;MATR.SOMMA.PRODOTTO((A2:B4=B7)*(RIF.COLONNA(A1:B1))))

o se hai libreoffice (si potrebbe fare anche con openoffice...ma è meno "pratico")
Codice: Seleziona tutto   Espandi visualeStringi visuale
=INDICE(A1:B1;SE.ERRORE(VAL.NUMERO(CONFRONTA(B7;A2:A4;0));VAL.NUMERO(CONFRONTA(B7;B2:B4;0)+1)))


...scusate ma stì quesiti qua mi divertono troppo :mrgreen:
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 846
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Cerca in tabella (no macro)

Messaggioda patel » giovedì 1 agosto 2019, 9:56

Grazie a tutti, mi rincuora vedere formule piuttosto complesse, credevo di essere rinco...
-------------------
OpenOffice 4.1 e Libre Office 6.o.7.3 su Windows 10
allega un file di esempio, guadagnerai tempo tu e lo farai risparmiare a chi ti aiuta
patel
Volontario attivo
Volontario attivo
 
Messaggi: 3292
Iscritto il: venerdì 30 aprile 2010, 8:04
Località: Livorno


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti

cron