Pagina 1 di 1

[Risolto] Inserire più condizioni

MessaggioInviato: martedì 30 luglio 2019, 20:32
da sundae26
Salve non riesco a trovare la formula giusta per completare un foglio, spero possiate aiutarmi:

Considerate che nella riga ho questo

A B C. D. E
3 ITALIA PERUGIA 16
4. SPAGNA SIVIGLIA 16
5. FRANCIA PARIGI 15
6 INGHILTERRA LONDRA 14
7 GERMANIA. DUISBURG. 13
8 SVEZIA. OSLO. 12

Nella cella D3 ho questa formula (che poi estendo anche sotto a seguire):
=SE(O(A3="ITALIA";A3="SPAGNA";A3="FRANCIA";A3="INGHILTERRA";);"TOP";"/")

Nella cella accanto (E3) ho questa formula:
=SE(C3≥14;"EXT";"/")

Ora anziché avere due celle con due formule diverse volevo unire le due cose e soddisfare contemporaneamente più condizioni.
Dunque se la cella A si chiama ITALIA, a prescindere dal valore della cella C, nella cella D vorrei che mi risultasse la dicitura "TOP". Nel momento in cui la cella A non si chiama come una nazione contenuta nella formula OPPURE, (es. Germania), vorrei che a, quel punto, dominasse la seconda formula, ovvero se soddisfa la condizione ≥14 la cella D si chiamerà "EXT", in caso contrario "/".
Come posso risolvere questo problema? Grazie e scusate se non mi sono saputo spiegare ma è la prima volta che scrivo su questo forum.

Re: Inserire più condizioni

MessaggioInviato: martedì 30 luglio 2019, 23:08
da gioh66
Salve siccome tu hai già il file perchè non lo alleghi senza farcelo ricostruire, magari sbagliando? :mrgreen:

Re: Inserire più condizioni

MessaggioInviato: mercoledì 31 luglio 2019, 8:47
da sundae26
Ecco l'allegato! Spero vada bene il formato.

Re: Inserire più condizioni

MessaggioInviato: mercoledì 31 luglio 2019, 11:57
da gioh66
Buondì. Se ho capito bene cosa vorresti, potresti fare uno schemino col nome delle nazioni che devono dare come risultato "TOP", poi in E2 (io ho messo li la formula) metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(VAL.NUMERO(CONFRONTA(A3;$H$2:$H$5;0));"TOP";SE(E(VAL.ERRORE(CONFRONTA(A3;$H$2:$H$5;0));C3>14);"EXT";"/"))

Re: Inserire più condizioni

MessaggioInviato: mercoledì 31 luglio 2019, 12:37
da sundae26
PERFETTO!
Grazie mille sei stato gentilissimo, problema risolto!