Pagina 1 di 1

[Risolto]CERCA.VERT con criterio nella seconda colonna

MessaggioInviato: lunedì 29 luglio 2019, 14:53
da nikolas1194
Buongiorno a tutti.
Per accelerare l'inserimento dei dati nella scheda per i tempi di lavoro (foglio 1), ho messo in alcune celle la ricerca con CERCA.VERT dei valori presenti nello scadenziario (foglio 2). Il problema è che il criterio (nr.ordine-nr.riga) nello scadenziario non è nella prima colonna(infatti mi da come risultato #ND), ma nella seconda (lo scadenziario voglio che sia in ordine in base alla data di consegna). E' possibile dire alla funzione CERCA.VERT che il criterio è nella seconda colonna della matrice? Altrimenti come si fa ad ordinare una tabella secondo valori contenuti nella colonna diversa dalla prima o dall'ultima?

Allego il file di esempio e ringrazio in anticipo per il Vostro aiuto.

Buona giornata

Re: CERCA.VERT con criterio non nella prima colonna della ma

MessaggioInviato: lunedì 29 luglio 2019, 15:23
da gioh66
Buondì! Aggiustando le intestazioni delle tabelle di "SCAD" e quelle di "Scheda TL", in modo da uniformare i termini (nelle intestazioni delle righe F3:F7 del foglio "Scheda TL" c'erano degli spazi dopo i nomi) puoi usare INDICE e CONFRONTA che è più versatile del CERCA.VERT.
In C3 puoi mettere
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(C4="";"";INDICE(SCAD!$B$3:$I$6;CONFRONTA($C$4;SCAD!$C$3:$C$6;0);CONFRONTA(B3;SCAD!$B$2:$I$2;0)))

e in H3 da tirare in basso
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE($C$4="";"";INDICE(SCAD!$B$3:$I$6;CONFRONTA($C$4;SCAD!$C$3:$C$6;0);CONFRONTA(F3;SCAD!$B$2:$I$2;0)))

Re: CERCA.VERT con criterio non nella prima colonna della ma

MessaggioInviato: martedì 30 luglio 2019, 11:22
da nikolas1194
gioh66 ha scritto:Buondì! Aggiustando le intestazioni delle tabelle di "SCAD" e quelle di "Scheda TL", in modo da uniformare i termini (nelle intestazioni delle righe F3:F7 del foglio "Scheda TL" c'erano degli spazi dopo i nomi) puoi usare INDICE e CONFRONTA che è più versatile del CERCA.VERT.
In C3 puoi mettere
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(C4="";"";INDICE(SCAD!$B$3:$I$6;CONFRONTA($C$4;SCAD!$C$3:$C$6;0);CONFRONTA(B3;SCAD!$B$2:$I$2;0)))

e in H3 da tirare in basso
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE($C$4="";"";INDICE(SCAD!$B$3:$I$6;CONFRONTA($C$4;SCAD!$C$3:$C$6;0);CONFRONTA(F3;SCAD!$B$2:$I$2;0)))


Funziona perfettamente!!! Dovrò studiarmi bene l'accoppiamento delle formule INDICE e CONFRONTA che sembrano molto interessanti :)

Grazie mille per la dritta e buona giornata :D

Re: [Risolto]CERCA.VERT con criterio nella seconda colonna

MessaggioInviato: martedì 30 luglio 2019, 11:49
da gioh66
Grazie del riscontro!
E si a INDICE e CONFRONTA non serve che il dato per il confronto sia sulla prima colonna a sinistra come per CERCA.VERT