Pannello di Controllo Moderatore ]

[Risolto]Formule Visualizzate come testo. (eraProblema Calc)

Discussioni sull'applicazione per i fogli di calcolo

[Risolto]Formule Visualizzate come testo. (eraProblema Calc)

Messaggioda Cameljs » domenica 28 marzo 2010, 20:47

Salve, chiedo aiuto in questo forum perchè non riesco a risolvere da sola il mio problema.

Uso da anni OpenOffice, ma è dalla versione 3.0 o 3.1 (da 10 giorni uso la versione aggiornata a 3.2) che non mi funziona più la funzione Somma in Calc.
Io faccio come sempre la somma dopo una serie di celle, e quando clicco invece di apparire il totale mi appare la stessa funzione ma nessun risultato di calcolo. Per esempio se sommo le celle: "C4:C40", alla fine della digitazione mi appare la stessa formula in maiuscolo, e poi i 3 cancelletti. Non capisco perchè.

Potete gentilmente aiutarmi? Grazie mille, sono super indietro con i miei calcoli...
OpenOffice 3.2 su Windows XP Professional
Cameljs
 
Messaggi: 20
Iscritto il: domenica 28 marzo 2010, 20:40

Re: Problema con Calc

Messaggioda Gumo » domenica 28 marzo 2010, 22:04

Verifica la formattazione della cella risultato (probabilmente è valorizzato a "testo" invece che a Numero)
dx mouse > formatta celle ... > Numeri > (categoria) Numero

Dopo il cambio di formattazione, forse serve cancellare la formula e riscriverla.
- Verifica inoltre che i numeri siano inseriti come numeri e non come testo (non devono avere l'apicetto davanti.)

Ti prego di inserire un titolo più significativo del tipo:
Formule Visualizzate come testo.

Se è risolto puoi inserire (risolto) in coda al titolo, così gli altri utenti sanno che c'è una soluzione.
ciao
g
Per cortesia, inserisci [Risolto] nel Titolo iniziale se il tuo problema è stato risolto.
-
Win 7 AOO4.1 + Ubuntu 12.04 AOO3.4.1 - Esci dall'illegalità: utilizza OpenOffice !
Avatar utente
Gumo
 
Messaggi: 1158
Iscritto il: lunedì 15 marzo 2010, 13:43
Località: IT

Re: Problema con Calc

Messaggioda Cameljs » lunedì 29 marzo 2010, 10:44

Grazie Gumo, e chiedo scusa x l'errore del titolo.
Riguardo il mio problema, avevo già provato come scrivi tu a cambiare sia con numero che con valuta ma non cambia il risultato, viene sempre fuori la formula completa. Ho provato anche a riscriverla cambiando persino i due punti con punto e virgola... niente.
Provo a spiegarmi meglio:
sotto un tot di celle clicco l'icona "somma", nella cella appare la formula intera così scritta:
=SOMMA(D61:D65)
quando poi clicco "invio" sulla cella del totale mi appare:
# # #

Scusa l'ignoranza, cos'è l"apicetto"?

PS: mi sono accorta che nello stesso periodo ha anche smesso di funzionare l'icona "ordina in ordine alfabetico"...

Grazie mille x l'aiuto
OpenOffice 3.2 su Windows XP Professional
Cameljs
 
Messaggi: 20
Iscritto il: domenica 28 marzo 2010, 20:40

Re: Problema con Calc

Messaggioda paolopoz » lunedì 29 marzo 2010, 12:55

Di solito ### compare quando il numero non è visualizzabile per intero. Prova semplicemente ad aumentare la larghezza della colonna.

L'apicetto (o apice) è quello che di solito usiamo come apostrofo, sulla tastiera italiana si trova sullo stesso tasto del punto di domanda. Nel foglio di calcolo, se utilizzato come primo carattere all'interno di una cella, forza il programma a considerare il contenuto come testo.
Avatar utente
paolopoz
 
Messaggi: 244
Iscritto il: venerdì 22 maggio 2009, 12:20

Re: Problema con Calc

Messaggioda Bruno » lunedì 29 marzo 2010, 14:09

Prova a controllare se in Modifica - Modifche è attiva l'opzione Registra. Qualora sia attiva, disattivala e verifica se i comportamenti anomali sono ancora presenti (magari chiudendo e riaprendo il file...). Buon lavoro!
OpenOffice.org 3.2.0 su Windows Vista Home Premium
Bruno
 
Messaggi: 2
Iscritto il: lunedì 29 marzo 2010, 13:57

Re: Problema con Calc

Messaggioda Cameljs » martedì 30 marzo 2010, 10:19

Grazie Paolo, avevo provato anche questo, ma allargando la cella non cambia il risultato, si allarga semplicemente anche lo spazio della formula scritta.

Grazie Bruno, proverò questa funzione e ti farò sapere.
OpenOffice 3.2 su Windows XP Professional
Cameljs
 
Messaggi: 20
Iscritto il: domenica 28 marzo 2010, 20:40

Re: Problema con Calc

Messaggioda Cameljs » mercoledì 31 marzo 2010, 20:25

Ho provato ma modifica-modifiche non era spuntato. Non è cambiato nulla! Il problema continua.....
OpenOffice 3.2 su Windows XP Professional
Cameljs
 
Messaggi: 20
Iscritto il: domenica 28 marzo 2010, 20:40

Re: Problema con Calc

Messaggioda paolopoz » giovedì 1 aprile 2010, 11:06

Probabilmente qualcosa è andato storto durante gli aggiornamenti da una versione all'altra.
Dato che con la 3.2 installata da zero funziona tutto correttamente dovresti provare a disinstallare OOo, rimuovere il profilo utente (c'è una guida in inglese qui, purtroppo devo ancora tradurla in italiano) e reinstallare la 3.2 ex-novo.
:!: cancellando il profilo utente perderai tutte le impostazioni personalizzate che nel frattempo hai applicato.

Un'altra cosa che sarebbe utile sapere è se il file su cui stai operando è .ods o usa un altro formato.
Se crei un nuovo file e inserisci una somma di prova si comporta nella stessa maniera o funziona correttamente?
Avatar utente
paolopoz
 
Messaggi: 244
Iscritto il: venerdì 22 maggio 2009, 12:20

Re: Problema con Calc

Messaggioda antoniocantaro » giovedì 1 aprile 2010, 11:24

Ho appena provato la "Somma" con OOo 3.2 tutto perfettamente funzionante. Fai come ti dice Paolo.
_____

La scuola per il software libero
http://www.istitutomajorana.it
Avatar utente
antoniocantaro
 
Messaggi: 300
Iscritto il: lunedì 15 marzo 2010, 18:31
Località: Gela - Sicily

Re: Problema con Calc

Messaggioda Cameljs » giovedì 1 aprile 2010, 20:09

Grazie ragazzi x avermi risposto.
Sì ho provato anche con un foglio nuovo ma la somma non funziona ugualmente, e uso i formati ODS.
Proverò a fare come consigliate. Una domanda: come posso fare a togliermi dal profilo utente? Se potete spiegarlo com semplicità senza darvi disturbo, l'inglese lo capisco a livello di scuole elementari...
Grazie mille
OpenOffice 3.2 su Windows XP Professional
Cameljs
 
Messaggi: 20
Iscritto il: domenica 28 marzo 2010, 20:40

Re: Problema con Calc

Messaggioda Gumo » giovedì 1 aprile 2010, 21:55

Prova semplicemente ad eliminare il profilo utente in questo modo:
cerca la directory C:\Documents and Settings/<utente>/Dati applicazioni/OpenOffice.org/3

Chiudi tutto OOo compreso il Quickstarter (icona in basso a destra).
Rinomina la directory "3" in "3OLD"
Avvia OOo che è costretto a ricrearla nuova!

Se tutto funziona puoi cancellare la directory "3OLD" .
ciao
g
Per cortesia, inserisci [Risolto] nel Titolo iniziale se il tuo problema è stato risolto.
-
Win 7 AOO4.1 + Ubuntu 12.04 AOO3.4.1 - Esci dall'illegalità: utilizza OpenOffice !
Avatar utente
Gumo
 
Messaggi: 1158
Iscritto il: lunedì 15 marzo 2010, 13:43
Località: IT

Re: Problema con Calc

Messaggioda Cameljs » venerdì 2 aprile 2010, 20:28

Incredibile: ho guardato e riguardato ma quella cartella non c'è!
Non ho nè la cartella Dati applicazione nè la cartella 3 come sottodirectory di Openoffice.org.
Caspita non so più che pesci pigliare...
La cartella "Openoffice" c'è solo in questa directory: "c:\ Documents and settings\All users\Menu avvio\Programmi\Openoffice3.2
Non penso sia una cartella nascosta... Grazie, mi aiutate ancora?
OpenOffice 3.2 su Windows XP Professional
Cameljs
 
Messaggi: 20
Iscritto il: domenica 28 marzo 2010, 20:40

Re: Problema con Calc

Messaggioda antoniocantaro » sabato 3 aprile 2010, 11:06

La cartella c'è, ma devi renderla visibile. La cosa è semplicissima, guardati questa mia videoguida:

http://www.istitutomajorana.it/files/ub ... indows.htm

Ciao.
_____

La scuola per il software libero
http://www.istitutomajorana.it
Avatar utente
antoniocantaro
 
Messaggi: 300
Iscritto il: lunedì 15 marzo 2010, 18:31
Località: Gela - Sicily

Re: Formule Visualizzate come testo. (eraProblema con Calc)

Messaggioda Cameljs » lunedì 5 aprile 2010, 12:44

Vi ringrazio tantissimo, ho seguito il tutorial di Antonio, ed ora funziona. Mi sono accorta che malgrado avevo eseguito gli aggiornamenti, non so come Openoffice non era aggiornato. Pur avendo già installato OOo3.2, la mia versione graficamente era più vecchia. Boh, mistero. Ora funziona, grazie a tutti.

Quindi: RISOLTO.
OpenOffice 3.2 su Windows XP Professional
Cameljs
 
Messaggi: 20
Iscritto il: domenica 28 marzo 2010, 20:40

Re: [Risolto]Formule Visualizzate come testo. (eraProblema C

Messaggioda patty71 » lunedì 30 luglio 2012, 14:42

io ho lo stesso problema ma con OO 3.4.0 ma utilizzo mac osx 10.7.4...potete aiutarmi ???

grazie
open office 3.4.0 con mac os x 10.7.4
patty71
 
Messaggi: 3
Iscritto il: giovedì 26 luglio 2012, 9:15


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti