Pannello di Controllo Moderatore ]

Conta Se - Più Fogli

Discussioni sull'applicazione per i fogli di calcolo

Conta Se - Più Fogli

Messaggioda capodimontemassimo » domenica 30 agosto 2020, 12:10

Ciao a tutti, ho un file con vari fogli, in ciascuno c'è una lista di nomi che possono ripetersi nei fogli successivi . Desidero trovare una funzione che conti il numero dei nomi tenendo conto che a volte possono ripetersi e quindi lo stesso nome deve essere conteggiato una sola volta. Allego il file.
Allegati
Prova.ods
(12.37 KiB) Scaricato 38 volte
Ultima modifica di capodimontemassimo il sabato 25 settembre 2021, 8:42, modificato 3 volte in totale.
open office 4.1.5
vista
capodimontemassimo
 
Messaggi: 63
Iscritto il: sabato 8 aprile 2017, 9:09

Re: Conta Se - Più Fogli

Messaggioda gioh66 » lunedì 31 agosto 2020, 9:59

Ciao. Se non hai tanti fogli potresti ricopiare i vari elenchi uno sotto l'altro nel foglio4 poi con questa formula ricavi il numero univoco
Codice: Seleziona tutto   Espandi visualeStringi visuale
=MATR.SOMMA.PRODOTTO(1/CONTA.SE(A1:A42;A1:A42))
Allegati
conta se più fogli.ods
(11.14 KiB) Scaricato 30 volte
...se sei soddisfatto delle risposte ricevute metti il "Risolto" viewtopic.php?f=9&t=5661

Libreoffice 6/7 Ubuntu 20.04 - PcLinuxOS - LinuxMint 19
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 1333
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Conta Se - Più Fogli

Messaggioda capodimontemassimo » sabato 25 settembre 2021, 8:44

Non è esattamente la soluzione che cercavo ma un buon rimedio. Rimane solo il problema che inserendo una riga la formula non si aggiorna.
open office 4.1.5
vista
capodimontemassimo
 
Messaggi: 63
Iscritto il: sabato 8 aprile 2017, 9:09

Re: Conta Se - Più Fogli

Messaggioda gioh66 » sabato 25 settembre 2021, 12:42

Ciao. Prova a modificare la formula così
Codice: Seleziona tutto   Espandi visualeStringi visuale
=MATR.SOMMA.PRODOTTO(1/CONTA.SE(INDIRETTO("A1:A"&CONTA.VALORI(A1:A1000));(INDIRETTO("A1:A"&CONTA.VALORI(A1:A1000)))))

In questo modo il range si adatta man mano che aggiungi valori (o che li togli)
...se sei soddisfatto delle risposte ricevute metti il "Risolto" viewtopic.php?f=9&t=5661

Libreoffice 6/7 Ubuntu 20.04 - PcLinuxOS - LinuxMint 19
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 1333
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli


Torna a Calc

Chi c’è in linea

Visitano il forum: Google [Bot] e 7 ospiti

cron