Pannello di Controllo Moderatore ]

[Risolto]Popolare colonna senza duplicati

Discussioni sull'applicazione per i fogli di calcolo

[Risolto]Popolare colonna senza duplicati

Messaggioda Muset » giovedì 16 settembre 2021, 17:24

Buongiorno,
devo popolare una colonna (E) con dati immessi in altri 3 fogli. In ogni foglio ci sono nomi che si possono ritrovare anche negli altri 2 fogli, questi nomi non devono essere ripetuti nella colonna E.
Nel file che allego, nel foglio " Tutti i docenti" c'è la spiegazione più dettagliata.
Grazie per i suggerimenti
Allegati
A prova scuola primaria.ods
(37.37 KiB) Scaricato 12 volte
Ultima modifica di Muset il venerdì 17 settembre 2021, 11:33, modificato 1 volta in totale.
LibreOffice 7.1.3.2 (x64)
Muset
 
Messaggi: 86
Iscritto il: lunedì 29 marzo 2021, 14:35

Re: Popolare colonna senza duplicati

Messaggioda gioh66 » giovedì 16 settembre 2021, 20:57

Salve! Con le formule e una colonna d'appoggio puoi provare così: in una colonna (nel mio esempio da S1) metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE('Plesso A'.$B$122:$B$140;AGGREGA(15;6;(RIF.RIGA('Plesso A'.$B$122:$B$140)-RIF.RIGA('Plesso A'.$B$122)+1)/('Plesso A'.$B$122:$B$140<>"");RIF.RIGA(A1)));INDICE('Plesso B'.$B$122:$B$140;AGGREGA(15;6;(RIF.RIGA('Plesso B'.$B$122:$B$139)-RIF.RIGA('Plesso B'.$B$122)+1)/('Plesso B'.$B$122:$B$140<>"");RIF.RIGA(A1)-CONTA.VALORI('Plesso A'.$B$122:$B$140))));INDICE('Plesso C'.$B$126:$B$144;AGGREGA(15;6;(RIF.RIGA('Plesso C'.$B$126:$B$144)-RIF.RIGA('Plesso C'.$B$126)+1)/('Plesso C'.$B$126:$B$144<>"");RIF.RIGA(A1)-CONTA.VALORI('Plesso A'.$B$122:$B$140)-CONTA.VALORI('Plesso B'.$B$122:$B$140))));"")

E ottieni un elenco dei nominativi presenti nei tre fogli.
Poi per la lista univoca, in E6 metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE.ERRORE(INDICE($S$5:$S$200;CONFRONTA(0;INDICE(CONTA.SE($E$5:E5;$S$5:$S$200););0));"")&""

e tira in basso.
Nelle celle a fianco delle celle vuote di colonna E per non vedere i calcoli puoi mettere un controllo alle formula con un SE, tipo
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(E6="";"";"formula")

Ps.: la colonna d'appoggio se non la vuoi vedere la puoi nascondere.
Allegati
A prova scuola primaria (bis).ods
(41.56 KiB) Scaricato 8 volte
...se sei soddisfatto delle risposte ricevute metti il "Risolto" viewtopic.php?f=9&t=5661

Libreoffice 6/7 Ubuntu 20.04 - PcLinuxOS - LinuxMint 19
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 1331
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli

Re: Popolare colonna senza duplicati

Messaggioda Muset » venerdì 17 settembre 2021, 11:33

Buongiorno gioh,
il tuo suggerimento è indubbiamente perfetto, io ci sono arrivato vicino, ma con un dettaglio negativo, ovvero considera come nome anche le celle vuote :D
lo allego per darti un'idea di come l'ho messa giù.
Comunque grazie mille, applicherò la tua soluzione decisamente migliore.
Allegati
Aprova scuola primaria.ods
(38.84 KiB) Scaricato 6 volte
LibreOffice 7.1.3.2 (x64)
Muset
 
Messaggi: 86
Iscritto il: lunedì 29 marzo 2021, 14:35

Re: [Risolto]Popolare colonna senza duplicati

Messaggioda gioh66 » venerdì 17 settembre 2021, 12:41

Grazie del riscontro!
Nelle mie prove iniziali avevo avuto anch'io lo stesso problema, risolto utilizzando INDICE con AGGREGA per ottenere la colonna d'appoggio ed escludere le celle vuote.
...se sei soddisfatto delle risposte ricevute metti il "Risolto" viewtopic.php?f=9&t=5661

Libreoffice 6/7 Ubuntu 20.04 - PcLinuxOS - LinuxMint 19
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 1331
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli


Torna a Calc

Chi c’è in linea

Visitano il forum: Google [Bot] e 8 ospiti