Pannello di Controllo Moderatore ]

Formule concatenate con formato tempo

Discussioni sull'applicazione per i fogli di calcolo

Formule concatenate con formato tempo

Messaggioda Giuseppe v » mercoledì 21 luglio 2021, 9:32

Buongiorno a tutti. Ho un problema con un un menu a tendina concatenato. La concatenazione l’ho effettuata normalmente ma il formato, invece di visualizzarlo col tempo, me lo visualizza in formato numerico. Qualcuno sa perché?
Allegati
concatenazione tempo prova.ods
(140.46 KiB) Scaricato 17 volte
Open office 4.1.6 su Windows vista
Giuseppe v
 
Messaggi: 3
Iscritto il: martedì 9 luglio 2019, 12:01

Re: Formule concatenate con formato tempo

Messaggioda gioh66 » mercoledì 21 luglio 2021, 14:07

Ciao! Il tempo nei fogli di calcolo è contato come unità (dove 1 rappresenta un giorno) e frazioni di 1 per rappresentare gli orari.
Quello che vediamo come data e orario è solo una rappresentazione visuale. Probabilmente la FC non è programmata per mostrare gli orari come tali e li mostra solo come numeri.
Secondo me ti conviene fare un menù a tendina in C8 che ti visualizza le categorie (Corsa, Marcia e cagsm) e in e da G11 in giù un menù dove metti questa formula
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(TESTO(INDIRETTO($C$8);"hh.mm.ss")="00.00.01";"PROVA NON SUPERATA";SE(TESTO(INDIRETTO($C$8);"hh.mm.ss")="00.00.02";"ASSENTE";TESTO(INDIRETTO($C$8);"hh.mm.ss")))

Ps.: al posto di "PROVA NON SUPERATA" e "ASSENTE" metti 00.00.01 e 00.00.02. Questo perchè altrimenti queste prime due voci verrebbero viste nel menù a tendina come 00.00.00.
Ti allego il file modificato
Allegati
concatenazione tempo prova (bis).ods
(149.79 KiB) Scaricato 15 volte
...se sei soddisfatto delle risposte ricevute metti il "Risolto" viewtopic.php?f=9&t=5661

Libreoffice 6/7 Ubuntu 20.04 - PcLinuxOS - LinuxMint 19
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 1293
Iscritto il: lunedì 31 luglio 2017, 14:57
Località: Friuli


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti