Pannello di Controllo Moderatore ]

Foglio di calcolo base

Discussioni sull'applicazione per i fogli di calcolo

Foglio di calcolo base

Messaggioda SHANKT » lunedì 23 novembre 2020, 19:12

Buonasera a tutti,
sono molto incapace su calc (ho qualche piccola esperienza in piu' con Excel) e non so fare le piu' banali operazioni. In allegato vi metto il foglio che sto creando in cui non riesco a fare le seguenti funzioni:
- in J8 mi serve sommare tutti i valori con il "-" (segno meno) davanti
- in H8 invece mi serve sommare solo i positivi
- in H6 mi serve che mi venga riportato l'ultimo valore riportato nella colonna B

Sapreste aiutarmi, e magari spiegarmi, come fare per cortesia?

Grazie
Allegati
Deposito.ods
(11.28 KiB) Scaricato 13 volte
Ultima modifica di SHANKT il lunedì 23 novembre 2020, 20:17, modificato 1 volta in totale.
Open Office 4.1.6 - Windows 7
SHANKT
 
Messaggi: 4
Iscritto il: lunedì 23 novembre 2020, 19:07

Re: Foglio Di calcolo base

Messaggioda charlie » lunedì 23 novembre 2020, 19:30

Ciao e benvenuto/a sul forum.
Se intanto ti vuoi presentare, farai cosa gradita. Puoi farlo in questa sezione -> https://forum.openoffice.org/it/forum/viewforum.php?f=16

L’utente che apre un quesito si impegna:
In caso di inosservanza saremo costretti ad azioni di “richiamo”, sospensione o chiusura del profilo utente.

Buon proseguimento.


 Editato: Su questo forum usiamo il formato nativo dei file di Open Office. Quindi, per cortesia, allega un esempio in formato .ods. Grazie. 
charlie
macOS 10.12 Sierra: Open Office 4.1.8 - LibreOffice 6.4.6.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 7139
Iscritto il: mercoledì 19 dicembre 2012, 10:50

Re: Foglio Di calcolo base

Messaggioda gioh66 » lunedì 23 novembre 2020, 21:36

Salcve prova cosi: in J8 metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SOMMA.SE(C4:C200;"<"&0;C4:C200)
in H8
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SOMMA.SE(C4:C200;">"&0;C4:C200)
e in H6
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SCARTO($C$3;CONTA.NUMERI(C4:C200);0)
...se sei soddisfatto delle risposte avute metti il "Risolto" viewtopic.php?f=9&t=5661

Libreoffice 6/7 Ubuntu 20.04 - PcLinuxOS - LinuxMint 19
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 1223
Iscritto il: lunedì 31 luglio 2017, 13:57
Località: Friuli

Re: Foglio Di calcolo base

Messaggioda SHANKT » martedì 24 novembre 2020, 9:01

gioh66 ha scritto:Salcve prova cosi: in J8 metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SOMMA.SE(C4:C200;"<"&0;C4:C200)
in H8
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SOMMA.SE(C4:C200;">"&0;C4:C200)
e in H6
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SCARTO($C$3;CONTA.NUMERI(C4:C200);0)


Grazie mille, le prime 2 funzionano (io scrivero "<0" ecco l'errore, se dovessi mettere solo un numero non andrebbe tra virgolette giusto?) L'ultimo invece no. Mi serve solo che copi l'ultimo valore scritto nella colonna B. Intanto grazie di nuovo!
Open Office 4.1.6 - Windows 7
SHANKT
 
Messaggi: 4
Iscritto il: lunedì 23 novembre 2020, 19:07

Re: Foglio Di calcolo base

Messaggioda bobo779256 » martedì 24 novembre 2020, 9:28

Metti questa in H6:

Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA.VERT("zzzzz";B4:B200;1;1)

e poi formatti H6 come data

Presa sempre qua sul forum, non mi ricordo dove (le formule utili le metto tutte in una specie di database da cui poi le estraggo per provarle)
OpenOffice 4.1.7 su Windows 8.1 64bit
bobo779256
 
Messaggi: 107
Iscritto il: mercoledì 2 maggio 2012, 15:05

Re: Foglio Di calcolo base

Messaggioda gioh66 » martedì 24 novembre 2020, 12:51

SHANKT ha scritto:Grazie mille, le prime 2 funzionano (io scrivero "<0" ecco l'errore, se dovessi mettere solo un numero non andrebbe tra virgolette giusto?) L'ultimo invece no. Mi serve solo che copi l'ultimo valore scritto nella colonna B. Intanto grazie di nuovo!

Esatto! Se metti il numero tra virgolette viene interpretato come testo.
Per l'ultima formula ho sbagliato colonna. Prova così:
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SCARTO(B3;CONTA.NUMERI(B4:B200);0)

o anche così
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA(9^99;B4:B200)

o come suggerito da @bobo779256
...se sei soddisfatto delle risposte avute metti il "Risolto" viewtopic.php?f=9&t=5661

Libreoffice 6/7 Ubuntu 20.04 - PcLinuxOS - LinuxMint 19
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 1223
Iscritto il: lunedì 31 luglio 2017, 13:57
Località: Friuli

Re: Foglio Di calcolo base

Messaggioda SHANKT » mercoledì 25 novembre 2020, 14:11

gioh66 ha scritto:
SHANKT ha scritto:Grazie mille, le prime 2 funzionano (io scrivero "<0" ecco l'errore, se dovessi mettere solo un numero non andrebbe tra virgolette giusto?) L'ultimo invece no. Mi serve solo che copi l'ultimo valore scritto nella colonna B. Intanto grazie di nuovo!

Esatto! Se metti il numero tra virgolette viene interpretato come testo.

quindi qualsiasi numero deve stare fuori dalla virgilette... Ok grazie... ma invece di minore di zero non posso fare un'esclusione controllando i valori con il meno davanti?

gioh66 ha scritto:Per l'ultima formula ho sbagliato colonna. Prova così:
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SCARTO(B3;CONTA.NUMERI(B4:B200);0)

o anche così
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CERCA(9^99;B4:B200)

o come suggerito da @bobo779256


Perfetto funzioanno entrambi grazie mille...
Open Office 4.1.6 - Windows 7
SHANKT
 
Messaggi: 4
Iscritto il: lunedì 23 novembre 2020, 19:07

Re: Foglio Di calcolo base

Messaggioda gioh66 » mercoledì 25 novembre 2020, 17:23

... ma invece di minore di zero non posso fare un'esclusione controllando i valori con il meno davanti?

Si con un'altra formula, dove i numeri vengono trasformati in testi in modo da comparare e sommare quelli preceduti dal segno meno. Così:
Codice: Seleziona tutto   Espandi visualeStringi visuale
=MATR.SOMMA.PRODOTTO(C4:C100*(SINISTRA(TESTO(C4:C100;"0,00");1)="-"))

Però non credo sia molto meglio.
...se sei soddisfatto delle risposte avute metti il "Risolto" viewtopic.php?f=9&t=5661

Libreoffice 6/7 Ubuntu 20.04 - PcLinuxOS - LinuxMint 19
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 1223
Iscritto il: lunedì 31 luglio 2017, 13:57
Località: Friuli

Re: Foglio Di calcolo base

Messaggioda SHANKT » venerdì 27 novembre 2020, 17:53

Ah non legge in automatico "in numeri" quelli negativi. Cioè lui il segno "meno" lo vede solo come testo... Piu' complicata questa, userò l'altra allora. Grazie mille della spiegazione... Purtroppo non capisco perchè non usi le stesse logiche di excel... Peccato!
Open Office 4.1.6 - Windows 7
SHANKT
 
Messaggi: 4
Iscritto il: lunedì 23 novembre 2020, 19:07


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti