Pannello di Controllo Moderatore ]

Copia/incolla in verticale invece che orizzontalmente

Discussioni sull'applicazione per i fogli di calcolo

Copia/incolla in verticale invece che orizzontalmente

Messaggioda gocu01 » domenica 12 gennaio 2020, 22:57

Salve a tutti,

sono solito copiare dati (in genere numeri) da una pagina web ed incollarli su un figlio Calc. I dati della pagina web sono disposti con un preciso ordine e si susseguono orizzontalmente e ricalcando questo ordine io li incollo su Calc facendo un semplice e veloce copia/incolla. Da oggi però, di punto in bianco, me li incolla in verticale.

Non capisco cosa sia successo.. avete qualche idea?
openoffice 4.1.2 windows10
gocu01
 
Messaggi: 23
Iscritto il: domenica 20 marzo 2016, 20:49

Re: Copia/incolla in verticale invece che orizzontalmente

Messaggioda patel » lunedì 13 gennaio 2020, 8:29

probabilmente è cambiato qualcosa nel codice della pagina web anche se non visibile, però puoi sempre fare la trasposizione
https://help.libreoffice.org/latest/it/ ... otate.html
-------------------
OpenOffice 4.1 e Libre Office 6.o.7.3 su Windows 10
allega un file di esempio, guadagnerai tempo tu e lo farai risparmiare a chi ti aiuta
patel
Volontario attivo
Volontario attivo
 
Messaggi: 3374
Iscritto il: venerdì 30 aprile 2010, 7:04
Località: Livorno

Re: Copia/incolla in verticale invece che orizzontalmente

Messaggioda gocu01 » lunedì 13 gennaio 2020, 21:02

Ok grazie, peccato però che sia cambiato tutto così di punto in bianco
openoffice 4.1.2 windows10
gocu01
 
Messaggi: 23
Iscritto il: domenica 20 marzo 2016, 20:49

Re: Copia/incolla in verticale invece che orizzontalmente

Messaggioda gocu01 » lunedì 13 gennaio 2020, 22:48

Cioè, per fare un esempio ho allegato due files: Esempio1 è ciò di cui ho bisogno facendo copia/incolla di un testo formattato preso da web ed Esempio2 è ciò che accade ora e che mi causa problemi.

Sapete se c'è un modo per convertire Esempio2 in Esempio1?

Grazie mille
Allegati
esempio2.ods
(12.47 KiB) Scaricato 3 volte
esempio1.ods
(10.61 KiB) Scaricato 2 volte
openoffice 4.1.2 windows10
gocu01
 
Messaggi: 23
Iscritto il: domenica 20 marzo 2016, 20:49

Re: Copia/incolla in verticale invece che orizzontalmente

Messaggioda gioh66 » martedì 14 gennaio 2020, 10:47

Buondì. Se i tuoi dati sono sempre a blocchi di 14 righe, come da esempio, si potrebbe tentare con una formula. In A1 di un secondo foglio prova a mettere
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(COLONNE($A$1:A1)>14;"";SE(VAL.ERRORE(INDICE($Foglio1.$A$1:$A$28;(RIF.RIGA($A1)*14-14)+RIF.COLONNA(A1)));"";INDICE($Foglio1.$A$1:$A$28;(RIF.RIGA($A1)*14-14)+RIF.COLONNA(A1))))

e tiri a destra e in basso.
Allegati
trasponi righe.ods
(15.1 KiB) Scaricato 2 volte
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS - LinuxMint 19
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 945
Iscritto il: lunedì 31 luglio 2017, 13:57
Località: Friuli

Re: Copia/incolla in verticale invece che orizzontalmente

Messaggioda gocu01 » martedì 14 gennaio 2020, 23:09

Grazie mille Gioh66,

Sì, i dati sono sempre a blocchi di 14 righe, però ho provato la formula e non sembra funzionare a dovere.
Mi riporta solo i valori a A1 e A2, nient'altro purtroppo.

Ti allego il file
Allegati
trasponi righex.ods
(12.26 KiB) Scaricato 1 volta
openoffice 4.1.2 windows10
gocu01
 
Messaggi: 23
Iscritto il: domenica 20 marzo 2016, 20:49

Re: Copia/incolla in verticale invece che orizzontalmente

Messaggioda gioh66 » mercoledì 15 gennaio 2020, 10:39

Si questo perchè sono stato stretto con i valori dell' INDICE: prova così, che si evita anche di vedere gli 0 quando le celle sono vuote.
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(COLONNE($A$1:A1)>14;"";SE(INDICE($Foglio1.$A$1:$A$5000;(RIF.RIGA($A1)*14-14)+RIF.COLONNA(A1))="";"";INDICE($Foglio1.$A$1:$A$5000;(RIF.RIGA($A1)*14-14)+RIF.COLONNA(A1))))

inoltre, come ti avevo detto nel messaggio precedente la formula va tirata a destra e in basso (o copiata e incollata).
Allegati
trasponi righex(bis).ods
(20.93 KiB) Scaricato 2 volte
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS - LinuxMint 19
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 945
Iscritto il: lunedì 31 luglio 2017, 13:57
Località: Friuli


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti