Pannello di Controllo Moderatore ]

Problemi di formattazione del testo

Discussioni sull'applicazione di videoscrittura

Problemi di formattazione del testo

Messaggioda Din-Draug » giovedì 7 dicembre 2017, 0:24

Buongiorno, primo post sul forum e già mi tocca partire con "problemi" piuttosto vaghi... Accidenti! :?

Premetto che sto usando un computer di seconda mano di cui non conosco la "storia clinica" e tutto ciò che il precedente proprietario potrebbe aver fatto, come modifiche alle impostazioni, installazione di "cose", e che dopo anni di TextEdit (Mac OS) e Word Office (Windows) OpenOffice mi sembra sì molto famigliare nell'aspetto, ma spesso non trovo le cose dove mi aspetto di trovarle - forse la soluzione ai miei problemi è dietro l'angolo e non la trovo.

Allora, la formattazione a volte impazzisce, in modi diversi. Ho riscontrato principalmente due problemi:

(1) Quando copio un testo da un file (OpenOffice, formato .rtf) e lo incollo in un'altro file (sempre software, sempre formato) perdo tutta la formattazione, indipendentemente che la formattazione della fonte e della destinazione siano esattamente uguali (font, dimensione, paragrafo). Cercando in rete ho trovato tante persone che si chiedono come copiare senza portarsi dietro la formattazione originale, io cerco di fare esattamente il contrario e non ci riesco.

P.S. Credo possa centrare che spesso il documento non tiene la formattazione che gli assegno: tutto Times New Roman corpo 12, ma spuntano sempre fuori parti del documento in cui risulta Calibri 11 (mi pare).
P.P.S. Mentre scrivo sto facendo alcune prove e copiando un blocco di testo composto da più paragrafi è stato di volta in volta incollato in modo diverso: perdendo tuta la formattazione, perdendo il fond e la dimensione ma mantenendo gli stile, e un po' e un po', un paragrafo in un modo e uno nell'altro.

Il secondo problema (2) è più... strano.
Alcuni documenti, solo in alcune porzioni di testi, non riconoscono più caratteri speciali (solitamente vocali accentate, trattini lunghi e apostrofi più la vocali che li segue), sostituendolo con un ideogramma, "rombi neri con punto interrogativo" e una volta con semplici rettangolini.
La cosa divertente è quando correggo queste sostituzioni non volute, salvo e me le ritrovo alla riapertura del documento. Non capita sempre, ma quando le formattazioni impazziscono non so mai se la loro correzione rimarrà e quante volte dovrò rimetterci mano.
Un'altra strana sostituzione di caratteri è la comparsa di spazi grigi larghi quanto uno spazio della barra spaziatrice, talvolta sostituiscono questa, altre si infilano davanti a simboli come trattini a inizio frase, numeri all'interno di una tabella e cose simili. Queste apparizioni una volta corrette non si ripresentano.

Ok, una precisazione: molti (ma non tutti) dei file su cui lavoro sono stati creati con Word, ma spesso quando ritorno a lavorarci li risalvo ex novi (Salva non nome). Il "problema 2" tende a sopravvivere all'incollaggio su un nuovo documento e riformattazione del testo.


Ringrazio anticipatamente e mi scuso per la lunghezza del post (la sintesi è una bella cosa, ma preferisco la precisione). E se i miei problemi sono delle cavolate che si possono risolvere con pochi click abbiate pietà, sono un po' gniubbo. :D
OpenOffice 4.1.4 / Windows 7
Din-Draug
 
Messaggi: 2
Iscritto il: mercoledì 6 dicembre 2017, 23:45

Re: Problemi di formattazione del testo

Messaggioda unlucky83 » giovedì 7 dicembre 2017, 0:46

complimenti...praticamente hai una situazione a dir poco disastrosa.
Mi limito ai "rombi neri con punto interrogativo" e ai semplici rettangolini. Compaiono quando c'è un errore nella codifica.
E' passato molto tempo da quando sono passato da windows a linux, in quella circostanza ho riscontrato parecchie volte, ma non sempre, errori di questi tipi.
Linux e Mac adottano la codifica utf-8, mentre windows la ISO...ciò può creare problemi se il file è stato salvato con codifica utf-8 e aperto su windows.
Se non ricordo male, quando copiavo del testo dal web su writer, il documento iniziava ad adottare la codifica impiegata dalla pagina web, tipicamente ISO, poi aprendo il file su linux mi comparivano questi simboli.
L'ideale sarebbe che condividessi un documento che presenta questi errori e che chiarissi bene su che macchina stai lavorando al momento, windows o mac, e su che macchina è stato creato il documento in questione
LibO5.1.6.2-Ubuntu 16.04.2 32-bit
-
Se risolvi:
1. Condividi la soluzione qui con noi
2. Metti [Risolto] al titolo del primo messaggio
Avatar utente
unlucky83
Volontario
Volontario
 
Messaggi: 2229
Iscritto il: lunedì 7 gennaio 2013, 2:23
Località: Latina

Re: Problemi di formattazione del testo

Messaggioda unlucky83 » giovedì 7 dicembre 2017, 1:07

Din-Draug ha scritto:P.S. Credo possa centrare che spesso il documento non tiene la formattazione che gli assegno: tutto Times New Roman corpo 12, ma spuntano sempre fuori parti del documento in cui risulta Calibri 11 (mi pare)


Ciò capita quando non si modifica direttamente lo stile. Se lo stile "predefinito" adotta Calibri, quando scrivi un nuovo paragrafo riprende il font Calibri.
Se selezioni il testo e gli cambi il font, questa modifica riguarda il testo selezionato, ma lo stile "predefinito" continua ad adottare il Calibri. Per un effetto globale devi modificare lo stile.
Se crei un nuovo documento, hai lo stile "predefinito" con il font indicato nelle opzioni di openoffice...se non desideri il calibri ogni volta che crei un nuovo docomento devi cambiare le opzioni.
LibO5.1.6.2-Ubuntu 16.04.2 32-bit
-
Se risolvi:
1. Condividi la soluzione qui con noi
2. Metti [Risolto] al titolo del primo messaggio
Avatar utente
unlucky83
Volontario
Volontario
 
Messaggi: 2229
Iscritto il: lunedì 7 gennaio 2013, 2:23
Località: Latina

Re: Problemi di formattazione del testo

Messaggioda Din-Draug » giovedì 7 dicembre 2017, 1:21

Sospettavo potessero centrare gli Stili, ma non mi ci sono ancora messo a smanacciarci.
Quindi, poiché utilizzo sempre una serie di precise formattazioni (applicate manualmente) per testo, titoletti, titoloni, elenchi puntinati, conviene creare Stiri di Carattere/Paragrafo appropriati e usare quelli? O basta modificare il Predefinito, applicarlo e poi i vari grassetti, corsivi e allineamenti vi si mettono manualmente di volta in volta?... Non so', dico cose un po' così... :(

unlucky83 ha scritto:Mi limito ai "rombi neri con punto interrogativo" e ai semplici rettangolini. Compaiono quando c'è un errore nella codifica.
E' passato molto tempo da quando sono passato da windows a linux, in quella circostanza ho riscontrato parecchie volte, ma non sempre, errori di questi tipi.
Linux e Mac adottano la codifica utf-8, mentre windows la ISO...ciò può creare problemi se il file è stato salvato con codifica utf-8 e aperto su windows.
Se non ricordo male, quando copiavo del testo dal web su writer, il documento iniziava ad adottare la codifica impiegata dalla pagina web, tipicamente ISO, poi aprendo il file su linux mi comparivano questi simboli.
L'ideale sarebbe che condividessi un documento che presenta questi errori e che chiarissi bene su che macchina stai lavorando al momento, windows o mac, e su che macchina è stato creato il documento in questione


Allora... Molti documenti sono stati creati su un PC con Windows 7, usando Office Word (versione sconosciuta), poi ho spostato tutto su un portatile con Windows 7 e OpenOffice (aggiornato). Tutti i file sono in .RTF, se non altro per abitudine, era il formato che usavo a suo tempo su Mac - ma dovrebbe anche essere il più compatibile dei formati per file di testo.
Il fenomeno "ideogrammi-rombi interrogativi" finora è stato imprevedibile e ora non ho sotto mano un documento che non abbia conservato le correzioni. A volte ricapita, a volte no, e solo su alcuni documenti (probabilmente creati dal primo PC... probabilmente) e interessa solo parti del documento, mai tutto. Mi fa strano che i simbolini si ripresentano anche dopo essere stati copiati su un nuovo documento, forse perché
OpenOffice 4.1.4 / Windows 7
Din-Draug
 
Messaggi: 2
Iscritto il: mercoledì 6 dicembre 2017, 23:45

Re: Problemi di formattazione del testo

Messaggioda charlie » giovedì 7 dicembre 2017, 7:49

Ciao e benvenuto sul forum.
Se ti vuoi presentare puoi farlo qui: https://forum.openoffice.org/it/forum/v ... m.php?f=16
Per una panoramica delle regole del forum consulta il Manuale di sopravvivenza https://forum.openoffice.org/it/forum/v ... hp?f=1&t=2.

Ti prego di fare un uso moderato delle citazioni dei messaggi di chi ti risponde. Usale solo quando è necessario e in modo parziale (aggiungendo qualche .....). Ne guadagnerà la facilità di lettura dell'intero argomento.
charlie
macOS 10.12 Sierra: Open Office 4.1.7 - LibreOffice 6.2.8.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 6892
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: Problemi di formattazione del testo

Messaggioda unlucky83 » giovedì 7 dicembre 2017, 23:47

Cercando in rete delle info sul formato rtf, ho trovato molti messaggi in cui viene segnalato il problema dei quadratini e dei rombi quando questo genere di file viene aperto in un sistema operativo differente...principalmente quando lo si apre su windows. Non c'è nulla di chiaro e definitivo, ma anche in queste discussioni si da la colpa alla codifica ISO-8859-15 di windows che non è in grado di leggere i caratteri speciali (lettere accentate...), questo perchè su MAC il file rtf viene salvato con codifica utf-8.
In teoria gli editor come word e writer dovrebbero riconoscere la codifica corretta da impiegare...
vedi le "è" nel file allegato da me?

Potresti provare a modificare la prima linea del file rtf, in cui si specifica la codifica del file.
https://forum.openoffice.org/en/forum/v ... 19#p317023
Qui vengono messi a confronto i codici del file rtf salvato con word e con Aoo, il codice cambia parecchio e il punto cruciale è il primo rigo
{\rtf1\ansi\deff3\adeflang1025 è l'intestazione che assegnano Aoo e Libreoffice all'rtf salvato. Quando aprono un file rtf con questa intestazione, dovrebbero leggere tutto correttamente.

p.s.
apri il file rtf con blocco note per leggere il codice del file rtf.
Allegati
Senza nome 1.rtf
(2.69 KiB) Scaricato 93 volte
LibO5.1.6.2-Ubuntu 16.04.2 32-bit
-
Se risolvi:
1. Condividi la soluzione qui con noi
2. Metti [Risolto] al titolo del primo messaggio
Avatar utente
unlucky83
Volontario
Volontario
 
Messaggi: 2229
Iscritto il: lunedì 7 gennaio 2013, 2:23
Località: Latina


Torna a Writer

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite