Pannello di Controllo Moderatore ]

Problema con i font

Discussioni sull'applicazione di videoscrittura

Problema con i font

Messaggioda IsaacCasaubon96 » mercoledì 8 settembre 2021, 17:54

Salve a tutti: è il mio primo post su questo forum. Spero di scrivere tutto in modo giusto, secondo le vostre regole. Scusatemi ma io non sono un esperto di informatica: se sbaglio qualcosa perdonatemi.
Allora: io sto usando Open Office Writer versione 4.0.0 su Windows 64bit.
Sto scrivendo la mia tesi di laurea, e dovrei assolutamente scrivere dei testi in scrittura Brāhmī. Per farvi un'idea, potete andare alla pagina di Wikipedia inglese Heliodorus pillar, alla sezione "Inscriptions", nella seconda colonna della tabella.
Io non riuscivo NEANCHE a vedere quel testo in Brāhmī sulla pagina che vi ho appena citato. Ho seguito banalmente i consigli di Wikipedia e ho installato il font Noto Sans Brahmi, creato da Google. Ora riesco a vedere la scrittura sulla pagina che vi ho citato. MA, se io vado alla pagina di Wikipedia inglese Brahmi script e vado alla seconda tabella del paragrafo "Semitic model hypothesis", non riesco a vedere i simboli "Brahmi" nell'ultima colonna della seconda tabella! (non riesco nemmeno a vedere "Hieroglyphs" e "Aramaic".)
Inoltre non riesco nemmeno a copiare/incollare almeno i segni che riesco a leggere nella pagina Heliodorus pillar: già quando voglio incollarli su Google il computer mi mostra dei quadrati bianchi, vuoti (c'è il comando "Incolla" e poi c'è la serie di quadrati vuoti). Quando li incollo su Open Office Writer, compaiono punti interrogativi (?), quadrati bianchi e segni di scrittura cinese (credo, non so di che lingua siano).
Come posso fare per scrivere in Brāhmī? Non nascondo che a me pare più un problema del computer, non di Open Office Writer, però non so... Provate ad aiutarmi però, per favore... Vi ringrazio in anticipo.
(Scusatemi per i rimandi a Wikipedia, non voglio assolutamente spammare nulla.)

IsaacCasaubon96
Open Office 4.0.0
IsaacCasaubon96
 
Messaggi: 15
Iscritto il: mercoledì 8 settembre 2021, 17:14

Re: Problema con i font

Messaggioda charlie » mercoledì 8 settembre 2021, 21:38

Ciao e benvenuto/a sul forum.
Se intanto ti vuoi presentare, farai cosa gradita. Puoi farlo in questa sezione -> https://forum.openoffice.org/it/forum/viewforum.php?f=16

L’utente che apre un quesito si impegna:
In caso di inosservanza saremo costretti ad azioni di “richiamo”, sospensione o chiusura del profilo utente.

Buon proseguimento.
charlie
macOS 10.12 Sierra: Open Office 4.1.9 - LibreOffice 6.4.6.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 7655
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: Problema con i font

Messaggioda charlie » giovedì 9 settembre 2021, 11:06

Ciao, digitando "Brahmi" sui forum in inglese e francese di OO non esce niente :( .
Hai provato con Libre Office? non si sa mai ...
Anch'io penso che sia un problema di sistema operativo del computer.
charlie
macOS 10.12 Sierra: Open Office 4.1.9 - LibreOffice 6.4.6.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 7655
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: Problema con i font

Messaggioda lucky63 » sabato 18 settembre 2021, 11:34

IsaacCasaubon96 ha scritto:se io vado alla pagina di Wikipedia inglese Brahmi script e vado alla seconda tabella del paragrafo "Semitic model hypothesis", non riesco a vedere i simboli "Brahmi" nell'ultima colonna della seconda tabella! (non riesco nemmeno a vedere "Hieroglyphs" e "Aramaic".)

Potrebbe dipendere da un errore di decodifica da “Unicode”, “UTF-8” a “HTML” di cui chi ha elaborato la pagina wikipedia non si è accorto/a.

IsaacCasaubon96 ha scritto:non riesco nemmeno a copiare/incollare almeno i segni che riesco a leggere nella pagina Heliodorus pillar:

la pagina è molto ampia e non è chiaro/facile capire a cosa ti riferisci ...

IsaacCasaubon96 ha scritto:Sto scrivendo la mia tesi di laurea, e dovrei assolutamente scrivere dei testi in scrittura Brāhmī.
IsaacCasaubon96 ha scritto:Come posso fare per scrivere in Brāhmī?

Hai provato usando/applicando un font Brāhmī ? (Clicca sull'immagine per ingrandirla)

Test - Scrittura in alfabeto Brāhmī.png

.
Avatar utente
lucky63
Volontario assiduo
Volontario assiduo
 
Messaggi: 2652
Iscritto il: martedì 18 maggio 2010, 17:01

Re: Problema con i font

Messaggioda IsaacCasaubon96 » giovedì 23 settembre 2021, 23:42

Scusatemi per il ritardo nella risposta. Scusatemi ma non sono capace di citare, quindi userò le virgolette.
 Editato: Soppressa citazione non necessaria (admin) 

Come avevo già scritto, "ho installato il font Noto Sans Brahmi, creato da Google". Tuttavia, quando lo ho installato e ho cliccato per vedere effettivamente come erano i caratteri che offriva, non mi sono apparsi i simboli che invece sono presenti nella Sua immagine. C'erano solo caratteri normali in latino (come A a, B b, C c etc.)
Open Office 4.0.0
IsaacCasaubon96
 
Messaggi: 15
Iscritto il: mercoledì 8 settembre 2021, 17:14

Re: Problema con i font

Messaggioda IsaacCasaubon96 » venerdì 24 settembre 2021, 23:15

(Non so perché l'admin abbia cancellato 2 mie citazioni: non avevo scritto nulla di male o di offensivo, davvero.)
Open Office 4.0.0
IsaacCasaubon96
 
Messaggi: 15
Iscritto il: mercoledì 8 settembre 2021, 17:14

Re: Problema con i font

Messaggioda charlie » sabato 25 settembre 2021, 11:13

charlie
macOS 10.12 Sierra: Open Office 4.1.9 - LibreOffice 6.4.6.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 7655
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: Problema con i font

Messaggioda lucky63 » domenica 26 settembre 2021, 10:08

.
Ti allego il font utilizzato per la mia prova nell'esempio precedente.

Font.png

Per poterlo caricare sul forum ho dovuto rinominarlo cambiandone l'estensione in .zip
Una volta scaricato devi rinominarlo nuovamente cambiandone l'estensione da .zip a .ttf (che è la corretta estensione per i fonts caratteri "True Type Font") e installarlo.
.

.
Allegati
BrahmiRomani-6qvq.zip
(32.46 KiB) Scaricato 8 volte
Avatar utente
lucky63
Volontario assiduo
Volontario assiduo
 
Messaggi: 2652
Iscritto il: martedì 18 maggio 2010, 17:01

Re: Problema con i font

Messaggioda IsaacCasaubon96 » domenica 26 settembre 2021, 16:44

Ti ringrazio tantissimo, ma non riesco ad aprire il file che hai messo. Mi appare un messaggio che dice "The archive is either in unknown format or is damaged".
Open Office 4.0.0
IsaacCasaubon96
 
Messaggi: 15
Iscritto il: mercoledì 8 settembre 2021, 17:14

Re: Problema con i font

Messaggioda lucky63 » domenica 26 settembre 2021, 18:04

IsaacCasaubon96 ha scritto:Mi appare un messaggio che dice "The archive is either in unknown format or is damaged"

Molto probabilmente perché hai omesso di rinominare il file da .zip a .ttf come ti avevo detto di fare.
.
Ho provato a scaricarlo. Rinominato. Doppio click sul file. Ecco il risultato (lavoro con sistema operativo linux):

Font.png

.
Avatar utente
lucky63
Volontario assiduo
Volontario assiduo
 
Messaggi: 2652
Iscritto il: martedì 18 maggio 2010, 17:01

Re: Problema con i font

Messaggioda IsaacCasaubon96 » lunedì 27 settembre 2021, 2:20

Allora: io non avevo capito che rinominare il file significasse proprio cambiare il suo formato, il suo tipo.
Ho fatto e funziona, La ringrazio.
Tuttavia, non so se mettere [Risolto] anche a questo topic: secondo me il problema è del mio sistema, non di Office...
Perché il mio computer legge il font che Lei mi ha inviato ma quello che io avevo installato no?
Non so.
Open Office 4.0.0
IsaacCasaubon96
 
Messaggi: 15
Iscritto il: mercoledì 8 settembre 2021, 17:14

Re: Problema con i font

Messaggioda lucky63 » lunedì 27 settembre 2021, 9:57

IsaacCasaubon96 ha scritto:funziona

OK
IsaacCasaubon96 ha scritto:Perché il mio computer legge il font che Lei mi ha inviato ma quello che io avevo installato no?

Da questo link ho scaricato il file compresso del font "Noto Sans Brahmi" creato da Google che hai indicato inizialmente.
Scompattato il file .zip e installato il file "NotoSansBrahmi-Regular.ttf".
Sia OpenOffice quanto LibreOffice lo vedono disponibile in elenco ma utilizzandolo direttamente da tastiera NON ho riscontro.
Il font sembra non essere stato "Mappato" associandolo ai caratteri della tastiera.
Sulla mia postazione (Linux) risulta gestibile unicamente con l'inserimento quale "carattere speciale" ... da Menu > Inserisci > Carattere speciale (vedi immagine):

Font.png

Non ti so dire il perché di tale scelta.
.
.
Avatar utente
lucky63
Volontario assiduo
Volontario assiduo
 
Messaggi: 2652
Iscritto il: martedì 18 maggio 2010, 17:01


Torna a Writer

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti