Pagina 1 di 1

base - scorrimento barra laterale

MessaggioInviato: mercoledì 19 aprile 2017, 21:28
da maremmanogr
buongiorno a tutti,
premetto configurazioni:
win 10 e OpenOffice 3.4
win 7 e OpenOffice 3.4
Ubuntu 16.4 LTS e OpenOffice 3.4
ho voluto premettere le configurazioni perché il problema si presenta in ognuna di esse.
quando apro una tabella in Base per guardare gli inserimenti e faccio scorrere la barra laterale, ad un certo punto tutti i record prendono lo stesso nome (e i dati) per cui non ha piu' senso lo scroll della tabella e devo uscire e rientrare nella tabella. Anche scorrendo piano piano i record si presenta il problema anche se in modo minore. la cosa e' irritante anche se con pazienza si puo' fare la lettura che interessa.
Esempio: ho la tabella libri con circa 950 record e se mi accorgo di errori di inserimento sono costretto ad aprirla e scorrere tutti i record, a parte il fatto che quando il cursore della barra laterale arriva in fondo devo ritornare un po' piu' sopra per permettere lo scroll dei record successivi, e cosi' facendo mi ritrovo con la sostituzione dei record in modo random con i dati di un qualsiasi record della videata.
spero di essere stato chiaro nella esposizione e vi ringrazio per l'aiuto che mi potrete dare

maremmanogr

Re: base - scorrimento barra laterale

MessaggioInviato: mercoledì 19 aprile 2017, 22:29
da charlie
Ciao, lavori con le macro? Il problema assomiglia un po' a questo
https://forum.openoffice.org/it/forum/v ... cro#p26455

Poi, perchè una vecchia versione do OO? Hai provato con una più recente?

Re: base - scorrimento barra laterale

MessaggioInviato: mercoledì 19 aprile 2017, 22:39
da maremmanogr
no, in questo database non uso macro.
avevo provato anche la versione piu' recente ma il problema restava, per cui ho preferito ritornare sulla versione solida.
guardero' il link che mi hai inviato e se del caso mettero' una videata con la tabella da correggere
grazie per ora
maremmanogr

Re: base - scorrimento barra laterale

MessaggioInviato: mercoledì 19 aprile 2017, 22:49
da maremmanogr
il link non riguarda il mio problema.
allego una videata del problema
grazie
maremmanogr

Re: base - scorrimento barra laterale

MessaggioInviato: mercoledì 19 aprile 2017, 23:20
da charlie
Forse assomiglia di più a questo che avevo segnalato qui https://forum.openoffice.org/en/forum/v ... 68#p309868. Mi era stato detto trattarsi di un bug conosciuto, ma non ho approfondito.

Re: base - scorrimento barra laterale

MessaggioInviato: giovedì 20 aprile 2017, 9:46
da maremmanogr
ho letto il post e credo di aver capito che il problema si presenti quando un ID e' settato ad autoincremento =SI, un bug che mi sembra prioritario da risolvere. un ID non autoincrementato sai i problemi che puo' provocare, magari quando per una ricerca usi uno dei campi in ordine alfabetico e poi ti dimentichi di riorganizzare secondo l'ID, mi vengono i brividi solo a pensarci.
io invece avevo pensato ad una cache troppo esigua per cui,diciamo, i record in scroll si accavallano e mandano in tilt il refresh del video. dico bischerate?
grazie
filiberto

Re: base - scorrimento barra laterale

MessaggioInviato: giovedì 20 aprile 2017, 10:14
da charlie
Al di là della constatazione della presenza del problema con ID con incremento automatico (non so immaginare database senza, ma il bug è ancora presente con OO 4.3.1 mentre non c'è con LO)), avevo pensato anch'io ad un problema con la scheda grafica.

Re: base - scorrimento barra laterale

MessaggioInviato: giovedì 20 aprile 2017, 12:11
da maremmanogr
provero' ad installare per l'ennesima volta LO, anche se nn mi aveva molto convinto come stabilita' sotto win10 per cui ero ritornato a OO 3.4.
grazie comunque per la tua pazienza
filiberto

PS: non metto RISOLTO, sperando che qualcuno prima o poi trovi la soluzione