Pannello di Controllo Moderatore ]

[Risolto] LibreOffice 7.1.6.2 still non si avvia

Discussioni sui problemi di installazione e configurazione

[Risolto] LibreOffice 7.1.6.2 still non si avvia

Messaggioda markinson » martedì 14 settembre 2021, 18:41

Salve a tutti! :)

Ai miei annosi dilemmi, causa la mia impreparazione, con Base, purtroppo stasera ho aggiunto i guai con l'ultima release di LibreOffice still, la versione 7.1.6.2, che non si avvia su due dei tre elaboratori a mia disposizione.

Devo dire che questo fenomeno affligge due vecchi portatili e non l'elaboratore più recente.
Se provo ad avviare LibreOffice in modalità provvisoria, il programma parte regolarmente. Ho tentato varie soluzioni (tra cui disattivare l'accelerazione hardware, piuttosto che il ripristino del profilo), senza ottenere alcun esito positivo.

Ovviamente ho rimosso e reinstallato la suite, in entrambi i portatili, ma niente da fare.

Alla fine ho ripiegato sulla "vecchia" versione 7.0.6.2 e tutto è tornato regolarmente a funzionare.

Mi sembra di non essere l'unico ad aver avuto problemi con l'ultima 7.1.6.2, infatti:

Qualche suggerimento?

Grazie in anticipo!

---EDIT---
Ho trovato questo bug: Bug 144434 - LibreOffice 7.1.6.2 fails to start if Skia is enabled.
Non so tuttavia se si applica al mio caso, non ho avuto ancora tempo di provare, purtroppo.
Ultima modifica di charlie il mercoledì 15 settembre 2021, 18:18, modificato 2 volte in totale.
Motivazione: Aggiunta ✔ verde.
OpenOffice 4.1.10 / LibreOffice 7 still - Windows 10 Pro x64
"Facesti come quei che va di notte, che porta il lume dietro e sé non giova, ma dopo sé fa le persone dotte"
Dante (Purgatorio, Canto XXII)
Avatar utente
markinson
 
Messaggi: 114
Iscritto il: mercoledì 24 giugno 2020, 15:18

Re: LibreOffice 7.1.6.2 still non si avvia

Messaggioda charlie » mercoledì 15 settembre 2021, 8:54

Ciao, da quello che ho capito Skia dovrebbe essere Open CL.
charlie
macOS 10.12 Sierra: Open Office 4.1.9 - LibreOffice 6.4.6.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 7657
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: LibreOffice 7.1.6.2 still non si avvia

Messaggioda markinson » mercoledì 15 settembre 2021, 11:29

Grazie ancora una volta, charlie! Vieni sempre in mio soccorso! :)

Credo di aver capito che potrebbe essere qualcosa legato ai driver delle vecchie schede video che montano i miei due portatili e dunque, dovrei provare a intervenire proprio su Skia-OpenGL, stante che l'accelerazione hardware è già disabilitata.

Tenterò e farò sapere, spero a breve.

Se possibile, legato a questo aspetto, non riesco a capire quale sia l'ultima versione stabile, cosiddetta "still" (sbaglio?), di LibreOffice: è la 7.1.6.2? Oppure la 7.1.6.2 è la versione ancora di "testing", cosiddetta "fresh"?

Se vado alla fonte dell'archivio dei download di LibreOffice, QUI, trovo:
LibreOffice_000.jpg
LibreOffice_000.jpg (49.43 KiB) Osservato 504 volte


Scegliendo la sezione "stable" ottengo:
LibreOffice_001_Stable.jpg
LibreOffice_001_Stable.jpg (37.95 KiB) Osservato 504 volte


Mentre andando sotto "testing" trovo:
LibreOffice_002_Test.jpg
LibreOffice_002_Test.jpg (36.72 KiB) Osservato 504 volte


Insomma, c'è la versione "7.1.6 - 09-Sep-2021 09:32" dentro "stable" e anche la release "7.1.6 - 09-Sep-2021 09:25" all'interno di "testing" ... inoltre, sempre contenuta in "stable", trovo l'edizione "7.2.0 - 19-Aug-2021 09:23", ma del 19 agosto! ... sto perdendo l'orientamento ... in definitiva: qual è l'ultima versione "stable - still" che posso impiegare? Quella scaricabile dal sito sotto "Download - LibreOffice Still"? Cioè la 7.1.6?
OpenOffice 4.1.10 / LibreOffice 7 still - Windows 10 Pro x64
"Facesti come quei che va di notte, che porta il lume dietro e sé non giova, ma dopo sé fa le persone dotte"
Dante (Purgatorio, Canto XXII)
Avatar utente
markinson
 
Messaggi: 114
Iscritto il: mercoledì 24 giugno 2020, 15:18

Re: LibreOffice 7.1.6.2 still non si avvia

Messaggioda charlie » mercoledì 15 settembre 2021, 16:11

Io vedo questo, e mi basta :D .
Allegati
Schermata 2021-09-15 alle 16.09.49.png
charlie
macOS 10.12 Sierra: Open Office 4.1.9 - LibreOffice 6.4.6.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 7657
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: LibreOffice 7.1.6.2 still non si avvia

Messaggioda markinson » mercoledì 15 settembre 2021, 16:21

:lol: :lol: :lol:
Era l'unico collegamento che, tra i tanti, non avevo messo e l'hai beccato tu!

Adesso sto facendo qualche prova, per vedere se riesco a trovare il modo di installare l'ultima versione "still", la 7.1.6.2, sulle mie vecchie macchine ... ;)
OpenOffice 4.1.10 / LibreOffice 7 still - Windows 10 Pro x64
"Facesti come quei che va di notte, che porta il lume dietro e sé non giova, ma dopo sé fa le persone dotte"
Dante (Purgatorio, Canto XXII)
Avatar utente
markinson
 
Messaggi: 114
Iscritto il: mercoledì 24 giugno 2020, 15:18

Re: LibreOffice 7.1.6.2 still non si avvia

Messaggioda markinson » mercoledì 15 settembre 2021, 16:59

Eureka! :)

Prendendo spunto da quanto segnalato nel Bug 144434 - LibreOffice 7.1.6.2 fails to start if Skia is enabled. e, soprattutto, cercando di decifrare (opera sempre ardua per me) dalla lingua inglese, sono riuscito a far funzionare l'ultima edizione still 7.1.6.2 sui miei vecchi portatili!

Praticamente mi sono concentrato su questo:
Steps to Reproduce:
Scenario 1 :
[...]

Scenario 2 :
[...]

Scenario 3 :
1. Clean install of LibreOffice 7.1.5.2.
2. Start LibreOffice.
Verify that the following option is checked (enabled) by default.
Tools/Options/LibreOffice/View/'Use Skia for all rendering'
3. Disable (uncheck) Skia in the following option.
Tools/Options/LibreOffice/View/'Use Skia for all rendering'
4. Stop LibreOffice.
5. Update LibreOffice with 7.1.6.2.
6. Start LibreOffice.
Verify that the following option is unchecked (disabled).
Tools/Options/LibreOffice/View/'Use Skia for all rendering'

Scenario 4 :
[...]

[...]

Scenario 3 : LibreOffice 7.1.6.2 starts properly.
[...]


Nel mio caso la strada è stata, per la versione a 64bit (scusate, lo preciso solo ora) e per entrambi i portatili, la seguente:
  1. installazione dell'ultima versione still sicuramente funzionante, ossia la 7.0.6.2;
  2. lancio della suite LibreOffice e, sotto "Strumenti - Opzioni - Vista", deselezionata la voce "Usa Skia per tutti i rendering";
  3. come richiesto, riavviato la suite;
  4. di nuovo posizionato sotto "Strumenti - Opzioni - Vista", deselezionata la voce "Usa accelerazione hardware" (che dopo la disattivazione di Skia si era automaticamente attivata);
  5. installata, sopra la precedente, la versione 7.1.6.2;
  6. verifica che l'icona sul desktop di LO fosse quella "standard" e lancio della suite che finalmente si apre!

Non credo che possa essere d'aiuto a molti, perché immagino che vecchi catorci come i miei siano rari da trovare, però ... chissà! ;)
OpenOffice 4.1.10 / LibreOffice 7 still - Windows 10 Pro x64
"Facesti come quei che va di notte, che porta il lume dietro e sé non giova, ma dopo sé fa le persone dotte"
Dante (Purgatorio, Canto XXII)
Avatar utente
markinson
 
Messaggi: 114
Iscritto il: mercoledì 24 giugno 2020, 15:18


Torna a Installazione e risoluzione problemi

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti