Pannello di Controllo Moderatore ]

Problema filtro ascii ma con esiti diversi dal solito

Discussioni sui problemi di installazione e configurazione

Problema filtro ascii ma con esiti diversi dal solito

Messaggioda Manolo Zwei » giovedì 29 luglio 2021, 22:07

Debbo ahimé accodarmi a quanti hanno disperatamente chiesto numi e aiuti per il famigerato problema filtro ascii.
Il mio presenta anomalie tali da indurmi a sospettare di avere l'hd invaso da poltergeist, gremlins e slime ghostbustersiani...

in buona sostanza è accaduto quel che accade a chiunque l'abbia segnalato (ovvero alla riapertura di un file odt di OpenOffice 4.1.6 - installato su windows 8.1- è apparsa una finestra di controllo codice ascii. dando l'ok il file si riapre, ma con la pessima sorpresa del testo sostituito per intero da una miriade di soli cancelletti).

la prima cosa anomala (e decisamente la più assurda) è che tre giorni prima avevo deciso di acquistare un nuovo hd esterno per salvare tutti i file di lettura e scrittura, proprio per preservarli dal ripetersi di accidenti simili. ebbene, pur avendolo là copiato proprio per averne una copia integra in caso di corruzioni su pc, mi risulta parimenti corrotto anche se provo ad aprirlo da hd esterno, e ciò malgrado fino a ieri notte fosse leggibile su pc! :shock: :crazy:

le altre differenze sostanziali e credo di un certo peso dalla volta scorsa:

1) a quanto leggo il motivo scatenante di questa miriadi di binari zero sotto forma di cancelletti è un arresto anomalo, un crash, un'interruzione di batteria o corrente col file ancora aperto e non salvato.
niente di tutto questo. la sera prima si leggeva sia da pc che da hd e il pomeriggio seguente all'avvio mi è apparso il codice ascii.

2) rispetto alla volta scorsa, sia a odt chiuso che aperto mi appare un file omonimo semi-trasparente (la cui icona è quella dei file txt o srt) tranne per un prefisso ".~lock." e un suffisso col cancelletto

3) la volta scorsa il file, una volta corrottosi, era notevolmente diminuito di peso, passando da qualche mega a pochi kb, questa volta è rimasto identico. come identico è rimasto il numero di pagine (9)

ma soprattutto:

4) la volta scorsa non avevo impostato "esegui sempre il back up", stavolta sono certissimo che ci fosse. c'è solo che la directory per accedervi e annessa modalità di recupero file mi sono oscure. ho provato a cercare di capire il da farsi, invano. :roll:

provo ad allegarvelo, anche se con una pietra al collo - temo di conoscere già gli esiti... :( grazie comunque di cuore per l'eventuale tentativo..

frattanto, dato che nemmeno spostare i files su hd ext è più qualcosa di sicuro, ho fatto (e da oggi sempre farò) copia odt, doc e txt di tutti i file di lettura e scrittura, e per quanto seccante e cronologicamente dispendioso sia, raccomando a tutti di fare altrettanto con i file particolarmente importanti. se ne deteriora una, il testo è comunque salvo altrove in un'altra forma.
;)
Allegati
BRANDAVINEW.odt
(35.54 KiB) Scaricato 10 volte
OpenOffice 4.6.1 su Windows 8.1
Manolo Zwei
 
Messaggi: 8
Iscritto il: giovedì 29 luglio 2021, 21:40

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda charlie » venerdì 30 luglio 2021, 6:47

Ciao,
Manolo Zwei ha scritto:2) rispetto alla volta scorsa, sia a odt chiuso che aperto mi appare un file omonimo semi-trasparente (la cui icona è quella dei file txt o srt) tranne per un prefisso ".~lock." e un suffisso col cancelletto

I file .~lock, temporanei e normalmente nascosti, si formano in automatico ad ogni apertura del file originario e scompaiono alla chiusura. La presenza permanente, sta ad indicare una chiusura "traumatica" non corretta che può aver originato il problema (anche se non lo spiega).
Comunque, esaminando il file con un tool che trovi anche nel forum, l'esito è infausto.


Codice: Seleziona tutto   Espandi visualeStringi visuale
File BRANDAVINEW.odt :

   ***

Analisi :
Ricerca di byte nulli ...
36389 i byte sono stati letti.
36389 sono stati trovati byte nulli.

QUESTO FILE CONTIENE SOLO BYTES NULLI!
L'analisi non e' riuscita!
charlie
macOS 10.12 Sierra: Open Office 4.1.9 - LibreOffice 6.4.6.2
http://www.charlieopenoffice.altervista.org
Avatar utente
charlie
Site Admin
Site Admin
 
Messaggi: 7611
Iscritto il: mercoledì 19 dicembre 2012, 11:50

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda lucky63 » venerdì 30 luglio 2021, 13:03

Manolo Zwei ha scritto:la volta scorsa non avevo impostato "esegui sempre il back up", stavolta sono certissimo che ci fosse. c'è solo che la directory per accedervi e annessa modalità di recupero file mi sono oscure. ho provato a cercare di capire il da farsi, invano


Menu > Strumenti > Opzioni > OpenOffice/LibreOffice > Percorsi > Copie di sicurezza (o BackUp a seconda delle versioni).

Trovi indicato il percorso della cartella contenete i file che ti interessano.

Tramite il file manager del tuo sistema operativo ti porti in quella cartella.

In tale cartella trovi la copia di sicurezza dei file.
Hanno lo stesso nome di quelli che hai salvato normalmente ma con estensione .bak.
Sposta quel file sul desktop o altra cartella cambiando poi l'estensione del file da .bak con quella del formato che ti interessa (Writer/Calc/…).
Apri il file.
.
Avatar utente
lucky63
Volontario assiduo
Volontario assiduo
 
Messaggi: 2631
Iscritto il: martedì 18 maggio 2010, 17:01

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda Manolo Zwei » venerdì 30 luglio 2021, 21:23

charlie ha scritto:Ciao,
Manolo Zwei ha scritto:2) rispetto alla volta scorsa, sia a odt chiuso che aperto mi appare un file omonimo semi-trasparente (la cui icona è quella dei file txt o srt) tranne per un prefisso ".~lock." e un suffisso col cancelletto

I file .~lock, temporanei e normalmente nascosti, si formano in automatico ad ogni apertura del file originario e scompaiono alla chiusura. La presenza permanente, sta ad indicare una chiusura "traumatica" non corretta che può aver originato il problema (anche se non lo spiega)


questo non solo non scompare alla chiusura e se ne sta lì inchiodato beffardo a spernacchiarmi, ma oggi è magicamente apparso anche nelle versione anteriore omonima di un anno e mezzo fa del documento. di peso e contenuto differenti, presente dentro la chiavetta. e semplicemente aprendo la cartella che la conteneva. stava lì già da prima che aprissi il file. la volta prima (il danno era già avvenuto) non c'era. la sola differenza è che non mi ha neutralizzato l'odt e ho fatto in tempo a copiarne il contenuto rinominandolo... perché? e a questo punto: che roba è??
ma soprattuttissimo: com'è possibile che la copia salvata su hd esterno (non lesa al momento del trasferimento) risulti ora danneggiata a posteriori? :evil:
in ogni caso non ci sono state, prima di chiudere il pc, circostanze anomale di alcun genere prima della chiusura del file. per cui mi ha detto proprio rogna nerissima. anche perché avevo acquistato l'hd ext soprattutto per evitare una sorte simile a quel file.

che immaginavo del resto irrecuperabile al 99%. provo a vedere se lo trovo backuppato, ma temo proprio di no. grazie mille lo stesso.

il menù della directory che mi hai fornito indica lo start del pc o fa capo all'icona di openoffice?
OpenOffice 4.6.1 su Windows 8.1
Manolo Zwei
 
Messaggi: 8
Iscritto il: giovedì 29 luglio 2021, 21:40

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda Manolo Zwei » venerdì 30 luglio 2021, 21:53

lucky63 ha scritto:
Manolo Zwei ha scritto:la volta scorsa non avevo impostato "esegui sempre il back up", stavolta sono certissimo che ci fosse. c'è solo che la directory per accedervi e annessa modalità di recupero file mi sono oscure. ho provato a cercare di capire il da farsi, invano


Menu > Strumenti > Opzioni > OpenOffice/LibreOffice > Percorsi > Copie di sicurezza (o BackUp a seconda delle versioni).

Trovi indicato il percorso della cartella contenete i file che ti interessano.

Tramite il file manager del tuo sistema operativo ti porti in quella cartella.

In tale cartella trovi la copia di sicurezza dei file.
Hanno lo stesso nome di quelli che hai salvato normalmente ma con estensione .bak.
Sposta quel file sul desktop o altra cartella cambiando poi l'estensione del file da .bak con quella del formato che ti interessa (Writer/Calc/…).
Apri il file.
.


questa le batte davvero tutte. trovato il BAK. lo copio su desktop, lo rinomino in odt e indovina un po'? parte di nuovo il controllo codice ascii con annessi cancelletti. ho provato anche a cambiare nome al documento, stessa cosa. eppure è il file di backup! e ora?
OpenOffice 4.6.1 su Windows 8.1
Manolo Zwei
 
Messaggi: 8
Iscritto il: giovedì 29 luglio 2021, 21:40

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda lucky63 » venerdì 30 luglio 2021, 23:09

Manolo Zwei ha scritto:parte di nuovo il controllo codice ascii con annessi cancelletti. ho provato anche a cambiare nome al documento, stessa cosa. eppure è il file di backup! e ora?


Di prassi il file .bak corrisponde alla copia del file di lavoro relativo al precedente salvataggio.
Ad ogni salvataggio del file di lavoro viene sovrascritto il file .bak.
Il file .bak non contiene quindi le ultime modifiche fatte.

Prova il ripristino di altri file .bak e vedi se hanno tutti lo stesso problema.
Crea nuovo file di test e salvalo un paio di volte sul disco interno del pc (No Pendrive o Hd esterno) e poi verifica il file .bak.

Valuta se resettare il profilo utente e/o fare una nuova installazione di OpenOffice/LibreOffice.

Consiglio di lavorare sempre e solo sui file nel disco interno del computer e per ogni file di lavoro creato/modificato farne copia a fine giornata su altri supporti.

Io ho abbandonato Windows dai tempi di XP e lavorando con linux non ricordo di aver mai avuto problemi di file “danneggiati” (...cancelletti...) alla loro apertura.
Sulla mia postazione i file .bak opportunamente rinominati vengono aperti correttamente.
Avatar utente
lucky63
Volontario assiduo
Volontario assiduo
 
Messaggi: 2631
Iscritto il: martedì 18 maggio 2010, 17:01

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda Manolo Zwei » sabato 31 luglio 2021, 1:25

lucky63 ha scritto:Di prassi il file .bak corrisponde alla copia del file di lavoro relativo al precedente salvataggio.
Ad ogni salvataggio del file di lavoro viene sovrascritto il file .bak.
Il file .bak non contiene quindi le ultime modifiche fatte.


difatti l'ultima modifica del .bak risale al 25 luglio. a me l'odt si è danneggiato il 29. e quando l'ho trasferito su supporto esterno (il 27) andava ancora benissimo (ripeto, la cosa più strana di tutte è che il file trasferito si sia danneggiato in tandem a posteriori). per cui in teoria dovrebbe aprirmisi.
epperò se lo copio su desktop e rinomino non cambia nulla. ho provato anche altre estensioni, come txt o doc, il file aperto risulta in quel caso vuoto. non so forse sbaglio a fare dei copiaincolla, ma non mi fido a spostarlo perché ho paura di danneggiare l'unica copia che può farmi da salvacondotto.

>>>Prova il ripristino di altri file .bak e vedi se hanno tutti lo stesso problema.
Crea nuovo file di test e salvalo un paio di volte sul disco interno del pc (No Pendrive o Hd esterno) e poi verifica il file .bak.


fatto. si riaprono tutti tranne questo e quello che mi si danneggiò l'anno scorso, il cui bak ignoravo di avere..!! o meglio si riaprono ma chiedendo il codice ascii e poi dando i binari zero.
la differenza tra i due sta nel peso. quello della volta scorsa diminuì di parecchio, questo è rimasto inalterato.

la butto lì: se ti passassi copia del bak e provassi a cambiargli estensione tu, non importa quale, e a contenuto eventualmente ripescato mi passassi a tua volta tutto in odt o via mail??
OpenOffice 4.6.1 su Windows 8.1
Manolo Zwei
 
Messaggi: 8
Iscritto il: giovedì 29 luglio 2021, 21:40

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda lucky63 » sabato 31 luglio 2021, 9:24

.
Hai provato la procedura indicata a questo link.

Allega comunque una copia del file .bak interessato per chi volesse fare altri tentativi.

Come ultima possibilità valuta tentativo utilizzo programma recupero dati su disco fisso.

Non è chiaro se hai lo stesso problema anche con gli altri .bak (anche nuovi di recente creazione seguito test).
Avatar utente
lucky63
Volontario assiduo
Volontario assiduo
 
Messaggi: 2631
Iscritto il: martedì 18 maggio 2010, 17:01

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda Manolo Zwei » sabato 31 luglio 2021, 20:28

lucky63 ha scritto:.
Hai provato la procedura indicata a questo link.

Allega comunque una copia del file .bak interessato per chi volesse fare altri tentativi.

Come ultima possibilità valuta tentativo utilizzo programma recupero dati su disco fisso.

Non è chiaro se hai lo stesso problema anche con gli altri .bak (anche nuovi di recente creazione seguito test).


Sì, già provato a scaricare quel programma, vanamente. a circa metà dl parte un messaggio di errore circa non ricordo più quale file mancante e si interrompe.
no: come sopra, tutti gli altri bak si aprono regolarmente questo no, pur presentando come data di ultima modifica il 25, cioè antecedente di 4 giorni quella del file corrottosi. per cui, secondo logica, il contenuto dovrebbe essere integro.
provo ad allegarlo...

EDIT: provato ad allegare il bak. L’estensione bak non è permessa.
OpenOffice 4.6.1 su Windows 8.1
Manolo Zwei
 
Messaggi: 8
Iscritto il: giovedì 29 luglio 2021, 21:40

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda lucky63 » sabato 31 luglio 2021, 21:18

Manolo Zwei ha scritto:provato ad allegare il bak. L’estensione bak non è permessa.

Ti bastava cambiare estensione del file da .bak a .ods e indicare nel testo della risposta che era quel file.
.
Avatar utente
lucky63
Volontario assiduo
Volontario assiduo
 
Messaggi: 2631
Iscritto il: martedì 18 maggio 2010, 17:01

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda Manolo Zwei » sabato 31 luglio 2021, 21:34

lucky63 ha scritto:
Manolo Zwei ha scritto:provato ad allegare il bak. L’estensione bak non è permessa.

Ti bastava cambiare estensione del file da .bak a .ods e indicare nel testo della risposta che era quel file.
.


provvedo subito. questo che trovi allegato è il bak esteso in odt.
a giudicare dall'icona che vedo su desktop non è cambiato molto. attendo tue...
Allegati
BRANDAVINEW.odt
(35.52 KiB) Scaricato 5 volte
OpenOffice 4.6.1 su Windows 8.1
Manolo Zwei
 
Messaggi: 8
Iscritto il: giovedì 29 luglio 2021, 21:40

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda lucky63 » sabato 31 luglio 2021, 22:32

Mi spiace ma il file è andato.
Con gli strumenti che conosco non risulta recuperabile.
-----------------------------------------------------------
End-of-central-directory signature not found.
Either this file is not a zipfile, or it constitutes one disk of a multi-part archive.
In the latter case the central directory and zipfile comment will be found on the last disk(s) of this archive.
... ossia ...
Firma di fine directory centrale non trovata.
Questo file non è un file zip oppure costituisce un disco di un archivio multiparte.
In quest'ultimo caso la directory centrale e il commento del file zip si troveranno sull'ultimo disco o sugli ultimi dischi di questo archivio.
-----------------------------------------------------------
File BRANDAVINEW.odt :

***

Analisi :
Ricerca di byte nulli ...
36377 i byte sono stati letti.
36377 sono stati trovati byte nulli.

QUESTO FILE CONTIENE SOLO BYTES NULLI!
L'analisi non e' riuscita!

Apri un altro file o esci.
-----------------------------------------------------------
Avatar utente
lucky63
Volontario assiduo
Volontario assiduo
 
Messaggi: 2631
Iscritto il: martedì 18 maggio 2010, 17:01

Re: Problema filtro ascii ma con esiti diversi dal solito

Messaggioda Manolo Zwei » sabato 31 luglio 2021, 22:35

lo immaginavo. avevo già provato ad aprirlo con ogni possibile tipo di estensione (srt, doc, odt, etc)
grazie lo stesso. ora, per quel che serve, resta da capire perché sia andato a scoppio ritardato anche quello salvato su hd ext giorni prima che si danneggiasse l'originale...
OpenOffice 4.6.1 su Windows 8.1
Manolo Zwei
 
Messaggi: 8
Iscritto il: giovedì 29 luglio 2021, 21:40


Torna a Installazione e risoluzione problemi

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite