Pannello di Controllo Moderatore ]

Legatura caratteri - FI appare legato se salvo in pdf

Discussioni sull'applicazione di videoscrittura

Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda Azzurra » sabato 5 febbraio 2011, 3:41

Ciao a tutti,
sono nuova del forum... perché, fortunatamente, finora non ho mai avuto bisogno di un aiuto... Ma ora sono nei guai! Guai seri!
Ho un problema con un file di testo per il quale ho speso mesi di lavoro, saranno cinquecento pagine... e proprio ora che ho finito, spunta qualcosa che sembra irresolvibile!

Il punto è: se faccio un file testo (font Palatino Linotype) e salvo in .odt, i caratteri sono normali e sono spaziati normalmente. Quando però salvo lo stesso file in .pdf (perché mi servono diversi pdf separati) allora si sballa la visualizzazione e ogni volta che compaiono i due caratteri "f" e "i" l'uno di seguito all'altro, sono attaccatissimi, talmente tanto che nella stampa non si distinguono nemmeno più. E ovviamente, così com'è, il lavoro lo dovrei buttare e ricominciare da capo!!!

Qualcuno sa aiutarmi? Ho cercato anche in rete, e qui in giro nei vari argomenti, ma pare non esserci nulla al riguardo...
Vorrei soltanto che la creanatura o legatura (non ho capito bene come si chiama lo spazio tra le lettere, in senso orizzontale) restasse la medesima quando salvo il file .odt in .pdf.
Aspetto notizie, spero che qualcuno di voi sappia come posso risolvere/aggirare questo problema.
Grazie,
Azzurra

P.S.: Dimenticavo... Uso una versione OpenOffice 3.3.0 e Mac OS X 10.6.6
Versione OpenOffice 3.0 - Installata su Mac OS X 10.6.6
Azzurra
 
Messaggi: 5
Iscritto il: sabato 5 febbraio 2011, 3:22

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda RGB-it » sabato 5 febbraio 2011, 7:30

OOo supporta legature tipografiche soltanto nei font Graphite, perciò essendo Palatino Linotype un font opentype il problema sarà un altro... Se provi con un altro font? URW Paladio L e TeX Gyre Pagella sono molto simili a Palatino Linotype (oltre ad essere di libera distribuzione).
AOO / openSUSE / KDE SC
---
Ci sono due tipi di persone: quelli che dicono che ci sono due tipi di persone e quelli che dicono il contrario.
---
Avatar utente
RGB-it
 
Messaggi: 583
Iscritto il: domenica 14 marzo 2010, 13:52

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda Azzurra » sabato 5 febbraio 2011, 12:52

Perdonami, purtroppo sono poco pratica... Non conosco nemmeno la differenza tra un Graphite e un Opentype, ma ora mi informo...

Per il cambio dei font, il mio problema reale è che non posso alterare la formattazione originale (che ho impostato) perché questo libro fa parte di una collana e tutti i testi della collana devono per forza avere la medesima formattazione. La collana la pubblicano già da un po' e non posso scegliere font o altro!
Devo per forza adeguarmi... Uff!
Però, in un cartaceo che ho qui, (un testo di questa collana pubblicato qualche anno fa, con le stesse impostazioni, ma che non ho impaginato io) nella stampa questi errori non ci sono!
Dovevo usare un altro software per impaginare, in pratica.... se ho capito bene? Perché così com'è, a quanto mi pare di capire, non potrà mai essere aggirato questo problema...
Grazie per l'aiuto...
Versione OpenOffice 3.0 - Installata su Mac OS X 10.6.6
Azzurra
 
Messaggi: 5
Iscritto il: sabato 5 febbraio 2011, 3:22

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda RGB-it » sabato 5 febbraio 2011, 17:16

Mi sembra troppo presto per dire che il problema non può essere aggirato... ;) Sopratutto senza vedere il documento ne conoscere le impostazioni del tuo sistema.
Sei sicura che il font è correttamente installato? Le uniche volte che ho visto problemi del genere fu all'aprire un documento formattato con un font non presente nel computer e per il quale OOo tentò (con poco successo) di sostituirlo con un altro.
Anche se vedi il nome del font nella casella quello non vuol dire che quel font è installato, soltanto che il documento che hai aperto chiede quel font. Se inizi un documento nuovo, proprio da zero, è questo font disponibili? Devi tenere presente che Palatino Linotype è un font non libero che costa non pochi soldi (fino a qualche centinaia di euro il pacchetto completo con tutte le varianti), perciò non lo troverai su tutti i computer.
AOO / openSUSE / KDE SC
---
Ci sono due tipi di persone: quelli che dicono che ci sono due tipi di persone e quelli che dicono il contrario.
---
Avatar utente
RGB-it
 
Messaggi: 583
Iscritto il: domenica 14 marzo 2010, 13:52

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda Azzurra » domenica 6 febbraio 2011, 13:10

Allora, innanzitutto grazie per la pazienza...e per le speranze che mi dai...
Ieri ho passato una serata (lavoro in un bar) terribile, praticamente ero assente, e pensavo solo a font, compatibilità di programmi, pagine, scadenze che non rispetterò.... Non mi era mai capitato, ma mi girava la testa, dal panico! L'idea di dover buttare tutto il lavoro fatto finora! Ieri ho anche provato a fare una velocissima prova con QuarXpress, ma mi sono resa conto che ci metterei una vita a fare tutto da capo... Impossibile ricominciare...

Provo a rispondere a tutte le tue domande...
Il font mi sembra correttamente installato (me lo ha fornito la persona che mi ha chiesto l'impaginazione, non sapevo si comprasse!). L'ho inserito nella cartella Font del MAC, convalidato, e appare se apro un OOo nuovo nella lista dei font disponibili. Non so se questo vuol dire che sia installato correttamente.
- Ho cercato i due font di cui mi hai parlato nella cartella OOo, ma non ci sono e vorrei chiederti dove posso recuperarli e come installarli correttamente, per fare una prova. Se fossero davvero somiglianti come dici al Palatino Linotype avrei risolto tutti i miei problemi.
- Invece, un amico un pochino più pratico di me con la grafica, mi ha consigliato di mettere un altro font, cambiare completamente... Mi ha consigliato Helvetica, ma si vede che è tutt'altra cosa rispetto al Palatino. Secondo lui il Palatino semplice magari non crea questi problemi, e potrebbe essere il Linotype la causa di tutto. Io non so se stesse parlando a vanvera o se, poverino, stesse dicendo qualcosa di sensato.So soltanto che sono ancora in un mare di guai...
-Se volessi farti vedere una pagina-tipo in cui accade che i caratteri si incollano (nel passaggio da OOo a PDF), come posso fare?
-E quando dici "impostazioni di sistema" cosa intendi? Mi hai messo un tarlo nella testa... Ti spiego. Poco tempo fa mi è capitato un problema col mac, potrebbe entrarci qualcosa? Praticamente deve essere successo qualcosa alla cartella Font per cui - quando aprivo la mail, oppure le anteprime PDF - mi dava caratteri greci, o altri font strani.
Secondo te potrebbe essere un problema di MAC e se apro il file su un'altra macchina con installato correttamente il PalLinotype poi non si sballa da OOo a PDF??!!

Grazie ancora per la pazienza... e per l'aiuto.
A.
Versione OpenOffice 3.0 - Installata su Mac OS X 10.6.6
Azzurra
 
Messaggi: 5
Iscritto il: sabato 5 febbraio 2011, 3:22

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda RGB-it » domenica 6 febbraio 2011, 13:52

Non sono pratico con i mac (sono utente Linux da più di 10 anni), però se mi dici che ci sono stati problemi precedentemente con altri applicativi, forse è un problema del tuo sistema più che di OOo.
Puoi trovare TeX Gyre Pagella qui:
http://www.gust.org.pl/projects/e-found ... index_html
come dice nella pagina, può essere utilizzata al posto de Pallatino.
Comunque prova a creare, a partire del documento con problemi, un documento piccolo (una pagina) dove sia chiaro il problema, e allega quella pagina qui insieme al pdf che risulta (soto l'area di edizione del messaggio c'è una scheda «invia allegato»), così forse si riesce a capire quale font sta entrando nel pdf.
AOO / openSUSE / KDE SC
---
Ci sono due tipi di persone: quelli che dicono che ci sono due tipi di persone e quelli che dicono il contrario.
---
Avatar utente
RGB-it
 
Messaggi: 583
Iscritto il: domenica 14 marzo 2010, 13:52

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda Azzurra » domenica 6 febbraio 2011, 15:11

Ti invio due esempi, un .odt e un .pdf.
Sto provando a scaricare e installare (spero correttamente) URW Palladio e TeX, ma il sito mi dice che TeX è opentype... Se il problema è quella differenza di cui parlavi, non è che scaricare TeX sarà inutile? Ancora non sono riuscita a capire qual è la differenza tra Graphite e OpenType. Ho capito solo che gli OpenType sono quelli più problematici, a quanto pare! :)
Intanto, faccio altri tentativi prima di andare al lavoro... (quello vero e così piacevolmente semplice e lontano dall'informatica! faccio la barista...e almeno quello mi riesce bene...)
Grazie ancora per il tempo e la pazienza...
Azzurra
Allegati
Esempio caratteri slegati.odt
Al secondo rigo la parola "fine" è normalmente spaziata
(15.85 KiB) Scaricato 58 volte
Esempio caratteri legati.pdf
Al secondo rigo la parola "fine" appare diversa da quella del file .odt - La f e la i sono completamente attaccate
(69.44 KiB) Scaricato 65 volte
Versione OpenOffice 3.0 - Installata su Mac OS X 10.6.6
Azzurra
 
Messaggi: 5
Iscritto il: sabato 5 febbraio 2011, 3:22

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda RGB-it » domenica 6 febbraio 2011, 15:35

Devo dire che qui il pdf si vede perfettamente. La f e la i sono vicine e non sono così belle insieme, ma quello è proprio il disegno della tipografia(1), no le vedo per nulla legate perciò il problema forse è nel visore pdf che usi. Prova ad aprire il pdf in un altro computer per vedere se fa lo steso problema
fi1.png
fi1.png (24.35 KiB) Osservato 1745 volte

Un commento sulla struttura del file odt: quasi tutta la formattazione è realizzata direttamente senza l'utilizzo di stili, perciò cambiare il font sarà un po più di lavoro di quello normalmente necessario. Per prossimi lavori è importante che impari ad utilizzare gli stili, ti eviterai tanti problemi.

(1) in fati, quel «problema» si risolve proprio con le legature tipografiche!
AOO / openSUSE / KDE SC
---
Ci sono due tipi di persone: quelli che dicono che ci sono due tipi di persone e quelli che dicono il contrario.
---
Avatar utente
RGB-it
 
Messaggi: 583
Iscritto il: domenica 14 marzo 2010, 13:52

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda Azzurra » lunedì 7 febbraio 2011, 5:13

Scusami, lo so che sono incapace nella formattazione. Appena ho un attimo cercherò di informarmi e imparare qualcosa, ma con calma.
Il punto è che mi occupo (e mi sono sempre occupata) di editing di testi, e non di impaginazione... anche se sono due fasi vicinissime. E l'editing (per fortuna/purtroppo) si fa sul cartaceo, solitamente.
In ogni caso:
Non parlavo di quel Fi in basso, in Bibliografia, ma di quello al secondo rigo, nella parola "fine". Io lo visualizzo malissimo, attaccato, anche in stampa. E tu? A te il primo "fi" che compare (al secondo rigo del testo, non delle note) è separato? Non è praticamente un solo carattere? Non riesco a capire...

Alla fine, credo di aver trovato una soluzione per risolvere il problema... Stampo l'odt, faccio fare scansioni in alta risoluzione e le salvo in pdf, e così dovrei aver aggirato il problema. Lo so che è una cosa terribile, e che non si dovrebbe fare... ma non vorrei dover dire di no a questa persona che ha una scadenza a breve... quindi farò ogni tentativo possibile per darle questo benedetto pdf senza problemi di visualizzazione.
Anche lei lo ha stampato e - sia sul pc sia sul cartaceo - lo visualizza con i caratteri attaccati. L'unico problema su più di duecento pagine già perfettamente leggibili (anche se formattate malissimo, ok :( )

Ne approfitto per chiederti un'altra cosa... C'è un modo per superare il limite allo spazio predefinito delle Note in piè di pagina? Ho provato a inserire i vari valori, ma non riesco a far sì che in una pagina ci siano (magari) solo due righe di testo e tutto il resto nota. Purtroppo mi sono capitate note lunghissime... Scrittori scriteriati!! :)

Grazie, per tutte le prove che hai fatto per aiutarmi, e per il tempo dedicato.
A.
Versione OpenOffice 3.0 - Installata su Mac OS X 10.6.6
Azzurra
 
Messaggi: 5
Iscritto il: sabato 5 febbraio 2011, 3:22

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda d4rkheart » lunedì 7 febbraio 2011, 20:01

Ciao Azzurra, mi sono permessa di scaricare i tuoi files per vedere se riuscivo a visualizzarli correttamente. Io ho sistema operativo windows ed il font palatino linotype risulta installato nel mio s.o.
Nel tuo file pdf i caratteri f ed i sono effettivamente attaccati, credo che il font da te installato si sia corrotto...credo. Dovresti andare nella cartella dei font, eliminare il font ed installarlo nuovamente se ne hai la possibilità e riprovare con l'esportazione come file pdf. Allego il file pdf e l'immagine
Allegati
Esempio caratteri slegati.pdf
(65.48 KiB) Scaricato 47 volte
d4rkheart
 
Messaggi: 475
Iscritto il: martedì 9 novembre 2010, 1:50

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda d4rkheart » lunedì 7 febbraio 2011, 20:13

Nel caso non riuscirai ad esportare correttamente, dopo avvenuta installazione dei fonts palatino linotype, e i caratteri sono sempre attaccati devi provare ad eliminare il profilo utente di openoffice, se non sai come fare chiedi che ti aiuteranno, io non sono utente mac e non saprei come aiutarti, e poi provi a esportare.
d4rkheart
 
Messaggi: 475
Iscritto il: martedì 9 novembre 2010, 1:50

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda paolopoz » martedì 22 febbraio 2011, 13:51

Scusate se riesumo questo argomento ma forse ho trovato qualcosa che può essere d'aiuto...

Menu Formato - Carattere... nella scheda Posizione, sezione Spaziatura c'è un'opzione Crenatura caratteri a coppia. Può essere che sia questo che da fastidio?
Avatar utente
paolopoz
 
Messaggi: 244
Iscritto il: venerdì 22 maggio 2009, 12:20

Re: Legatura caratteri - FI appare legato se salvo in pdf

Messaggioda FncZ4pp4 » martedì 22 febbraio 2011, 18:01

paolopoz ha scritto:Scusate se riesumo questo argomento ma forse ho trovato qualcosa che può essere d'aiuto...

Menu Formato - Carattere... nella scheda Posizione, sezione Spaziatura c'è un'opzione Crenatura caratteri a coppia. Può essere che sia questo che da fastidio?

La spaziatura agisce su tutti i caratteri non solo con "fi".

@ Azzurra, hai provato a fare sostituisci fi con f i ? In emergenza può funzionare, ma fallo con una copia del documento.
Per cortesia, inserisci [Risolto] nel Titolo iniziale se il tuo problema è stato risolto.
-
OpenOffice 3.3 su Windows XP
Avatar utente
FncZ4pp4
 
Messaggi: 285
Iscritto il: domenica 2 gennaio 2011, 20:32


Torna a Writer

Chi c’è in linea

Visitano il forum: Google [Bot] e 7 ospiti