Pagina 1 di 1

[Risolto] Impossibile creare e aprire rapporti con LibOffice

MessaggioInviato: mercoledì 7 marzo 2018, 9:48
da Vioma
Buongiorno, come da titolo non riesco ne ad aprire e ne a creare rapporti di stampa.
Nel primo caso non mi si apre nulla, nel secondo caso mi esce la finestra di errore riportata in allegato.
Pensavo che si trattasse della mancanza dell'estensione base report, ma anche installandola non cambia nulla (ho riavviato libreoffice).
Sicuramente manca qualcosa, ma non capisco cosa.
La mia versione di libreoffice è la 6.0.2.1.
Selezione_704.png

Re: Impossibile creare e aprire rapporti con Libreoffice.

MessaggioInviato: mercoledì 7 marzo 2018, 12:50
da charlie
Ciao, tabelle, query e formulari funzionano?
È un database che puoi condividere?

Re: Impossibile creare e aprire rapporti con Libreoffice.

MessaggioInviato: mercoledì 7 marzo 2018, 13:12
da Vioma
charlie ha scritto:Ciao, tabelle, query e formulari funzionano?
È un database che puoi condividere?

Si tutto il resto funziona.
Certo che lo posso condividere, stavo seguendo un corso on line, è un file di esempio.
Non penso comunque che il problema sia del file, ho provato anche con altri fogli, comunque allego e ringrazio per le risposte e l'interessamento.
Interventi_PC.odb
(77.21 KiB) Scaricato 19 volte

Re: Impossibile creare e aprire rapporti con Libreoffice.

MessaggioInviato: mercoledì 7 marzo 2018, 13:30
da charlie
Ciao, confermo che il file si apre anche con LO 6.0.0.3 per Mac.
Escluderei problemi di Java, dal momento che tabelle, query e formulari funzionano.
Potrebbe essere la versione stessa che se, non erro, è ancora quella Fresh. provato con la 5?

Re: Impossibile creare e aprire rapporti con Libreoffice.

MessaggioInviato: mercoledì 7 marzo 2018, 16:33
da Vioma
Io utilizzo Linux non Mac.
Se è possibile vorrei risposte da chi utilizza Linux, possibilmente Ubuntu.

Re: Impossibile creare e aprire rapporti con Libreoffice.

MessaggioInviato: mercoledì 7 marzo 2018, 21:17
da Vioma
Ho risolto da solo.
Non è vero che se funzionano tabelle, ricerche e formulari debba necessariamente funzionare anche il modulo rapporto.
Il problema è proprio della mancanza di pacchetti Java che mancano dall'installazione principale di base anche nella versione 6.0.2.1 di Ubuntu.
Per chi ha questo stesso problema si risolve installando da terminale il pacchetto libreoffice-report-builder. Durante l'installazione di questo pacchetto vengono anche installate le dipendenze mancanti in Java.
Per l'installazione digitate:
Codice: Seleziona tutto   Espandi visualeStringi visuale
sudo apt-get install libreoffice-report-builder

Il tutto viene spiegato all'interno di questo filmato: https://www.youtube.com/watch?v=dTlesMR ... W&index=11.