Excel makró futási probléma Openoffice alkalmazás alatt

Táblázatkezelő

Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: VDénes » 2019. január 10., csütörtök 14:21

Jó napot!

Új témát indítok, ahogyan javasolta.
Az alábbi kód nem működik.
A Libre Office már jobb, mert legalább ír hibaüzenetet.
Hiba történt a BASIC-program futása közben. '91' Az objektumváltozó nincs beállítva. A 425-ös sorra mutat.
Vagy akkora a méret, hogy egyszerűbb másikat csinálni?

A fájl sajnos olyan nagy méretű, hogy azt nem tudom csatolni.
Köszönöm szépen előre is!
Csatolmányok
Új OpenDocument-szöveg.odt
kód szöveg fájlban
(25.23 KiB) 9 alkalommal.
ApacheOpenOffice 4.1.3
VDénes
 
Hozzászólások: 7
Csatlakozott: 2019. január 10., csütörtök 10:18

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: Zizi64 » 2019. január 10., csütörtök 14:48

A fájl sajnos olyan nagy méretű, hogy azt nem tudom csatolni.

De akkor én meg nem tudom próbálni. A nagy méretű fájlokat ingyenes fájlmegosztókról ide linkelve tudod megosztani.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO4.4.7, LO6.1.5;
winPenPack/PortableApps: AOO4.1.5, LO3.3.1-6.2.2
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3351
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: Zizi64 » 2019. január 10., csütörtök 15:01

Legalább a szubrutin, vagy eljárás nevét mondd meg - ahol a hiba jelentkezett -, mert Writerbe bemásolva a sorok száma nem biztos, hogy ugyanaz maradt, mint amennyi a kódszerkesztőben volt.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO4.4.7, LO6.1.5;
winPenPack/PortableApps: AOO4.1.5, LO3.3.1-6.2.2
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3351
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: Zizi64 » 2019. január 10., csütörtök 15:10

Hiba történt a BASIC-program futása közben. '91' Az objektumváltozó nincs beállítva.


Nos, visszamásoltam egy Modulba a LO makrószerkesztőjébe a kódot, és ott a 425. sor ez:

Kód: Egész kijelölése   KinyitásÖsszecsukás
ActiveSheet.Shapes.AddShape(msoShapeDiamond, z_xk, z_yk, z_x, z_y). _
                Select


Itt valóban az a helyzet - ahogy a hibaüzenet írja -, hogy a msoShapeDiamond változónak sehol nincs megadva az értéke. Mi az? Egy karakter egy speciális karakterkészletből, vagy valami grafikus objektum? Lehet, hogy az MS VBA-ban ez egy máshol (globálisan) megadott változó, de itt senki és semmi nem adott neki se típust, se értéket.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO4.4.7, LO6.1.5;
winPenPack/PortableApps: AOO4.1.5, LO3.3.1-6.2.2
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3351
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: VDénes » 2019. január 10., csütörtök 18:52

http://s1.toldacuccot.hu/letoltes?sid=c2787297b12f60ee371c726b88777d96&file=oszl_m%C3%A9retez_85_vista.xlsm

Elnézést nem voltam eddig gépközelben.
Ez lenne a teljes fájl.

Nagyon szépen köszönöm. Nem gondoltam ilyen gyorsan lesz válasz.
ApacheOpenOffice 4.1.3
VDénes
 
Hozzászólások: 7
Csatlakozott: 2019. január 10., csütörtök 10:18

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: Zizi64 » 2019. január 10., csütörtök 20:19

Letöltöttem a fájlodat és megnyitottam LibreOffice 6.1.4-gyel. Nem látok egyetlen olyan kezelőszervet sem a munkalapokon, amikre a makrók hivatkoznak. Se gombot, se rádió (option)-gombot, se checkboxot - semmit. Ha az IDE felületről futtatom a Rajzolas makró rutint, akkor a 424-es sorban áll meg:
Kód: Egész kijelölése   KinyitásÖsszecsukás
If OptionButton10.Value = False Then 'zöld_mez?

De ugyebár OptionButton10 se látszik a munkalapokon sem, és a Navigátorban sem, emiatt a hivatkozás "lóg a levegőben".

Minek a határása indulna nálad például ez a "Rajzolas" makró, és mit rajzolna (hová?)

A fő problémához mérten apróság, hogy a KÖF.O14 cellában =ISERROR() függvény van, ami nem létezik az AOO-ban, de a LibreOffice-ban létezik. "Kiváltani" az =IF(ISERROR()) függvénypárral lehet az esetek többségében.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO4.4.7, LO6.1.5;
winPenPack/PortableApps: AOO4.1.5, LO3.3.1-6.2.2
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3351
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: VDénes » 2019. január 10., csütörtök 20:24

http://s4.toldacuccot.hu/letoltes?sid=a424b24c68ab6a0f9005da50a864ed9f&file=oszl_m%C3%A9retez_85_vista.xlsm

Felteszek egy régit. Ezt én rontottam el. Mert alakítottam rajta és nem jót küldtem el.

Elnézést!
ApacheOpenOffice 4.1.3
VDénes
 
Hozzászólások: 7
Csatlakozott: 2019. január 10., csütörtök 10:18

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: Zizi64 » 2019. január 10., csütörtök 20:35

Erre meg azt mondja a böngészőm és a vírusirtóm, hogy fertőzött fájl, és nem engedi letölteni. Be kéne csomagolnod zip-be, (vagy egyszerűen átnevezni .zip-re), akkor talán letölthető lesz.

Több böngészővel is próbáltam, a vírusirtóm Avast.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO4.4.7, LO6.1.5;
winPenPack/PortableApps: AOO4.1.5, LO3.3.1-6.2.2
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3351
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: Zizi64 » 2019. január 10., csütörtök 20:41

Vagy küldjed mailben. Itteni üzenetben elküldöm az emailcímemet.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO4.4.7, LO6.1.5;
winPenPack/PortableApps: AOO4.1.5, LO3.3.1-6.2.2
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3351
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: VDénes » 2019. január 10., csütörtök 20:58

Nagyon szépen köszönöm. Elküldtem.
Nagyon restellem, hogy rajtam kifog ez...
ApacheOpenOffice 4.1.3
VDénes
 
Hozzászólások: 7
Csatlakozott: 2019. január 10., csütörtök 10:18

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: Zizi64 » 2019. január 10., csütörtök 21:17

Megjöttek a fájlok a sűrítményben.

A "csupasz_belogas.xls" több helyen egy Add-in komponensre hivatkozik, ami a LibreOffice-omban nincs meg. Ez lehet egy általános Add-in, ami alapból része az Excelnek, de lehet egy speciális, csak azon a gépen telepített Add-in is. Enélkül az a fájl nem képes működni AOO-ban, LO-ban.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO4.4.7, LO6.1.5;
winPenPack/PortableApps: AOO4.1.5, LO3.3.1-6.2.2
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3351
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: VDénes » 2019. január 10., csütörtök 21:19

Valószínű Excel sajátja lehet. Mert más gépeken is működött eddig csak Microsoft Officeban.
ApacheOpenOffice 4.1.3
VDénes
 
Hozzászólások: 7
Csatlakozott: 2019. január 10., csütörtök 10:18

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: Zizi64 » 2019. január 10., csütörtök 22:21

Mindhárom fájlt megnézve arra jutottam, hogy ez igen csak nagy munka lesz, mire hiba nélküli működésre bírja valaki.
Azaz:
- teljesen újra kell írni a makrókat;
- amit lehet, át kell helyezni "Stílus alapra", (és nem egyenként állítgatni a minden egyes elem tulajdonságait, hanem megnevezni egy - a sablonban már előkészített - stílust, és ráhúzni az adott objektumra).
- ki kell deríteni, hogy mi az az Add-in, ami hiányzik. Ingyenesen eléhető-e, és kompatibilissé tehető-e a LO-szal, vagy létezik-e kiváltó Add-in, - ha nincs, akkor meg kell írni.
- el kell dönteni, hogy AOO vagy LO alapon akarod-e folytatni a fejlesztést - mert annyi ideje váltak már szét, hogy egyre jelentősebb különbségek lesznek a két programcsomag között. Az AOO fejlesztése rendkívül lassú napjainkban, a Win10-en kompatibilitási/stabilitási problémák vannak - legalábbis az angol nyelvű fórum új témáiban előforduló panaszkodások alapján ez szűrhető le. Úgyhogy jómagam mindenképpen a LibreOffice-t javaslom, de ha "gyorsan" működőképesnek kell ennek a méretező alkalmazásnak, akkor leggyorsabb venni egy MS Office-t.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO4.4.7, LO6.1.5;
winPenPack/PortableApps: AOO4.1.5, LO3.3.1-6.2.2
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3351
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: VDénes » 2019. január 10., csütörtök 23:08

Köszönöm szépen!
Valószínű akkor az Office beszerzése marad most egyenlőre. Csak ez a havidíjas dolog nem tetszik, hogy már csak bérelni lehet. De ez van most egyenlőre.
Az OpenOffice-t egyetemi éveim alatt nagyon sokat használtam és azt gondoltam nem lesz gond.
Ahogyan lesz időm biztosan újra lesznek írva ezek a programok, mivel az előírások úgyis változnak.

Köszönöm mégegyszer a segítséget!

Minden jót kívánok!
ApacheOpenOffice 4.1.3
VDénes
 
Hozzászólások: 7
Csatlakozott: 2019. január 10., csütörtök 10:18

Re: Excel makró futási probléma Openoffice alkalmazás alatt

HozzászólásSzerző: Zizi64 » 2019. január 11., péntek 10:06

Valószínű Excel sajátja lehet. Mert más gépeken is működött eddig csak Microsoft Officeban.


Mivel a munkalap jelszóval védett, még az adott, "#ADDIN?" hibaüzenetet tartalmazó cellát se tudom megnézni, hogy milyen függvénynevet tartalmaz, amit aztán persze nem tud elérni. A függvénynévből lehetne következtetni az Add-in mibenlétére; nevére, elérhetőségére.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO4.4.7, LO6.1.5;
winPenPack/PortableApps: AOO4.1.5, LO3.3.1-6.2.2
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3351
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest


Vissza: Calc

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 0 vendég

cron