A lejátszott PPS-nek nincs hangja ALSA hangrendszeren

Bemutatókészítő

A lejátszott PPS-nek nincs hangja ALSA hangrendszeren

HozzászólásSzerző: kimarite » 2011. január 25., kedd 0:20

Ubuntu 9.10-et használok és LibreOffice-t. Az előzőleg telepített OpenOffice-n le tudtam hanggal játszani a "zenés" PPS-eket. Most teljes egészében törölve van a pulseaudio hangrendszer és az alsa van telepítve: alsamixergui és a más fórumon ajánlott alsa-oss. Így sincs hang. Az alsamixerben a potméterek felhúzva, némitásból a pipa ki. Minden pulse uninstall és "takarítva van". Miután alsa-ra váltottam, nem néztem "zenés" PPS-t, de ez lehet a hiba oka.
Nem szeretnék megválni az alsa-tól ... tulajdonképpen a Skype (hm) miatt telepítettem, de megtetszett.
Jó lenne rájönni a hang probléma okára, mert nem sok PPS-t nézek, de akadna néhány nagyon fontos. Valamint, mint linux használó, izgat a megoldás.
LibreOffice 3.3 az Ubuntu 9.10-en
kimarite
 
Hozzászólások: 4
Csatlakozott: 2011. január 25., kedd 0:04

Re: A lejátszott PPS-nek nincs hangja ALSA hangrendszeren

HozzászólásSzerző: kimarite » 2011. január 25., kedd 0:22

Nem vagyok túl gyakorlott linux felhasználó, de jó pár probléma okára már rájöttem. Esetleg törekedjetek az egyszerűségre a válaszok során. :)
LibreOffice 3.3 az Ubuntu 9.10-en
kimarite
 
Hozzászólások: 4
Csatlakozott: 2011. január 25., kedd 0:04

Re: A lejátszott PPS-nek nincs hangja ALSA hangrendszeren

HozzászólásSzerző: Zizi64 » 2011. január 25., kedd 19:24

Üdv!

Úgy látom másnak is okozott már problémát. Segíteni sajnos nem igazán tudok.
http://forums.opensuse.org/english/get- ... 1-1-a.html

Viszont megjelent a 3.3-as LibreOffice:
http://libreoffice.hu/2011/01/25/a-docu ... #more-2037

Hátha abban javítottak valamit ez ügyben...
Sok sikert!
Kovács Tibor (Win10x64Prof/W7x64P: LO6.1.6-6.2.8;
winPenPack/PortableApps: LO3.3.1-6.4.5, AOO4.1.7
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címének szerkesztésével. Írd elé: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3683
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: A lejátszott PPS-nek nincs hangja ALSA hangrendszeren

HozzászólásSzerző: Zizi64 » 2011. január 25., kedd 19:30

Sok sikert!
Kovács Tibor (Win10x64Prof/W7x64P: LO6.1.6-6.2.8;
winPenPack/PortableApps: LO3.3.1-6.4.5, AOO4.1.7
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címének szerkesztésével. Írd elé: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3683
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: A lejátszott PPS-nek nincs hangja ALSA hangrendszeren

HozzászólásSzerző: kimarite » 2011. január 27., csütörtök 18:56

MEGOLDVA!
Ez a link vezetett megoldásra a http://forums.opensuse.org/english/get- ... 1-1-a.html oldalról
https://bugs.launchpad.net/ubuntu/+sour ... bug/375891
:idea:

Telepítettem a következő fájlokat, és a LibreOffice lejátssza most már a hangot is a PPS bemutatónál. Többnyire csak a ".dbg" hiányzott (kodekekben viszonylag "otthon" vagyok), a ".dev"-et nem telepítettem. És a pulseaudio gstreamert is ... bár majd megnézem kell-e valójában, én nem ragaszkodom hozzá.

Először is bemásoltam a Launchpad-os linken talált utasítás sort a terminálba
dpkg -l | grep gstreamer
ii bluez-gstreamer 4.32-0ubuntu4.1 Bluetooth gstreamer support
ii gstreamer0.10-plugins-bad 0.10.11-2ubuntu1 GStreamer plugins from the "bad" set
ii gstreamer0.10-plugins-base 0.10.22-5 GStreamer plugins from the "base" set
ii gstreamer0.10-plugins-ugly 0.10.10.2-1build1 GStreamer plugins from the "ugly" set
ii gstreamer0.10-plugins-ugly-multiverse 0.10.7-2 GStreamer plugins from the "ugly" set (Multi
ii gstreamer0.10-pulseaudio 0.10.14-1 GStreamer plugin for PulseAudio
ii libgstreamer-plugins-base0.10-0 0.10.22-5 GStreamer libraries from the "base" set
ii libgstreamer0.10-0 0.10.22-1 Core GStreamer libraries and elements

Ezt írta ki (legalábbis nálam (!), másnál más lehet a végeredmény):
dpkg -l | grep gstreamer
ii bluez-gstreamer 4.51-0ubuntu2 Bluetooth GStreamer support
ii gstreamer-tools 0.10.25-2 Tools for use with GStreamer
ii gstreamer0.10-alsa 0.10.25-2ubuntu1.2 GStreamer plugin for ALSA
ii gstreamer0.10-doc 0.10.25-2 GStreamer core documentation and manuals
ii gstreamer0.10-esd 0.10.16-1ubuntu3 GStreamer plugin for ESD
ii gstreamer0.10-ffmpeg 0.10.9-1 FFmpeg plugin for GStreamer
ii gstreamer0.10-ffmpeg-dbg 0.10.9-1 FFmpeg plugin for GStreamer (debug symbols)
ii gstreamer0.10-fluendo-mp3 0.10.7.debian-1ubuntu1 Fluendo mp3 decoder GStreamer plugin
ii gstreamer0.10-gnomevfs 0.10.25-2ubuntu1.2 GStreamer plugin for GnomeVFS
ii gstreamer0.10-gnonlin 0.10.13-1 non-linear editing module for GStreamer
ii gstreamer0.10-gnonlin-dbg 0.10.13-1 non-linear editing module for GStreamer
ii gstreamer0.10-gnonlin-doc 0.10.13-1 GStreamer documentation for the non-linear e
ii gstreamer0.10-nice 0.0.9-2 ICE library (GStreamer plugin)
ii gstreamer0.10-pitfdll 0.9.1.1+cvs20080215-1ubuntu1 GStreamer plugin for using MS Windows binary
ii gstreamer0.10-plugins-bad 0.10.14-4ubuntu1.1 GStreamer plugins from the "bad" set
ii gstreamer0.10-plugins-bad-dbg 0.10.14-4ubuntu1.1 GStreamer plugins from the "bad" set (debug
ii gstreamer0.10-plugins-bad-doc 0.10.14-4ubuntu1.1 GStreamer documentation for plugins from the
ii gstreamer0.10-plugins-bad-multiverse 0.10.13-0ubuntu1 GStreamer plugins from the "bad" set (Multiv
ii gstreamer0.10-plugins-bad-multiverse-dbg 0.10.13-0ubuntu1 GStreamer plugins from the "bad" set (Multiv
ii gstreamer0.10-plugins-base 0.10.25-2ubuntu1.2 GStreamer plugins from the "base" set
ii gstreamer0.10-plugins-base-apps 0.10.25-2ubuntu1.2 GStreamer helper programs from the "base" se
ii gstreamer0.10-plugins-base-dbg 0.10.25-2ubuntu1.2 GStreamer plugins from the "base" set
ii gstreamer0.10-plugins-base-doc 0.10.25-2ubuntu1.2 GStreamer documentation for plugins from the
ii gstreamer0.10-plugins-good 0.10.16-1ubuntu3 GStreamer plugins from the "good" set
ii gstreamer0.10-plugins-good-dbg 0.10.16-1ubuntu3 GStreamer plugins from the "good" set
ii gstreamer0.10-plugins-good-doc 0.10.16-1ubuntu3 GStreamer documentation for plugins from the
ii gstreamer0.10-plugins-ugly 0.10.12-1 GStreamer plugins from the "ugly" set
ii gstreamer0.10-plugins-ugly-doc 0.10.12-1 GStreamer documentation for plugins from the
ii gstreamer0.10-plugins-ugly-multiverse 0.10.12-0ubuntu1 GStreamer plugins from the "ugly" set (Multi
ii gstreamer0.10-plugins-ugly-multiverse-dbg 0.10.12-0ubuntu1 GStreamer plugins from the "ugly" set (Multi
ii gstreamer0.10-pulseaudio 0.10.16-1ubuntu3 GStreamer plugin for PulseAudio
ii gstreamer0.10-sdl 0.10.14-4ubuntu1.1 GStreamer plugin for SDL output
ii gstreamer0.10-tools 0.10.25-2 Tools for use with GStreamer
ii gstreamer0.10-x 0.10.25-2ubuntu1.2 GStreamer plugins for X11 and Pango
ii libgstreamer-plugins-base0.10-0 0.10.25-2ubuntu1.2 GStreamer libraries from the "base" set
ii libgstreamer0.10-0 0.10.25-2 Core GStreamer libraries and elements
ii libgstreamer0.10-0-dbg 0.10.25-2 Core GStreamer libraries and elements

Telepítenem kellett az "ii" csomagot, hiányzott. Majd újból bemásoltam a fenti parancssort, de a jelszavam beírása és az Enter lenyomása után sem történt semmi, csak a bluez-gstreamer csomagon gondolkodott sokat a terminál ... így hagytam, bezártam az ablakot.

Ezután telepítettem a terminálban írt csomagokat a a szokásos módszerrel az újból megnyitott terminálban (fentebb a parancssorban szerepelnek. lehagytam a végét, hiszen ez disztribúciónként más és más lehet - lásd lejjebb). Az igazsághoz hozzátartozik, hogy synaptic-al csináltam, de így egyszerűbb :)
sudo apt-get update
sudo apt-get install bluez-gstreamer gstreamer-tools gstreamer0.10-alsa gstreamer0.10-doc gstreamer0.10-esd gstreamer0.10-ffmpeg gstreamer0.10-ffmpeg-dbg gstreamer0.10-fluendo-mp3 gstreamer0.10-gnomevfs gstreamer0.10-gnonlin gstreamer0.10-gnonlin-dbg gstreamer0.10-gnonlin-doc gstreamer0.10-nice gstreamer0.10-pitfdll gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-dbg gstreamer0.10-plugins-bad-doc gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-bad-multiverse-dbg gstreamer0.10-plugins-base gstreamer0.10-plugins-base-apps gstreamer0.10-plugins-base-dbg gstreamer0.10-plugins-base-doc gstreamer0.10-plugins-good gstreamer0.10-plugins-good-dbg gstreamer0.10-plugins-good-doc gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-doc gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-plugins-ugly-multiverse-dbg gstreamer0.10-pulseaudio gstreamer0.10-sdl gstreamer0.10-tools gstreamer0.10-x libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgstreamer0.10-0-dbg

Tulajdonképpen a megérzéseimre hagyatkoztam (nagyon nem lehet elrontani), mivel például a "grep" és az "-l" kapcsolók mibenlétét és az "ii" szoftvert sem tudom micsoda így hirtelen - de mindjárt megnézem :)

A wine-os megoldás nem szimpatikus, hiszen minek kéne a windows-hoz nyúlni, ha itt az open source megoldás. :)

Megosztom az említett PPS-t, lehet tesztelni ;)
Ritka látvány a Csendes-óceánon
http://www.bannercsere.info/new_age/ppt/370.pps

Köszi a segítséget!
Imre

Ui.: Közben megnéztem, mit is telepítettem, mi az "ii"
minimalist FIFO and filesystem-based IRC client

ii (irc it) is a minimalist FIFO and filesystem-based IRC client. It creates an
irc directory tree with server, channel and nick name directories. In every
directory a FIFO in file and a normal out file is created.

The in file is used to communicate with the servers and the out files contain
the server messages. For every channel and every nick name there are related in
and out files created. This allows IRC communication from command line and
adheres to the Unix philosophy.

It consists of <= 500 lines of code and is the big brother of sic.

.. azt hiszem a FIFO (first in, first out) volt számomra érdekes (az adatok kiolvasásánál, a kodekekre vonatkoztatva), nem találkoztam még az alkalmazásával (IRC-t nem használok)
FIFO: Linux / Unix Command Library
"Olyan adatszerkezet, amelyből az elemek tárolási sorrendben olvashatók ki (azaz legelsőnek a legelőször eltárolt elem, másodikra a másodiknak tárolt elem, stb.)."
"Egyik alkalmazása a Sor
pipe
sor, cső
A FIFO elv szerint megvalósított adatszerkezet, illetve IPC eszköz.
A legtöbb operációs rendszer kizárólag szimplex csöveket bocsát az alkalmazások rendelkezésére, de vannak duplex variánsokat is kínáló változatok."
.. hát igen :roll:
LibreOffice 3.3 az Ubuntu 9.10-en
kimarite
 
Hozzászólások: 4
Csatlakozott: 2011. január 25., kedd 0:04

Re: A lejátszott PPS-nek nincs hangja ALSA hangrendszeren

HozzászólásSzerző: Zizi64 » 2011. január 27., csütörtök 21:30

...Ez nem semmi...

Gratula!
Sok sikert!
Kovács Tibor (Win10x64Prof/W7x64P: LO6.1.6-6.2.8;
winPenPack/PortableApps: LO3.3.1-6.4.5, AOO4.1.7
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címének szerkesztésével. Írd elé: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3683
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: A lejátszott PPS-nek nincs hangja ALSA hangrendszeren

HozzászólásSzerző: kimarite » 2011. január 28., péntek 13:48

Köszönöm!
Megpróbálom megosztani máshol is. (ha sikerül időt szakítanom a HTML szerkesztésre - akkor például az Ubuntu fórumon: nem nagyon vagyok benne otthon - tanulom)
Te is sokat segítettél ;) Köszi!

Itt már megvan
http://linux.network.hu/blog/linux-klub ... rendszeren
LibreOffice 3.3 az Ubuntu 9.10-en
kimarite
 
Hozzászólások: 4
Csatlakozott: 2011. január 25., kedd 0:04

Re: A lejátszott PPS-nek nincs hangja ALSA hangrendszeren

HozzászólásSzerző: gabcsi43 » 2011. április 23., szombat 20:47

Nekem is nagy problémám, hogy a pps-nek nincs hangja. Most töltöttem le a 3.3 verziót és sajnos a helyzet változatlan. Sajnos a bonyolult leírások nekem kínaiul vannak. Remélem, hogy a fejlesztők az újabb verzióknál majd figyelembe veszik az igényünket a hangra. Ha az is lesz, akkor szerintem teljesen azonos értékű lesz az Microsoft Office-al, ami nekem régebben volt, de valahogy letiltódott. Csak sejtem, hogy miért... Akkor töltöttem fel az OOo 3.2-t, most pedig a 3.3-at.
OpenOffice 3.3 a Windows XP-n
gabcsi43
 
Hozzászólások: 1
Csatlakozott: 2011. április 23., szombat 20:39

Re: A lejátszott PPS-nek nincs hangja ALSA hangrendszeren

HozzászólásSzerző: Zizi64 » 2011. április 24., vasárnap 8:42

Üdv!

Ha csak lejátszani szeretnéd a PPS-eket, ahhoz fölösleges az Open/LibreOffice.
Elegendő a Microsoft ingyenes PPTviewere. Bárki számára ingyenesem letölthető a honlapjukról.
Így keresd a Google-ban: "PowerPoint megjelenítő 2007", vagy "PowerPoint megjelenítő 2010"

Ha szerkeszteni is szeretnéd, akkor más a helyzet. Milyen formátumú hangfájl van a bemutatódban? Azt a formátumot csupaszon - tehát nem dokumentumba ágyazva képes lejátszani a géped?
Ha szerkeszted is a fájlodat, akkor pedig mindig a natív fájlformátumokat használd! Bemutató: "odp", táblázat: "ods", szöveges dokumentum: "odt". Ezek a formátumok sok ország által elfogadott és átvett nemzetközi szabványban vannak lefektetve, nem úgy mint az MS bináris formátumai. (az "x" végű - docx, xlsx... - formátumait már az MS is szabványosította. Nem akar lemaradni...)
http://hu.wikipedia.org/wiki/OpenDocument

(Egyébként melyik nyílt forráskódú csomagot használod? Egyelőre úgy néz ki, ha ellenőrzött magyar verziót szeretnél, akkor a LbreOffice a jó választás számodra...)

:) csak egy kis számítástechnikai nyelvtan:
Akkor töltöttem fel az OOo 3.2-t, most pedig a 3.3-at.

"Akkor töltöttem le (az internetről), és telepítettem fel (a gépemre)" a helyesebb kifejezés, szerintem...
Sok sikert!
Kovács Tibor (Win10x64Prof/W7x64P: LO6.1.6-6.2.8;
winPenPack/PortableApps: LO3.3.1-6.4.5, AOO4.1.7
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címének szerkesztésével. Írd elé: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3683
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest


Vissza: Impress

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég

cron