"Olvasási hiba" képeknél >>> Eltűnő képek!!!

Szövegszerkesztő

"Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: BBoy » 2011. május 11., szerda 23:31

Sziasztok!

Sajnos már többször találkoztam az alábbi hibajelenséggel elsősorban OO.o Writer esetében.

http://dl.dropbox.com/u/4384372/IMG_11052011_232047-hiba1.png
http://dl.dropbox.com/u/4384372/IMG_11052011_232047-hiba2.png

Képek_megjelenése1.png

Képek_megjelenése2.png

(Beágyaztam a képeidet, hogy biztosan meglegyen a későbbiekban is...)

Mindenféle előzmény nélkül produkálja ezt a dokumentum. Egy ideig teljesen jól lehet szerkeszteni, aztán "egyszercsak" ilyenek lesznek a képek. Nem feltétlenül az összes, viszont a bosszantó, hogy ha ilyenkor rámentesz, akkor azzal a mozdulattal ezek a képek végleg "eltűnnek" a dokumentumból!

Nagyon hálás lennék, ha valaki megmondaná miért csinálja ezt az OpenOffice. Legújabb 3.2.1-es Windows-os verzióról van szó! (Elsősorban WinXP alatt előforduló hibajelenség!)

Válaszotokat előre is köszönöm!
BBoy
 
Hozzászólások: 7
Csatlakozott: 2008. március 6., csütörtök 10:47

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: Zizi64 » 2011. május 12., csütörtök 8:29

Üdv!

Első kérdésem:
Linkelt, vagy beágyazott képekről van szó?


Első megjegyzésem pedig:
a 3.2.1 az már régen nem a legújabb verzió. Elírtad, vagy nem értesültél az újabbakról?

Ehhez kapcsolódó második kérdésem: melyik disztribúciót használod? a GoOO félét (ebból nőtt ki a LibreOffice is) vagy a (régebbi "Mainstream") Sun/Oracle által kiadottat?
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3474
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: BBoy » 2011. május 12., csütörtök 9:23

Zizi64 írta:Üdv!

Első kérdésem:
Linkelt, vagy beágyazott képekről van szó?


Miből tudom ezt a legegyszerűbben megállapítani?

Zizi64 írta:Első megjegyzésem pedig:
a 3.2.1 az már régen nem a legújabb verzió. Elírtad, vagy nem értesültél az újabbakról?

Ehhez kapcsolódó második kérdésem: melyik disztribúciót használod? a GoOO félét (ebból nőtt ki a LibreOffice is) vagy a (régebbi "Mainstream") Sun/Oracle által kiadottat?


Igen, a verzióban igazad van. Tényleg már nem a legújabb verzió. (Ennek annyira nem néztem utána!)
A régebbi "mainstream"-et használom (office.fsf.hu-ról letölthető?!)
BBoy
 
Hozzászólások: 7
Csatlakozott: 2008. március 6., csütörtök 10:47

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: Zizi64 » 2011. május 12., csütörtök 14:06

Első kérdésem:
Linkelt, vagy beágyazott képekről van szó?

Miből tudom ezt a legegyszerűbben megállapítani?


Ha te tetted be képeket a dokumentumba, akkor gondolom tudod, hogy beágyaztad, vagy linkelted.
Ha készen kaptad a dokumentumot, akkor is meg lehet állapítani, hogy milyen módon kapcsolódik a dokumentumhoz. Ha "csak" linkelve van, akkor abban az esetben, ha a dokumentum megnyitásakor nem érhető el a kép tárolóhelye (internet, helyi hálózat, külső vincseszter, pendrájv, stb.) akkor az OOo/LibreOffice természetesen nem tudja megjeleníteni a képet, csak a keretet, a "helyét" tudja mutatni...
A hivatkozás típust a "Szerkesztés - Hivatkozások" menüpont alatt tudod leellenőrizni.
Ha van kép típusú fájl linkelve a megjelenő listában, akkor linkelve van a kép. Ha a menüpont szürke (inaktív), akkor semmi nincs linkelve a fájlodhoz; minden, amit egyébként benne látsz az benne is tárolódik, benne is helyezkedik el.
Kép_hivatkozással.png

Másik lehetőség:
Jobb klikk a képen, a lebegő menüben:"Kép - Kép (fül), ha ott látsz linket, akkor linkelve van a kép.
Kép_hivatkozással2.png


Ha másnak is el kell küldened a dokumentumot, akkor csakis a beágyazás lehet az elsődleges megoldás. (mert különben a képet külön kell átküldened a dokumentum mellett, és a link még akkor se biztos, hogy jól működik, a különböző könyvtárszerkezet miatt...)

Még egy kérdést kell tisztázni: milyen fajtájú képről van szó? bmp, gif, jpg, png... stb.?


(csak megnyugtatásul: a 3.2.1-ben sem tapasztaltam ilyen jelegű hibát (bár én abból a GoOO alapú OxygenOffice-t használtam...), tehát valószínűleg - hacsak nem sérült a fájlod - valami egyszerű beállításbeli problémával állunk szemben...
Az angol fórumon viszont vannak ilyen bejegyzések a problémával kapcsolatban:
http://user.services.openoffice.org/en/ ... or#p185432
http://user.services.openoffice.org/en/ ... or#p111514
http://user.services.openoffice.org/en/ ... ror#p98766
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3474
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: BBoy » 2011. május 22., vasárnap 23:19

Zizi64 írta:
Első kérdésem:
Linkelt, vagy beágyazott képekről van szó?

Miből tudom ezt a legegyszerűbben megállapítani?


Ha te tetted be képeket a dokumentumba, akkor gondolom tudod, hogy beágaztad, vagy linkelted.
Ha készen kaptad a dokumentumot, akkor is meg lehet állapítani, hogy milyen módon kapcsolódik a dokumentumhoz. Ha "csak" linkelve van, akkor abban az esetben, ha a dokumentum megnyitásakor nem érhető el a kép tárolóhelye (internet, helyi hálózat, külső vincseszter, pendrájv, stb.) akkor az OOo/LibreOffice természetesen nem tudja megjeleníteni a képet, csak a keretet, a "helyét" tudja mutatni...
A hivatkozás típust a "Szerkesztés - Hivatkozások" menüpont alatt tudod leellenőrizni.
Ha van kép típusú fájl linkelve a megjelenő listában, akkor linkelve van a kép. Ha a menüpont szürke (inaktív), akkor semmi nincs linkelve a fájlodhoz; minden, amit egyébként benne látsz az benne is tárolódik, benne is helyezkedik el.


Ez a menüpont szürke. Tehát minden kép csatolva van a dokumentumban!

Zizi64 írta:Ha másnak is el kell küldened a dokumentumot, akkor csakis a beágyazás lehet az elsődleges megoldás. (mert különben a képet külön kell átküldened a dokumentum mellett, és a link még akkor se biztos, hogy jól működik, a különböző könyvtárszerkezet miatt...)

Még egy kérdést kell tisztázni: milyen fajtájú képről van szó? bmp, gif, jpg, png... stb.?


Jellemzően JPEG, esetleg TIFF ill. elég sok - igazából a legtöbb WMF (vektoros) képről van szó. De az nem volt jellemző, hogy melyiknél jön elő a hiba. Ez így vegyesen fordult elő.

Egyébként időközben elkészült a végleges dokumentum. (Egyébként egy szakdolgozatról volt szó!) De a hibajelenség ugyanúgy megmaradt. Sőt, már korábban is tapasztaltam ezt a hibajelenséget más dokumentumoknál is!

Szóval számomra még mindig rejtély, hogy miért csinálja ezt az OpenOffice!?

Zizi64 írta:(csak megnyugtatásul: a 3.2.1-ben sem tapasztaltam ilyen jelegű hibát (bár én abból a GoOO alapú OxygenOffice-t használtam...), tehát valószínűleg - hacsak nem sérült a fájlod - valami egyszerű beállításbeli problémával állunk szemben...
Az angol fórumon viszont vannak ilyen bejegyzések a problémával kapcsolatban:
http://user.services.openoffice.org/en/ ... or#p185432
http://user.services.openoffice.org/en/ ... or#p111514
http://user.services.openoffice.org/en/ ... ror#p98766
BBoy
 
Hozzászólások: 7
Csatlakozott: 2008. március 6., csütörtök 10:47

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: Zizi64 » 2011. május 23., hétfő 7:10

Ez a menüpont szürke. Tehát minden kép csatolva van a dokumentumban!

Akkor úgy érted: BEÁGYAZVA vannak a képek?
Mekkora méretű lett összesen a fájlod?
Mekkora ehhez képest a processzorod teljesítménye, mekkora a rendszermemória?

Jellemzően JPEG, esetleg TIFF ill. elég sok - igazából a legtöbb WMF (vektoros) képről van szó.

Akkor legalább töltsél fel ide néhány problémás képet! Megnézzük, nálunk is úgy viselkedik-e? 128 kiB max! De belinkelhetsz külső tárhelyeket is (MediaFire, stb.) a nagyobb képeknek.

Érdemes azonos típusba konvertálni a képeket használat előtt. Erre a legalkalmasabb a .PNG (portable network graphic) formátum. "Windows-os találmányokkal" - mint a WMF - hamarabb lehet probléma. Szinte bármilyen okosabb képnézegetőnek van konvertáló funkciója, én az InfanView-et használom leggyakrabban.

Milyen (dokumentum) fájltípust használsz? Ez sajnos nem látszik az először felrakott képeiden. Mindig odt-ben dolgozz! Abban mentsd el a munkádat, azt is nyisd meg, ha folytatni akarod, csak másodpéldányt ments idegen formátumba!

Nem tudok egyelőre többet segíteni...

probléma a többlapos TIFF-ekkel:
http://user.services.openoffice.org/en/ ... ff#p158854
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3474
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: BBoy » 2011. május 24., kedd 0:29

Zizi64 írta:
Ez a menüpont szürke. Tehát minden kép csatolva van a dokumentumban!

Akkor úgy érted: BEÁGYAZVA vannak a képek?

Igen, beágyazva. Sorry, ezt elírtam tényleg!!!
Zizi64 írta:Mekkora méretű lett összesen a fájlod?

3-4MB-os fájlról beszéltünk jelen esetben...
Zizi64 írta:Mekkora ehhez képest a processzorod teljesítménye, mekkora a rendszermemória?

Intel Dual Core E6600, 2GB DDR2 RAM. Nem hinném, hogy ezzel lenne probléma?!

Zizi64 írta:
Jellemzően JPEG, esetleg TIFF ill. elég sok - igazából a legtöbb WMF (vektoros) képről van szó.

Akkor legalább töltsél fel ide néhány problémás képet! Megnézzük, nálunk is úgy viselkedik-e? 128 kiB max! De belinkelhetsz külső tárhelyeket is (MediaFire, stb.) a nagyobb képeknek.

Érdemes azonos típusba konvertálni a képeket használat előtt. Erre a legalkalmasabb a .PNG (portable network graphic) formátum. "Windows-os találmányokkal" - mint a WMF - hamarabb lehet probléma. Szinte bármilyen okosabb képnézegetőnek van konvertáló funkciója, én az InfanView-et használom leggyakrabban.

Milyen (dokumentum) fájltípust használsz? Ez sajnos nem látszik az először felrakott képeiden. Mindig odt-ben dolgozz! Abban mentsd el a munkádat, azt is nyisd meg, ha folytatni akarod, csak másodpéldányt ments idegen formátumba!


Csakis ODT formátumot használtam végig.

Zizi64 írta:Nem tudok egyelőre többet segíteni...

probléma a többlapos TIFF-ekkel:
http://user.services.openoffice.org/en/ ... ff#p158854


Többlapos TIFF-et nem használtam, ez biztos!
BBoy
 
Hozzászólások: 7
Csatlakozott: 2008. március 6., csütörtök 10:47

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: telmerk » 2015. február 16., hétfő 12:52

Sajnos nálam is elő-elő bukkan ez a probléma, én szinte kizárólag jpg-ket használok beágyazva, karakterként horgonyozva körbefuttatás nélkül. Jellemzően nagyobb dokumentumoknál jön elő (50+ oldal).
Ezt használom:
Verzió: 4.2.7.2
Build az.: 420m0(Build:2)
4*Intel core i3, CPU M370 @2,4GHz
1.8GB RAM
Avatar
telmerk
Önkéntesek
 
Hozzászólások: 55
Csatlakozott: 2008. március 14., péntek 9:53
Tartózkodási hely: Closed office

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: Zizi64 » 2015. február 16., hétfő 15:15

én szinte kizárólag jpg-ket használok beágyazva,


1.: "Szinte kizárólag", vagy kizárólag? És biztos, hogy mindegyik jpeg fájl, vagy csak az a kiterjesztése? (a neten rengeteg olyan kép kering a különböző oldalakon és dokumentumokban, aminek van egyfajta kiterjesztése, de valójában egy másik képformátum van a fájlban. Ezt a megoldást biztonsági eszközként szokták bevetni, hogy nehezebben lehessen ellopni a képeket.

2.: Biztos, hogy minden kép beágyazva került a dokumentumba?

3.: Mindig ( minden megnyitáskor) ugyanazok a képek tűnnek hibásnak?

4.: Mekkora méretű (Bájtméretű) képekről, és hány darabról van szó egy adott dokumentum esetében? Mekkora a dokumentum fáj összmérete a képekkel együtt?

5.: Milyen operációs rendszeren dolgozol?

6.: Milyen fájltípusba mented a munkádat?

7.: Ha a fájlod egy MÁSOLATÁT .zip-ra átnevezed, akkor megtalálható az archívumban az összes beágyazott kép? ha azokat onnan kimásolod egy normál könyvtárba, akkor képnézegetővel mindegyik megnyílik gond nélkül ?

Ide kellene linkelned egy olyan fájlodat, ami problémás, de publikus a tartalma. Azt letöltve meg tudnám nézni, hogy mi okozhatja a gondot... Feltölteni csak 128 KiB-ig tudsz ide a fórumra.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3474
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: telmerk » 2015. február 16., hétfő 16:21

1. Nem, nem kizárólag. Nagyrészt jpg (kiterjesztés alapján), de sokszor előfordul, hogy képernyőképet lopok, s utána CTRL-V-vel beillesztem a dokumentumba.

2. Biztos.

3. Nem, nem mindig. Ha viszont időben észreveszem, hogy nem sikerült betölteni egy képet, akkor újratöltésel, vagy becsukás-kinyitással újra megjelenik helyesen a kép. Viszont nyilván, ha már rámentettem a dokumentumra (mármint felülírtam), akkor már elveszett a kép, a helye sem jelenik meg a dokumentumban.

4. A fájl per pill. 8MB-os, 46 db képpel. Amikor beillesztema képet, akkor ha nem ront nagyon a láthatóságán, akkor minden esetben tömörítem.

5. Kubuntu. 14.04.

6. odt.

7. Igen, megvan mind, és meg is lehet nyitni őket. Sajnos publikus fájlom az nincsen, de amint lesz, töltök fel ide egyet!

Köszönettel:
TtM
Avatar
telmerk
Önkéntesek
 
Hozzászólások: 55
Csatlakozott: 2008. március 14., péntek 9:53
Tartózkodási hely: Closed office

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: Zizi64 » 2015. február 16., hétfő 16:40

1. Nem, nem kizárólag. Nagyrészt jpg (kiterjesztés alapján), de sokszor előfordul, hogy képernyőképet lopok, s utána CTRL-V-vel beillesztem a dokumentumba.
És az milyen formátumú? (Milyen formátumú lesz a fájlban?) Ezt mindenképpen jó lenne tudni...

2. Biztos. (beágyazva mind)
Meg kéne próbálnod linkelve használni a képeket, vagy - annak megfelelően, hogy nyomtatva, vagy képernyőn lesz használva a dokumentum csökkenteni a felbontását, esetleg a színmélységét is. Látva, hogy mekkora méretű lesz a fájlod összességében, ez is sokat segítene.

3. Nem, nem mindig. Ha viszont időben észreveszem, hogy nem sikerült betölteni egy képet, akkor újratöltésel, vagy becsukás-kinyitással újra megjelenik helyesen a kép. Viszont nyilván, ha már rámentettem a dokumentumra (mármint felülírtam), akkor már elveszett a kép, a helye sem jelenik meg a dokumentumban.
Mekkora memóriát állítottál be a képek számára a Beállítások erre vonatkozó részében?

4. A fájl per pill. 8MB-os, 46 db képpel. Amikor beillesztem a képet, akkor ha nem ront nagyon a láthatóságán, akkor minden esetben tömörítem.
Ez kicsit nagy fájlméret... Hiszen maga az .odt is egy tömörített forma...

5. Kubuntu. 14.04.
Sajnos ilyenem sosem volt (csak Ubuntu-m, de azt se használtam folyamatosan, csak ismerkedtem vele...)

6. odt.
HELYES!!!! :-)

7. Igen, megvan mind, és meg is lehet nyitni őket. Sajnos publikus fájlom az nincsen, de amint lesz, töltök fel ide egyet!
Hááát... ha a képek maguk nem hibásak, akkor a SOK kép, vagy a NAGY képek, vagy a KEVÉS memória, esetleg a NEM AJÁNLOTT fájlformátum lesz a gond...
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3474
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: telmerk » 2015. február 16., hétfő 16:47

1. Nem, nem kizárólag. Nagyrészt jpg (kiterjesztés alapján), de sokszor előfordul, hogy képernyőképet lopok, s utána CTRL-V-vel beillesztem a dokumentumba.
És az milyen formátumú? (Milyen formátumú lesz a fájlban?) Ezt mindenképpen jó lenne tudni...
:arrow: A zip fájlban ezek png kiterjesztésűek.
2. Biztos. (beágyazva mind)
Meg kéne próbálnod linkelve használni a képeket, vagy - annak megfelelően, hogy nyomtatva, vagy képernyőn lesz használva a dokumentum - csökkenteni a felbontását, esetleg a színmélységét is. Látva, hogy mekkora méretű lesz a fájlod összességében, ez is sokat segítene.
:arrow: Nos ez igen nagy meló! :(
3. Nem, nem mindig. Ha viszont időben észreveszem, hogy nem sikerült betölteni egy képet, akkor újratöltésel, vagy becsukás-kinyitással újra megjelenik helyesen a kép. Viszont nyilván, ha már rámentettem a dokumentumra (mármint felülírtam), akkor már elveszett a kép, a helye sem jelenik meg a dokumentumban.
Mekkora memóriát állítottál be a képek számára a Beállítások erre vonatkozó részében?
:arrow: Képgyorsítótár, LibreOffice által használt: 20MB / Memória objektumonként: 5,2MB / Törlés a memóból 10 perc után / beszúrt objektumok gyorsítótára, obj száma 20.
7. Lehet, hogy memória-problémáim vannak?? :?:
Avatar
telmerk
Önkéntesek
 
Hozzászólások: 55
Csatlakozott: 2008. március 14., péntek 9:53
Tartózkodási hely: Closed office

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: Zizi64 » 2015. február 16., hétfő 19:10

Mekkora memóriát állítottál be a képek számára a Beállítások erre vonatkozó részében?
:arrow: Képgyorsítótár, LibreOffice által használt: 20MB / Memória objektumonként: 5,2MB / Törlés a memóból 10 perc után / beszúrt objektumok gyorsítótára, obj száma 20.
7. Lehet, hogy memória-problémáim vannak?? :?:


...és ehhez képest 46 kép van a fájlodban...

Továbbá nem tudom biztosan, de feltételezem, hogy amikor a képernyőn megjelenik egy beszúrt kép, akkor az a memóriában nem jpg tömörítéssel van jelen - hiszen látszik minden pixel külön-külön (azok is, amik a kép-fájlban egyetlen adattal vannak leírva, a tömörítés miatt), azaz több memóriát "fogyaszt".

Nálam 100 MiB van beállítva a képekhez összesen, és 50 db objektum kezelésének lehetősége. Ezt még egy dokumentumom se lépte túl.

Meg kell fontolnod, hogy egy ilyen nagy fájlban kell-e neked az a funkció, hogy a képek folyamatosan látszanak. Ki lehet ugyanis kapcsolni a képek megjelenítését, helyettük ilyenkor csak egy téglalap látszik. Ezzel a módszerrel sokkal gyorsabb tud lenni a program. A képek beillesztésének idejére, az igazításokhoz persze ezt a funkciót bekapcsolhatod, de aztán célszerű kikapcsolni, ha ennyi és ilyen nagy összméretű képet, képcsoportot akarsz kezelni.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3474
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: Zizi64 » 2015. február 17., kedd 9:16

Nagyrészt jpg (kiterjesztés alapján), de sokszor előfordul, hogy képernyőképet lopok, s utána CTRL-V-vel beillesztem a dokumentumba.


Jobb lenne, ha külső képszerkesztővel konvertálnád .png formátumba egy megfelelő átméretezés után. A mai képernyőképek irdatlan nagy mennyiségű pixelből állnak. Egy A/4-es oldalra - főleg, ha álló pozíciójú oldalra illeszted be - mi a jó égnek kell egy 1920x1200 pixeles méretű, milliószínű kép? Csak problémákat fog okozni.

...Persze a munkát ki lehet váltani némi elszenvedett bosszúsággal... :lol:
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3474
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

[Megoldva] Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: telmerk » 2015. február 20., péntek 12:23

Nálam 100 MiB van beállítva a képekhez összesen, és 50 db objektum kezelésének lehetősége. Ezt még egy dokumentumom se lépte túl.

Beállítottam, megoldódni látszik a probléma! :) Köszönöm a segítséget! :super:
Avatar
telmerk
Önkéntesek
 
Hozzászólások: 55
Csatlakozott: 2008. március 14., péntek 9:53
Tartózkodási hely: Closed office

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: EndreszZ » 2015. április 15., szerda 8:21

Szép napot!

Sajnos az eltűnő képek problémájával én most találkoztam. Rendkívül bosszantó. A történet:
Van egy tudásbázis féle Writer doksim, .odt formában, amit évek óta vezetek. Amikor beleírok valami újdonságot, elmentem új néven (a fájl neve tartalmazza az aktuális dátumot).
Több hasonló doksim is van, évek óta vezetem őket problémamentesen. A beszúrt képek nem linkeltek.

Most fedeztem fel, hogy a 2-3 verzióval ezelőtti vátozatban megvannak a képek, az újabbakban némelyik nem látszik. Ami érdekes az az, hogy ha megnyitok egy régit, majd mindenféle változtatás nélkül elmentem azt a mai dátummal, akkor az új már hibás lesz. Ha a régit kiexportálom .pdf-be, az rendben megjelenik. Próbáltam a "Mentés másként" és a "Másolat mentése" funkciókkal is, az eredmény ugyanaz. A doksi mérete 6-7 MB.

A fentebb ajánlott változtatásokat megejtettem a "Beállítások" pont alatt, jelenleg:

Graphics cache use for LibreOffice: 100 MB
Memory per objects: 5 MB
Number of objects: 100

LibreOffice 4.4.1.2, Debian Wheezy alatt

Nagyon hálás lennék a segítségért!
Köszönöm előre is.

P.S.: A LibreOffice user profil reset nem oldotta meg a problémát, viszont a hatására megjelentek a korábban eltűnt ablak bezáró/minimalizáló/maximalizáló kezelő elemek a sarokból.
LibreOffice 4.4 Debian Wheezy-n
EndreszZ
 
Hozzászólások: 5
Csatlakozott: 2015. április 15., szerda 7:51

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: Zizi64 » 2015. április 15., szerda 9:42

És Linux verzió frissítés is volt az utóbbi időben?

Továbbá:
A képek milyen formátumúak? Leginkább a .png formátum ajánlott, és lehetőleg ne legyenek különböző típusú fájlok beágyazva!

A képgyorsítótár méretét ne a dokumentum méretéhez, sőt ne is a képek sűrített formában megadott méretéhez, hanem az általad körülbelül kiszámított képszám*képenkénti pixelszám*3 értékhez állítsd (a pixelek és azon belül a 3 alapszín mértéke külön-külön bájtban van tárolva olyankor, amikor a kép megjelenik a képernyődön - tehát gyakorlatilag "bitmap" szintig ki kell bontania a programnak a sűrített fájlformátumú képeket a helyes megjelenítéshez. Ehhez pedig rengeteg memória kellhet - a képek számának és tulajdonságainak függvényében.

Javasolni tudom még annak a funkciónak a használatát, hogy a képek valós megjelenését ki tudod kapcsolni. Csak a befoglaló méret marad meg egy téglalap alakjában. Ez akkor lehet hasznos, ha az eredeti natív fájlformátumot csak a szerkesztésre (az újabb dolgot beillesztésére) használod, az olvasgatáshoz pedig mindig készítesz egy PDF verziót.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3474
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: EndreszZ » 2015. április 15., szerda 9:59

Volt linux frissítés, most 3.2.0-4-686-pae #1 SMP Debian 3.2.65-1+deb7u1, de nem hiszem, hogy ez lenne a hiba. Időközben teszteltem ugyanis Windows alatt is, a szóban forgó jó fájlt megnyitottam majd elmentettem változás nélkül, és a hiba azonnal jelentkezett.

Sajnos nem tudom, hogy milyen képeket illesztettem be régebben, szerintem csak .jpg és .png formátumokat. A gyorsítótár méretét szimplán csak megsokszoroztam az eddigiekhez képest, nem számolgattam.

Ami közös az az, hogy mindkettőn (céges windows gép + linux laptop) frissítettem a közemúltban a LibreOffice-t a mostani 4.4.1.2 -re.
Na, mindjárt keresek valami régebbi 3.x-et...
LibreOffice 4.4 Debian Wheezy-n
EndreszZ
 
Hozzászólások: 5
Csatlakozott: 2015. április 15., szerda 7:51

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: EndreszZ » 2015. április 15., szerda 14:58

Üdvözlet!

Új infó: a Windows-os gépen letöröltem a 4.4.1.2 -es LibreOffice-t és feltettem egy 4.0.1.2 -t. A hibajelenség megszűnt.
Ez lesz a sorsa a Debian-os változatnak is, amint egy kissé ráérek.

Szóval szerintem valami bug lesz a bűnös. Ha ezzel az infóval segítettem valakinek, akkor örülök.

Szép napot!
LibreOffice 4.4 Debian Wheezy-n
EndreszZ
 
Hozzászólások: 5
Csatlakozott: 2015. április 15., szerda 7:51

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: Zizi64 » 2015. április 15., szerda 16:38

Szóval szerintem valami bug lesz a bűnös.


Lehet, hogy igazad van, az én dokumentumaim sohasem haladták meg azt a küszöböt, ahol a hiba már jelentkezett volna...
De abban nem bízzál túl erősen, hogy az adott számú Linuxos és a Windows-os verziók majd pont ugyanúgy működnek az aktuális bug-ok szempontjából... ;)
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3474
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: EndreszZ » 2015. április 23., csütörtök 10:01

Üdv!

Új infó:
A mai napon leszedtem a problémás LibreOffice-t az egyik linux-os gépemről, és egy merészet gondolva a lehető legfrisebbet töltöttem le és telepítettem (v4.4.3.1)
Jelentem, a fentebb vázolt képeltűnési hiba nem jelentkezik, user örül! :D Az alapbeállításokat hagytam, nem bizgettem semmi memória meg cache beállítást.
Úgy tűnik, hogy úgy a downgrade, mint az upgrade megoldás lehet a problémára.

Remélem segítettem, szép napot:

E.Z.
LibreOffice 4.4 Debian Wheezy-n
EndreszZ
 
Hozzászólások: 5
Csatlakozott: 2015. április 15., szerda 7:51

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: Zizi64 » 2015. április 23., csütörtök 11:45

Bátor vagy! :D
A 4.4.3.1 még csak előzetes verzió, nem véglegesen kiadott... Főleg az önkéntes tesztelőknek való. (Még én se szoktam ilyen korán letölteni egy új verziót. De ez mindenképpen hasznos lehet a projekt szempontjából.
Jelezz a fejlesztők felé, ha találsz valami kritikus bug-ot.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3474
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: "Olvasási hiba" képeknél >>> Eltűnő képek!!!

HozzászólásSzerző: EndreszZ » 2015. április 23., csütörtök 11:54

Rosszabb nem lett... :-)
LibreOffice 4.4 Debian Wheezy-n
EndreszZ
 
Hozzászólások: 5
Csatlakozott: 2015. április 15., szerda 7:51


Vissza: Writer

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég

cron