Nincs hiperhivatkozás kezdete/vége gomb

Szövegszerkesztő

Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: x00 » 2015. január 16., péntek 22:23

LibnreOffice 4.3-ban a tartalomjegyzék szerkesztésénél nincs hiperhivatkozás kezdete/vége gomb, így nem lehet vele ilyeneket létrehozni, ezek nélkül a tartalomjegyzékben Ctrl+kattintás hatására nem ugrik a fejezetre. A korábbi verziókban készült tartalomjegyzékek jók, szerkesztésükkor látszik hogy ezek bennevannak, de újat létrehozni már nem lehet mert nincs gomb amivel létrehozhatnám, így ha kitörlöm, nem tudom visszatenni. Ez most hiba vagy valami más van helyette. Ha más, mi? Ha hiba, bejelentem az angol bugzillába. Köszönöm.
Magyar OpenOffice.org 4.1.1 + mindig frissített magyar LibreOffice 4.4, teljesen befrissített magyar 64 bites Windows 7 Home Premium SP1, IBM PC kompatibilis, 2 GB DDR3 1600 MHz, Intel Celeron 1000M (2*1,8 GHz).
x00
Önkéntesek
 
Hozzászólások: 43
Csatlakozott: 2011. június 19., vasárnap 12:26

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: Zizi64 » 2015. január 16., péntek 23:50

http://libreoffice.hu/2014/12/18/libreo ... /#comments

Lehet, hogy a fenti link alatt is te írtál erről a jelenségről? (A neveket - még ha alá is írtad itt valamelyik hozzászólásodat - nem túl gyorsan jegyzem meg...)

Mindenképpen megér annyit a dolog, hogy jelezd a magyar, vagy az angol hibabejelentőben. Én magam éles helyzetben (munkára) még a 4.2.8 verziót használom, így még nem is találkoztam ezzel a jelenséggel, de könnyen elképzelhető, hogy valóban hibáról (vagy nagyon hirtelen jött koncepcióváltásról) van szó.

Egy mintadokumentumra a hibabejelentéshez is szükség lesz, azt célszerű lenne ide is feltölteni.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.3, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3480
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: x00 » 2015. január 17., szombat 12:35

Bejelentettem az angol bugzillába: https://bugs.freedesktop.org/show_bug.cgi?id=88529

A libreoffice.hu-n azért kérdeztem hogy bejelentsem-e a hibát, itt meg azért mert ott nem válaszoltak. A példafájl régebbi LibreOffice-ban vagy OpenOffice.org-ban készült, már nem emlékszek. Ebben tehát működik, de ha kitörlöm, nem tudom visszatenni.

A 4.2-eset azért nem használom, mert 120 dpi-re van átállítva a Windows 96 dpi-ről, és a 4.1 és a 4.2 hibásan működik így. Valamelyik régebbi verzió jól működött, nem tudom melyik. 4.3-nál nincs olyan hogy a legördülő lista utolsó néhány eleme elérhetetlen, de a képernyő legasó során levő kurzor nem mindig lép lefele, amikor görgetni kellene, ekkor meg kell kicsit mozgatni, mondjuk először felfele. 96 dpi-ben nem próbáltam hogy előjön-e a hiba. Jelenleg OpenOffice.org 4.1.1-et használok. Bejelentettem: https://bugs.freedesktop.org/show_bug.cgi?id=88530
Csatolmányok
routines.odt
(46.24 KiB) 62 alkalommal.
Magyar OpenOffice.org 4.1.1 + mindig frissített magyar LibreOffice 4.4, teljesen befrissített magyar 64 bites Windows 7 Home Premium SP1, IBM PC kompatibilis, 2 GB DDR3 1600 MHz, Intel Celeron 1000M (2*1,8 GHz).
x00
Önkéntesek
 
Hozzászólások: 43
Csatlakozott: 2011. június 19., vasárnap 12:26

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: Zizi64 » 2015. január 17., szombat 13:31

Még most sem értem pontosan, hogy mi is a gond, mert ha törlöm a HK, B#, B, T, #, HV Bejegyzéseket, akkor minden gond nélkül újra létre tudom hozni azokat, azzal a megkötéssel, hogy a Hiperhivatkozás gomb első megnyomása HK, a következő megnyomása HV Bejegyzést hoz létre. (A kurzornak a bejegyzés melletti üres területen kell állnia a második megnyomás előtt.)

És úgy tűnik, hogy a módosított verzió működőképes is: a módosított bejegyzésekkel is működik a link, a kurzor a megfelelő fejezetcímre ugrik, a dokumentumban történő linkre kattintás után (nálam ki van kapcsolva a "Ctrl-Click" opció)

Nem is igazán emlékszem: a régebbi verziókban külön volt "Hiperhivatkozás eleje" és "Hiperhivatkozás vége" gomb?

Most csak egy van a jobb szélen a LO 4.3.5-ben a "Mind" gomb; az AOO4.1.1-ban az ugyanolyan funkciójú, de eltérő feliratú "Minden szintre" gomb alatt. Lehetséges, hogy nálad a fent említett képernyőfelbontás-váltás miatt nem látszik?
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.3, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3480
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: x00 » 2015. január 17., szombat 13:42

4.3.5.2 release. A felbontás maradt, csak a pixelsűrűséget állítottam át. Képet csatolom, nálam elbújt a gomb.
Csatolmányok
nobutton.jpg
Magyar OpenOffice.org 4.1.1 + mindig frissített magyar LibreOffice 4.4, teljesen befrissített magyar 64 bites Windows 7 Home Premium SP1, IBM PC kompatibilis, 2 GB DDR3 1600 MHz, Intel Celeron 1000M (2*1,8 GHz).
x00
Önkéntesek
 
Hozzászólások: 43
Csatlakozott: 2011. június 19., vasárnap 12:26

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: Zizi64 » 2015. január 17., szombat 13:58

De hát nálad az összes gomb hiányzik!

A felbontás maradt, csak a pixelsűrűséget állítottam át.

Jó, OK, értem... Valami összefüggés mégis lehet, mert ilyet én még nem láttam...

AOO tartalomjegyzék.png
AOO 4.1.1 - Win7 x64 prof. operációs rendszeren.


LO tartalomjegyzék.png
LO 4.3.5.2 - Win7 x64 prof. operációs rendszeren.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.3, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3480
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: Zizi64 » 2015. január 17., szombat 14:54

Egyébként nálad miért szükséges (vagy miért /lenne/ jó dolog) átállítani a DPI értéket?
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.3, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3480
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: x00 » 2015. január 17., szombat 16:54

15,6"-es 1366*768-as felbontású monitor a szememtől 0,66 méterre. Igazából 144 dpi-re kellene állítani, de sok program úgy már nem megy. Az a helyzet hogy a Windowsban épp a leggyakoribb karakterek méretét nem lehet állítani, csak a többit: ha például a Windows Intézőben kiadom a másolás mappába parancsot, a párbeszédablakban hogy adjam meg a helyét, olyan kis betűkkel jelenik meg hogy mikroszkóp kell hozzá. De a hibaüzenetek is. A menü, stb. méretét lehet állítani, pont a leggyakoribbat nem. 10 évig XP-t használtam 144 dpi-n, működött. Egyedül a kontrasztos módnak nevezett valaminél lesznek nagyobbak a betűk, ami annyira kontrasztos hogy a már hivatkozott linkeket alig látni mert lilák, például a Vezérlőpultban. Windows 7-ben is próbáltam, ott se volt jó. Egyébként ez a monitor kb. 0,252 mm-es képpontméretű, és réges rég van 0,1245 mm-es képpontméretű monitor is (24" 3840*2400, IBM, jó drága lehet): ahhoz ugye 3-szoros, vagyis 288 dpi-s beállítás kellene. Képzelem hogy néznének ki a már 120 dpi-n is hibás programok. Állítólag a Windows 8-nak már jobb a hi-dpi támogatása.

Apropó, akkor meg is lehetne erősíteni a hibabejelentést: unconfirmed-ről new-ra állítani. Korábban szóltak érte amikor magamnak állítottam át. Ezen hozzászólásom olvasóit megkérném rá.
Magyar OpenOffice.org 4.1.1 + mindig frissített magyar LibreOffice 4.4, teljesen befrissített magyar 64 bites Windows 7 Home Premium SP1, IBM PC kompatibilis, 2 GB DDR3 1600 MHz, Intel Celeron 1000M (2*1,8 GHz).
x00
Önkéntesek
 
Hozzászólások: 43
Csatlakozott: 2011. június 19., vasárnap 12:26

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: Zizi64 » 2015. január 17., szombat 17:21

Gondolom, a tiéd laptop monitor valójában, mert a 15 colos monitor asztali kivitelben manapság már igencsak kicsinek számít. A kifejezetten használt számítástechnikai termékeket forgalmazó cégeknél, mint a PC-Aréna, vagy a Hadrianus, és a Finn PC (ezeket ismerem, mert ezeknél szoktunk vásárolni) igen kedvező áron lehet beszerezni 22-24 (néha 27 colos) monitorokat is.

Nekem 24 colos monitorom van (használtan nem is volt annyira drága, bár ez is csak 0,277 mm pixelmérettel bír és 1920x1080 felbontással) de semmi ilyesmi problémám nincs vele (a sok monitornézéstől, meg koromból adódóan az olvasáshoz, forrasztáshoz, monitoron történő munkavégzéshez persze már szemüveg kell, de néha azt is elhagyom, mert a lényeget szabadon nagyíthatom szinte minden programban, az apró betűs menüre meg (még) emlékszem...) :)

Úgyhogy én azt sem tudom, hogy hol lehetne átállítani a Windowsban ezt a 96 dpi-s értéket, inkább a hardver fejlesztésével és a nagyítási lehetőségek alkalmazásával oldottam meg a dolgot...
Még ha laptopról is van szó az esetedben, akkor is célszerű mellé egy nagyobb monitort használni (már ha a vele végzett munka többségében helyhez kötött...)
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.3, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3480
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: x00 » 2015. január 17., szombat 17:42

Természetesen laptop, HP 250 G1. A Vezérlőpultban lehet állítani, a lényege, hogy ha például 96 dpi-ről 144-re átállítjuk, akkor a ha program arra ad utasítást a kernelnek/drivernek hogy 10-es méretben írjon ki valamit a képernyőre, akkor 15-ösben fogja kiírni. A laptopot nem szoktam szállítani, de egy hibás program miatt felesleges lenne monitort venni, egyébként is van, 0,264 mm-es, és annál is kicsi még a 120 dpi is, 0,32 mm fölötti kellene, akkor meg recések a betűk, meg ma már ilyet szerencsére nem gyártanak. Az a probléma hogy pont a leggyakoribb méretét nem lehet állítani. Ráadásul most megúszom 1 forint/óra áramszámlával. Amíg ki nem javítják, használom az OpenOffice.org 4.1.1-et, abban nincs ilyen hiba. Én épp fordítva gondolkodok, nyáron egy 0,15-0,162 mm-eset akarok venni hoyg ne legyenek olyan recések a betűk, és 2,5-szeresre állítom a dpi-t (240 dpi) ha majd a Windows 10-be se lehet az alapértelmezett fontméretet állítani, amit a leggyakrabban használ. Ha lehet, akár maradhat 96 dpi-n is. Ha valaki megerősítené a hibabejelentést, rátenném hogy [Megoldva].
Magyar OpenOffice.org 4.1.1 + mindig frissített magyar LibreOffice 4.4, teljesen befrissített magyar 64 bites Windows 7 Home Premium SP1, IBM PC kompatibilis, 2 GB DDR3 1600 MHz, Intel Celeron 1000M (2*1,8 GHz).
x00
Önkéntesek
 
Hozzászólások: 43
Csatlakozott: 2011. június 19., vasárnap 12:26

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: Zizi64 » 2015. január 17., szombat 18:33

Ha valaki megerősítené a hibabejelentést,
...
Ezen hozzászólásom olvasóit megkérném rá.

Hát ez nem tőlünk függ... Nem baj az, ha a valódi megoldásig itt ezen a fórumon is megoldatlannak látszik a probléma. Ha én asszisztálnék a hibabejelentés állapotváltásához, azzal egy centivel sem haladna előre a dolog, mert én biztos nem fogok tudni egy kódsort sem (egy kód-karaktert sem) változtatni a forráskódon...

Én épp fordítva gondolkodok, nyáron egy 0,15-0,162 mm-eset akarok venni hoyg ne legyenek olyan recések a betűk, és 2,5-szeresre állítom a dpi-t (240 dpi)
...
de egy hibás program miatt felesleges lenne monitort venni,


De az előbb írtad, hogy más programok is nehezen viselik ezt a fajta átállítást:
Igazából 144 dpi-re kellene állítani, de sok program úgy már nem megy.
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.3, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3480
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: Zizi64 » 2015. január 17., szombat 19:05

És egyébként próbáltad már visszaállítani 96 dpi-re az értéket? Akkor megjelennek a gombok? Vagy ahhoz lehet, hogy úja kell telepíteni a programot?
A fejlesztőknek is sokat segítene, ha a két probléma összefüggését meg tudnád határozottan állapítani, vagy ki tudnád zárni, és az eredményt jeleznéd feléjük...
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.3, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3480
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: x00 » 2015. január 17., szombat 19:28

Természetesen megjelennek a gombok. Programozóként ezt már kipróbálás előtt is tudtam: ugyanis ha telepítéskor kérdezné le és tárolná el, azzal a készítőknek lenne több dolguk, hajszálnyival lassabb lenne és több helyet foglalna, és ha telepítés után átállítom, mégrosszabb megjelenés lenne. Szóval annak semmi értelme se lenne. Inkább a program indulásakor kell lekérdezni, a képi elemek közötti távolsághoz fontos figyelembe venni a nagyítást, meg az ablak méreténél. Grafikus felhasználói felületű programok készítéséhez én se értek egyébként, csak a működési elvüket ismerem.

Egyébként XP SP1-ben már volt ilyen beállítási lehetőség, tehát már több mint 12 éve van. De az is lehet hogy mégrégebben van már, nem emlékszek hogy Windows 3.1-ben volt-e. Remélem a programozók fel fognak zárkózni a korhoz, ideje lenne. Nemrég jelent meg egy 27"-es 5120*2880-as monitor, 0,12 mm alatti képpontmérettel. És a megfizethető áru monitorok felbontása is nő. nyárra 3840*2160-as 100 000 forint körülire várható: 0,162 mm 28"-nél. 40"-es ugyanilyen felbontású smart tv 160 000-ért volt karácsonyi akcióban, szóval nemsokára elterjedtek lesznek, főleg Amerikában és Nyugat-Európában.

Egyébként köszönöm a segítséget hogy rájöttünk végre mi a hiba oka.
Magyar OpenOffice.org 4.1.1 + mindig frissített magyar LibreOffice 4.4, teljesen befrissített magyar 64 bites Windows 7 Home Premium SP1, IBM PC kompatibilis, 2 GB DDR3 1600 MHz, Intel Celeron 1000M (2*1,8 GHz).
x00
Önkéntesek
 
Hozzászólások: 43
Csatlakozott: 2011. június 19., vasárnap 12:26

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: Zizi64 » 2015. január 17., szombat 22:25

Upsz! Töltöttem fel képet a hibabejelentésedhez, de véletlenül "elavulttá" tettem a te képedet (át van húzva a linkje, de szerencsére továbbra is működik, elérhető a képed. Ha tudod hogyan kell, módosítsd vissza az eredeti állapotra (én nem jöttem rá, hogy hogyan kellene). (Elnézést!)

https://bugs.freedesktop.org/show_bug.cgi?id=88529
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.3, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3480
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: Zizi64 » 2015. január 17., szombat 22:32

No, úgy látom, hogy sikerült javítanod, vagy megjavult magától, vagy én hülyülök, és nem is volt áthúzva?
(az elsőre tippelek, mert most látom, van új hozzászólásod az enyém után.)
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.3, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3480
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Nincs hiperhivatkozás kezdete/vége gomb

HozzászólásSzerző: x00 » 2015. január 22., csütörtök 22:03

Igen én állítottam vissza. Volt olyan hogy törölt csatolmányok, bejelentkezve az adatoknál (details) tudtam módosítani: obsolete-ről átállítottam. Majd Save.

Egyébként az unconfirmed -> new (megerősítetlen -> új) átállítás azt jelenti, hogy a hiba valóban létezik, nem azt, hogy aki megerősítette, el is vállalta a javítását. Amikor magamnak állítottam át, szóltak érte és vissza is állították.
Magyar OpenOffice.org 4.1.1 + mindig frissített magyar LibreOffice 4.4, teljesen befrissített magyar 64 bites Windows 7 Home Premium SP1, IBM PC kompatibilis, 2 GB DDR3 1600 MHz, Intel Celeron 1000M (2*1,8 GHz).
x00
Önkéntesek
 
Hozzászólások: 43
Csatlakozott: 2011. június 19., vasárnap 12:26


Vissza: Writer

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég