OO2.4 kapcsolótábla használatához regisztráció

Makró készítés, parancsfájl írás és az API használata

OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: NagyL » 2012. július 27., péntek 11:37

SUN OO2.4-et szeretnék regisztrálni, de a firefox "A kiszolgáló nem található" hibaüzenetet ad. A regisztrációra azért van szükségem mert - itt a fórumon olvastam -, hogy a kapcsolótábla (swichboard) kiegészítőt csak ez után tudom használni.
sun oo2.4, win98, xp
NagyL
 
Hozzászólások: 7
Csatlakozott: 2012. július 27., péntek 11:15

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: Zizi64 » 2012. július 27., péntek 12:23

A Sun már régen nem foglalkozik az OpenOffice projekttel. (Átadta az Oracle-nak, aki meg már átadta az Apache-nak. (A sok tulajdonosváltás körüli ellehetetlenülés volt az egyik oka a LibreOffice létrejöttének, de mára újra beindult az Apache OpenOffice projektje is.)
Arról nincs tudomásom, hogy a Sun a saját fizetős verzióját viszi-e tovább, vagy hogy egyáltalán támogatja-e (ő támogatja-e) még...)

A 2.4 verzióra azért van szükséged, mert az még futott a Win9x rendszereken is?
Mert egyébként (ha nem ez az oka) felejtsd el, és használd a mostani legújabb LibreOffice 3.3.5-öt, vagy az OpenOffice 3.4-et.
(azt nem mondom, hogy FRISSÍTS, mert ilyen régi verzióról nem fogy működni a TELJES eltávolítás nélküli rátelepítés sem, nagy valószínűséggel...)

Kapcsolótáblát sose használtam, az ügyben nem tudok segíteni...
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3468
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: NagyL » 2012. július 27., péntek 12:36

Igen win98-on vagyok kénytelen használni az oo-t. Az xp-s gépen libreoffice van.

A kapcsolótáblát az eseménykezelőn keresztül lehet használni, ha jól értelmezem, mintha makrót adnál hozzá. Nálam annyi látszik, hogy a kapcsolótáblát hozzáadtam, de nem nyílik ki úgy, mint a saját makró - modul1 ahol láthatók az általam írt makrók.
sun oo2.4, win98, xp
NagyL
 
Hozzászólások: 7
Csatlakozott: 2012. július 27., péntek 11:15

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: Zizi64 » 2012. július 27., péntek 12:40

A mások által írt kiterjesztések nem biztos, hogy a Standard könyvtárba kerülnek, és az se biztos, hogy Basic nyelven vannak megírva. Kerested egy másik nyelv, másik könyvtárában is?

(Szerintem a 2.4-nek még a kiterjesztéskezelője is másmilyen volt, ha jól emlékszem...)
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3468
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: NagyL » 2012. július 27., péntek 13:19

Nem tudom értelmezni amit írtál.
- Mi az, hogy Standard könyvtár?
-Hogyan kell keresni másik nyelv másik könyvtárában?

Én a kapcsolótáblát úgy adtam hozzá, hogy az Eszközök/Kiterjesztéskezelő/Hozzáadás... után kitallóztam a helyét.
sun oo2.4, win98, xp
NagyL
 
Hozzászólások: 7
Csatlakozott: 2012. július 27., péntek 11:15

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: NagyL » 2012. július 27., péntek 13:29

Közben megpróbáltam újabb, az oo3.4-et felrakni, de el sem indult. Most visszaraktam egy FSF oo2.3-at, de azt sem tudtam regisztrálni. A kapcsolótáblát hozzáadtam az előbb leírtak szerint, de ebben a kiadásban már nem látszik a makrók között.
sun oo2.4, win98, xp
NagyL
 
Hozzászólások: 7
Csatlakozott: 2012. július 27., péntek 11:15

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: Zizi64 » 2012. július 27., péntek 13:43

Közben megpróbáltam újabb, az oo3.4-et felrakni, de el sem indult.

XP operációs rendszeren?
Melyik service pack van fenn?
Java van?

XP-n futnia kell, de az előző nagyon régi verziót szőröstül-bőröstül el kell távolítani a telepítés előtt! (Program files mappa, és a Documents and Settins ide vonatkozó alkönyvtárainak tartalmát - az ottfelejtett fájlokat - kézzel kell törölni!)
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3468
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: Zizi64 » 2012. július 27., péntek 13:48

A menü-fa végén látszanak az elérhető programnyelvek. Nem minden programnyelvhez van beépített IDE, azaz fejlesztő környezet. A LO3.5.4-ben sincs még például Pythonhoz. Ezeket a makrókat az Office programon kívül kell megírnod, itt csak futtatni tudod azokat (már ha hibátlanok) A Basic alatt viszont találsz szerkesztési, menedzselési lehetőséget is.:

Makrók helye1.png


A Basic - Saját makrók - Standard könyvtára tartalmazza azokat a Modulokat, amiket te hoztál létre. Ezekben a Modulokban vannak a te eljárásaid, függvényeid. Ezek a program indulásával automatikusan betöltődnek, elérhetővé válnak.

Makrók helye2.png


A kiterjesztések általános kezelése .oxt formátumban történik elég régen. (nem tudom, hányas verziótól.)
A Kiterjesztéskezelő csak menedzseli (telepíti/eltávolítja illetve engedélyezi/letiltja a kiterjesztéseket, de szerkeszteni, létrehozni nem tudod azzal.
Kiterjesztéskezelő.png
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3468
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: Zizi64 » 2012. július 27., péntek 14:09

A Makrók és a Kiterjesztések tárolási helye a régebbi verziókhoz képest - úgy tudom -, megváltozott.
Nálam itt érem el fájlkezelővel a saját makróimat:
Makrók helye3.png



Itt meg a kiterjesztéseket:
Kiterjesztések helye.png
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3468
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: Zizi64 » 2012. július 28., szombat 7:55

SUN OO2.4-et szeretnék regisztrálni, de a firefox "A kiszolgáló nem található" hibaüzenetet ad.

Visszakanyarodva az eredeti kérdésedhez:
Emlékeim szerint az FSF kiadású OOo változatoknál régebben sem kellett regisztrációt végrehajtani, csak a "gyári verziónál". Talán még megtalálhatók olyan oldalakon a régebbi változatok is telepítőfájljai, mint például a
http://www.oldapps.com/openoffice.php
oldal. Sajnos azt nem tudom, hogy melyik kiadást, és melyik nyelvi változatot tárolják, de látok fenn 2.4.0, 2.4.1, 2.4.2, 2.4.3 verziókat is.

Valahol nekem is megvan a 2.4.1 magyar nyelvű verzió telepítője, de már arra sem emlékszem, hogy jómagam mikor álltam át az akkoriban "hivatalosabb vonalnak" számító
Star/Sun/Oracle/Apache kiadási vonalról
az FSFverzió/Go-OO/OxigenOffice/LibreOffice vonalra...
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3468
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: NagyL » 2012. július 30., hétfő 16:11

Köszönöm szépen az alapos és jól érthető magyarázatot! Látszik, hogy botcsinálta felhasználó vagyok és az alapokkal kapcsolatos ismereteim hiányosak.
Utánanézek a könyvtáraknak. Sajnos az explorel.exe közben hibát észlelt a keresés közben és bezáródott. Később folytatom a keresést.
sun oo2.4, win98, xp
NagyL
 
Hozzászólások: 7
Csatlakozott: 2012. július 27., péntek 11:15

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: Zizi64 » 2012. július 30., hétfő 22:54

Sajnos az explorel.exe közben hibát észlelt a keresés közben és bezáródott. Később folytatom a keresést.


Használj "normális" fájlkezelő ptogramot...
:-)

Total Commander, Unreal Commander, stb...
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3468
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: NagyL » 2012. augusztus 1., szerda 9:59

Kikerestem a makrók helyeit. A Switchboard könyvtárban levő makrókat átmásoltam a saját makróim könyvtárába - lehet, hogy csak varázslat volt - és már látom a switchboardot amikor eseményt akarok rendelni az űrlap mezőhöz. Most már csak azt lenne jó kitalálni, hogy melyiket rendeljem hozzá, mert van bőven. A neveik alapján nem találtam olyat ami nekem kellene, ami megnyitna egy már létező űrlapot.
sun oo2.4, win98, xp
NagyL
 
Hozzászólások: 7
Csatlakozott: 2012. július 27., péntek 11:15

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: Zizi64 » 2012. augusztus 1., szerda 10:08

A
http://extensions.services.openoffice.o ... itchBoard/
oldalról letölthető "Switchboard" kiterjesztés egy .oxt "kiterjesztéscsomag" annak belső szerkezetét megbontva, részeit máshová másolva, nem biztos, hogy fogy működni...

Sajnos ebben a "Switchboard" dologban nem tudok segíteni. Sose használtam, nem ismerem...
Sok sikert!
Kovács Tibor (Win7x64Prof/W10x64prof: LO6.1.6;
winPenPack/PortableApps: LO3.3.1-6.3.1, AOO4.1.6
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címe elejének szerkesztésével - tedd hozzá: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3468
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: OO2.4 kapcsolótábla használatához regisztráció

HozzászólásSzerző: NagyL » 2012. augusztus 1., szerda 11:31

Köszönöm a segítségedet!

Szerintem működik, mert - mint fentebb írtam - az eseménykezelőben látható a Switchborad és a benn levő könyvtárszerkezet és a makrók is, amik szerkeszthetők is.

Ez nem biztos, hogy a másolás miatt van - mint fentebb írtam - lehet, hogy a gép újraindítása (openoffice, explorer...) miatt következett be. Lehet, hogy az explorer hibaüzenet is ezzel volt kapcsolatos.

Végül is mindegy, a Switchboard látszik, csak nem tudom használni. Megpróbálom a makrókat végignézni, hogy melyik mit csinál és átírni egy hasonlót úgy, hogy azt tegye ami nekem kell.
sun oo2.4, win98, xp
NagyL
 
Hozzászólások: 7
Csatlakozott: 2012. július 27., péntek 11:15


Vissza: Testreszabás és kibővítés

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég