Libre Office-ban nem jelennek meg a felületi elemek

Általában minden ami máshova nem fér

Libre Office-ban nem jelennek meg a felületi elemek

HozzászólásSzerző: Ambakaj » 2020. július 30., csütörtök 10:59

Szisztok!
Remélem jó helyen nyitottam témát és nem rondítok bele a fórum integritásába! Ha mégsem jó helyen nyitottam, akkor első körben elnézést kérek és második körben, ha lehetséges, akkor egy moderátor segítségét kérném, hogy helyezze át a megfelelő helyre a kérdésemet.

Szeretnék segítséget kérni egy bosszantó problémában.
Liber office 64 bites 6.4.5-ös verzióját használom Windows 7 Pro 64 bites rendszeren. Egy probléma miatt újra kellet telepítenem a Windowst a gépen. Most jutottam el odáig, hogy feltelepített a Libre Office-t is. Sajnos telepítés után elindítva a programot, nem jelennek meg a felületi elemek. Ok' Uninstall a Windows saját programkezelőjével. A hiba ugyan úgy jelentkezik telepítés után. Plusz telepítés közben hibát dob, a parancsikonok sikertelen regisztrációja miatt. De ez gondolom azért van, mert a Windows programkezelője nem törölte a korábbi parancsikonokat. Ok', következő próba az Ashampoo uninstallerrel felügyelt telepítés. A hiba ismét jelentkezik, így az Ashampoo-val távolítottam el a programot. Újra telepítés és minden változatlan. Továbbra sem tölt be rendesen a program.

Nem tudom a gépen futó egyéb programokhoz, vagy beállításokhoz kötni a problémát, mivel ezek évek óta ugyan azok. Nem telepítgetek új programokat, mivel minden megvan, amit használni szoktam és szükségem is van rá. Nem használok rendszer-optimalizáló, vagy takarító programokat, mert a tapasztalatom szerint, több kárt okoznak hosszútávon, mint amennyi hasznuk lenne. Ugyan ezekkel a beállításokkal, ugyan ebben a szoftver környezetben, hibátlanul működött a program.

Mi az amire nem figyelek? Mit rontok el?
Vagy ha nem én rontok el valamit, akkor hogyan tudom javítani?
Minden építő jellegű segítség jól jönne és köszönöm!

hiányzó felületi elemek 1.PNG

hiányzó felületi elemek 2.PNG

Link létrehozási hiba.PNG
Link létrehozási hiba.PNG (9.34 KiB) Megtekintve 106 alkalommal.
LibreOffice Windows x86_64 (Vista or newer required), Verzi??: 6.4.5, Magyar
Windows 7 Pro 64 bit
Ambakaj
 
Hozzászólások: 4
Csatlakozott: 2020. július 30., csütörtök 10:20

Re: Libre Office-ban nem jelennek meg a felületi elemek

HozzászólásSzerző: Zizi64 » 2020. július 30., csütörtök 11:46

Teljesen jó helyre írtál.

Ilyen hibát sohasem tapasztaltam, pedig már jó pár verziót telepítettem, általában 10-15 gépre.

Plusz telepítés közben hibát dob, a parancsikonok sikertelen regisztrációja miatt. De ez gondolom azért van, mert a Windows programkezelője nem törölte a korábbi parancsikonokat.


Ha valami nem törlődött a szabályos Uninstall során, akkor azt neked kell törölni. (Márpedig a LO felhasználói profilja szándékosan nem törlődik, mert ott vannak tárolva az egyéni beállításaid. De nagy verzióugrásnál nem célszerű megőrizni a régit.)

Két hely van amit ellenőrizned kell:

- A LibreOffice programkönyvtár a ProgramFiles vagy a ProgramFiles(x86) könyvtárát (attól függően, hogy a 32 vagy a 64 bites verzió volt telepítve nálad...) Rendszergazdai jogokkal tudod törölni a LibreOffice alkönyvtárban megmaradt fájlokat. Természetesen 32 bites Windows-on csak az egyik létezhet, és azon csakis a 32 bites LO verziót tudod működőképesen telepíteni. De 64 bites Windows-on bármelyiket telepítheted.

- A LibreOffice User Profil könyvtárát. Ez most nálam Win10-en a
C:\Users\a_windows_felhasználói_nevem\AppData\Roaming\LibreOffice\4
(pedig már a 6-os verziót használom, de az al-al-al könyvtár neve a 4.x.x verzió óta mindig "4" maradt, pedig tiszta telepítést csináltam.) na, az ebben lévő dolgokat is törölnöd kell.

Ezután indítsd újra a géped. Ekkor mondhatod, hogy "tiszta telepítést fogok csinálni"...
Persze a telepítő fájlt se árt még egyszer letölteni, mert az is meghibásodhatott letöltés közben.

Windows7-re már egy ideje nem telepítettem LO/AOO-t, remélem, hogy nem vált vele inkompatibilissé (azaz: sem a MS, sem a LO oldaláról nem történt olyan változás, ami lehetetlenné tenné a telepítést. A régebben feltelepített programverziók nekem működnek Win7-en mind a mai napig.
Sok sikert!
Kovács Tibor (Win10x64Prof/W7x64P: LO6.1.6-6.2.8;
winPenPack/PortableApps: LO3.3.1-6.4.5, AOO4.1.7
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címének szerkesztésével. Írd elé: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3634
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Libre Office-ban nem jelennek meg a felületi elemek

HozzászólásSzerző: Ambakaj » 2020. július 31., péntek 22:31

Szia!
Köszönöm a gyors válaszodat.
A 32-64 bit viszonyokkal, függőségekkel tisztában vagyok. Az nem jelent problémát. Illetve ugye írtam, hogy 64 bites Windows 7-re a 64 bites LO-t telepítettem.
A parancsikon létrehozási probléma sem igazából probléma, inkább csak kellemetlenség. Ennek ellenére el lehet indítani a LO bármelyik komponensét, akár az asztalon lévő, akár a startmenüben lévő parancsikonokkal.
Tiszta telepítés. Annál tisztább telepítés nincs, mint amikor először telepíted a rendszerre a programot. Akkor ugyebár még sehol nem lehet jelen semmilyen elhagyott könyvtár fájl, vagy registri bejegyzés. Ellenben már az első telepítésnél jelentkezett a hiba, hogy nem jelentek meg bizonyos felületi elemek. És igazából én erre keresek megoldást, választ, hogy ezt mi okozhatja, ez mitől lehet.
LibreOffice Windows x86_64 (Vista or newer required), Verzi??: 6.4.5, Magyar
Windows 7 Pro 64 bit
Ambakaj
 
Hozzászólások: 4
Csatlakozott: 2020. július 30., csütörtök 10:20

Re: Libre Office-ban nem jelennek meg a felületi elemek

HozzászólásSzerző: Zizi64 » 2020. augusztus 1., szombat 6:45

Liber office 64 bites 6.4.5-ös verzióját használom Windows 7 Pro 64 bites rendszeren.

A 32-64 bit viszonyokkal, függőségekkel tisztában vagyok. Az nem jelent problémát. Illetve ugye írtam, hogy 64 bites Windows 7-re a 64 bites LO-t telepítettem.

Igen, láttam, hogy írtad, de gondoltam: érdemes tisztázni ezt a részét is a dolognak.



Egy probléma miatt újra kellet telepítenem a Windowst a gépen.

Tiszta telepítés. Annál tisztább telepítés nincs, mint amikor először telepíted a rendszerre a programot.

Ez csak akkor jelent VALÓBAN tiszta telepítést, ha le is formáztad a háttértárat, vagy egy teljesen újat használsz. Mert egyébként a LO fájljai vígan a helyükön marad(hat)nak a régi telepítés alapján, akkor is, ha a Windows fájljait "letúrtad", törölted róla. A telepítés egyéb parancs híján ugyanabba a könyvtárba történik meg (ha az még létezik a tárolón). Meg aztán azt is írtad, hogy (a Windows és a LO telepítése után) már a LO uninstallásával is próbálkoztál. Ott pedig belép az a "probléma", hogy a szabályos uninstall szándékosan nem távolít el bizonyos fájlokat.



Ezek után marad akkor hibalehetőségként
- a telepítőfájl meghibásodása, megsérülése. Ezt újbóli letöltéssel lehet javítani, ellenőrizni.
- bizonyos Windows komponensek hiánya. Ne feledd, hogy idén januártól a Windows 7 már nem támogatott, és azt nem tudom, hogy egy friss telepítés ugyanúgy "frissül-e" a telepítés után, mint régen tette: akkor ugyanis képes volt (több menetben) félórákig letölteni és telepíteni a telepítőlemezen nem meglévő, azaz annál újabb Windows komponenseket, funkciókat, beállításokat. A LibreOffice-t szinte mindig ezek megtörténte UTÁN telepítettem
- Esetleg nem lehet, hogy a LO bizonyos útvonalát, vagy a Windows rendszerkönyvtárakat (Path) a Win/LO beállításokban másik háttértárra/partícióra irányítottad, és az ott megmaradt beállítások a hibásak?

Ezek mind csak tippek, mert igazából fogalmam sincs, mi lehet az oka. Soha nem volt ILYEN problémám a több száz OOo, Go-OO, OOO, AOO, LO telepítés során, semelyik Windows-on, kezdve a Win98SE-nal, a WinME-on és az WinXP-n át a Win7-ig; és most a Win10-zel sem..
Sok sikert!
Kovács Tibor (Win10x64Prof/W7x64P: LO6.1.6-6.2.8;
winPenPack/PortableApps: LO3.3.1-6.4.5, AOO4.1.7
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címének szerkesztésével. Írd elé: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3634
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Libre Office-ban nem jelennek meg a felületi elemek

HozzászólásSzerző: Ambakaj » 2020. augusztus 3., hétfő 11:28

Ok’
Akkor sorban válaszolok a kérdéseidre, felvetéseidre:
– Windows telepítés:
A telepítést mindig úgy végzem, hogy mielőtt belekezdek, lecsatlakoztatom azokat a háttértárakat, amelyike szükségtelenek a telepítéshez. Így csak az az egy merevlemez, SSD marad csatlakoztatva, amelyikre a Windowst telepítem. Ezután a telepítőben a partíció kezelés résznél Shift+F10-zel meghívom a parancssort és a diskpart clean parancsával törlöm a lemez teljes tartalmát, így az összes partíciót is. Nem hozok létre saját partíciókat, hanem az üres lemezre irányítom a telepítést és majd a telepítő elvégzi a particionálást is.
A telepítés után az első lépésben először telepítem az SHA–2 biztonsági tanúsítványok frissítését, majd az összes .NET és Visual C++ runtime-ot. Ha ezek megvannak, akkor jöhet a frissítések keresése és telepítése. Jelenleg még le tudja szedni a Windows 7 az összes januárig kiadott, a rendszerhez tartozó publikus frissítést.
Ha ez megvan, akkor telepítem a szükséges drivereket, majd az általam használt egyéb programokat. Még mindig csak az az egy lemez van csatlakoztatva, amelyikre a Windowst telepítettem, így nem kerül semmilyen fájl másik meghajtóra, vagy nem olvas be másik meghajtóról esetleg hibás adatokat.
A frissítéseket most másképp csináltam mint korábban, mert a WSUS-el már korábban leszedtem az összes frissítést és .NET/VC++ runtime-ot, így ezt egy lépcsőben, offline módban gyorsabban tudom telepíteni.

Nem mondom, hogy elegáns módon, de megoldottam a problémát.
Először is a DoYourData Uninstallerrel eltávolítottam a LO-t. Mivel felügyelt telepítés volt, így a DoYourData Uninstaller törölt minden felhasználói könyvtárat és registry bejegyzést. Az O&O registry editorral rákerestem az összes Libre Offcice (LibreOffice) bejegyzésre és töröltem azt a párat, amik nem a letöltési könyvtárakra hivatkoztak. A Microsoft support oldalán, ami a System.AppUserModell.ID figyelmeztetéssel foglalkozik, találtam 3 registry kulcsot ({9F4C2855-9F79-4B39-A8D0-E1D42DE1D5F3}, 12 / {9F4C2855-9F79-4B39-A8D0-E1D42DE1D5F3}, 11 / {B725F130-47EF-101A-A5F1-02608C9EEBAC}, 23), ami előidézheti a parancsikon bejegyzések hibáját, ezeket is végignéztem, hogy van-e valamilyen LO-ra utaló bejegyzés bennük. Itt nem találtam semmit. Ezután kénytelen-kelletlen, de használtam a Wise Registry Cleanert és azzal is átnéztem a registry-t.
Ok’
Kipucoltam a rendszert, majd ránéztem a LO letöltési oldalára és újra letöltöttem a 32 és 64 bites telepítőt. Aztán egy ötlettől vezérelve letöltöttem a 64 bites, 7.0.3 verziójú előzetes kiadását is. Kíváncsiságból elsőnek az előzetes kiadást telepítettem. Láss csodát, tökéletesen működik! Nem tudom mi volt a probléma oka és mi hozta a megoldást, de sikerült és működik rendesen a 7.0.3 verzió. Egyetlen problémám van vele, hogy néhány helyen még angol szöveget tartalmaz a beállításokban, illetve néhány parancsikon még hiányzik, de ezzel nem foglalkoztam különösebben, mert minimális angol tudással ez a probléma áthidalható. A lényeg, hogy tökéletesen működik és egyelőre csak ez számít nekem.

Köszönöm a tanácsaidat, észrevételeidet! Ugyan a legtöbbel tisztában voltam, de ha valaki belefut hasonló problémába és megtalálja ezt a topicot, annak még hasznos lehet. Még egyszer köszönök mindent!

LO.png
LibreOffice Windows x86_64 (Vista or newer required), Verzi??: 6.4.5, Magyar
Windows 7 Pro 64 bit
Ambakaj
 
Hozzászólások: 4
Csatlakozott: 2020. július 30., csütörtök 10:20

Re: Libre Office-ban nem jelennek meg a felületi elemek

HozzászólásSzerző: Zizi64 » 2020. augusztus 3., hétfő 19:07

A Fresh verziókkal - főleg, hogy A 7.0.x még ki sem jött valójában - vigyázz: éles használatra nem javasolt! Mindig a Still verziókat használd, de legalábbis a Fresh-ek közül a főverziónak a 4.-5. al-verzióját.
Tehát most a 6.3.6 a Still verzió, és 6.4.x a Fresh verzió; jelen pillanatban a 6.4.5 a "leg-Fresh-ebb".

Nálam a cégnél a 6.1.6, itthon a 6.2.8 van fixen (permanensen) feltelepítve, a 6.4.5 pedig hordozható verzióként van fenn a gépemen: az is jól működik.
Sok sikert!
Kovács Tibor (Win10x64Prof/W7x64P: LO6.1.6-6.2.8;
winPenPack/PortableApps: LO3.3.1-6.4.5, AOO4.1.7
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címének szerkesztésével. Írd elé: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3634
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest

Re: Libre Office-ban nem jelennek meg a felületi elemek

HozzászólásSzerző: Ambakaj » 2020. augusztus 4., kedd 21:39

Ok'
Köszi ezt nem tudtam és megfogadom a tanácsodat.
Azzal tisztában voltam, hogy az előzetes (beta) kiadásokat nem szabad használni, nem is használom, éles munkakörnyezetben. De a többi stabil kiadás közti különbséget nem ismertem.
LibreOffice Windows x86_64 (Vista or newer required), Verzi??: 6.4.5, Magyar
Windows 7 Pro 64 bit
Ambakaj
 
Hozzászólások: 4
Csatlakozott: 2020. július 30., csütörtök 10:20

Re: Libre Office-ban nem jelennek meg a felületi elemek

HozzászólásSzerző: Zizi64 » 2020. augusztus 5., szerda 7:01

A "Beta" kiadások egyértelműen a fejlesztőknek, a fejlesztő vénájú felhasználóknak,
a Fresh verziók a "bátraknak", a kísérletező kedvűeknek, az önkéntes tesztelőknek,
a Still verziók pedig az átlagos (céges és magán-) felhasználók számára vannak közzétéve.

Mivel központosított, egy munkahelyre összpontosuló fejlesztő és tesztelőcsapat nincs, nem létezik, viszont a világban szerteszét mindenhol vannak önkéntesek, ezért - gondolom - ez a terjesztési mód volt a leglogikusabb, legkönnyebben megvalósítható.

Ez (és az angol OpenOffice fórum) sem "hivatalos Support", hanem (főleg az angol fórumon) önkéntes felhasználók "hada" próbál segíteni más felhasználóknak a már létező, kiadott verziók megismerésében, és használatában. Tehát én is a szabadidőmből áldozok erre az önként vállalt "feladatra". Én is kérdezni jöttem ide, aztán most válaszolok - ha tudok.

Ebben talán ma még "jobb az OpenOffice", mert a LibreOffice-hoz elég szétszórt segítségrendszer tartozik. A leírásokat átvették már a LO fejlesztő-önkéntesek, többször át is dolgozták azokat; sőt újakat is készítettek, amik elérhetők a neten, de igazi, nagy internetes FÓRUM most nem létezik a LO felhasználók számára. Ezért "közös" ez a fórum is. Jöhetsz AOO és LO kérdésekkel is, bár a név az OpenOffice-ra utal. (Nagy különbség még mindig nincs a két programcsomag használata között, bár folyamatosan nő az a különbség.)
A LO-hoz köthető néhány régebbi és újabb levelezőlista, egy-egy nyelven létezik LO Fórum is:
https://www.libreoffice-forum.de/
Meg ott a HUP, de az nem kifejezetten a LO számára jött létre. Volt egy angol nyelvű magánkezdeményezésű - ehhez valamelyest hasonló - Fórum is, de azt megszüntette a létrehozója.
Sok sikert!
Kovács Tibor (Win10x64Prof/W7x64P: LO6.1.6-6.2.8;
winPenPack/PortableApps: LO3.3.1-6.4.5, AOO4.1.7
Ha megoldódott a probléma, jelöld a témaindító hozzászólásod címének szerkesztésével. Írd elé: [Megoldva].
Avatar
Zizi64
Globális moderátorok
 
Hozzászólások: 3634
Csatlakozott: 2008. november 12., szerda 21:22
Tartózkodási hely: Budapest


Vissza: Általános kérdések

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 2 vendég

cron