PostgreSQL adatbázis csatlakozás

Adatbázis kezelő

PostgreSQL adatbázis csatlakozás

HozzászólásSzerző: pisti » 2010. április 24., szombat 23:18

Sziasztok,

tudna segíteni valaki, mert nem akar működni Ooo 3.2 alatt a PostgreSQL adatbázishoz való csatlakozás. Feltettem a bővítményt és végig mentem a beállításon, de a kapcsoalt tesztelésénél azt mondja, hogy " A következő URL-hez nincs regisztrálva illesztő program: sdbc:postgresql:dbname=mydb host=localhost."

Ugyanakkor a "Befejezés"-t választva elmenti a beállításokat és megnyitja az odb-t, de mikor kiválasztom a táblákat és beolvasná az adatbázist apsql-ből, akkor hibát ír ki: "SQL állapota HY000".

Probáltam keresgélni, de nem találtam rá megoldást. Mit lehet ilyenkor tenni?

Köszi
pisti
OpenOffice 3.2.0.7 OpenSUSE 11.2
pisti
 
Hozzászólások: 8
Csatlakozott: 2010. április 24., szombat 23:09

Re: PostgreSQL adatbázis csatlakozás

HozzászólásSzerző: r4zoli » 2010. április 25., vasárnap 12:16

Melyik bővítményt?
Ehhez hasonló rpm csomag van telepítve:
OpenOffice_org-base-drivers-postgresql-3.2.0.XXXXXX

Nekem most az unstable alól a 3.2.1RC van már fennt, azzal megnézem, de még fel kell tennem a postgresqlt is.
Olvasd el, és lehetőleg tartsd be az útmutatót a fórum használatához.
AOO 3.4.1 win7, LibO 4.0 win7.
Avatar
r4zoli
Site Admin
 
Hozzászólások: 850
Csatlakozott: 2008. február 17., vasárnap 4:52
Tartózkodási hely: Budapest

Re: PostgreSQL adatbázis csatlakozás

HozzászólásSzerző: pisti » 2010. április 25., vasárnap 14:03

A postgresql-sdbc-0.7.6.zip bővítmény. A fenti driver viszont nem volt fenn, úgy látszik ezt magától nem telepítette, de most feltettem és úgy tűnik, hogy csatlakozik. Ki kell tapasztalnom, hogyan működik.

Köszönöm a gyors választ, ez a segítség megfelelő volt, hogy megtaláljam a saját hibámat.

Köszönöm
pisti
OpenOffice 3.2.0.7 OpenSUSE 11.2
pisti
 
Hozzászólások: 8
Csatlakozott: 2010. április 24., szombat 23:09

Re: PostgreSQL adatbázis csatlakozás

HozzászólásSzerző: r4zoli » 2010. április 25., vasárnap 14:27

pisti írta:A postgresql-sdbc-0.7.6.zip bővítmény.

Akkor ezzel volt a baj, a 3.2 és felette a módosított bővítményt igényli: http://dba.openoffice.org/drivers/postg ... 0.7.6a.zip
Valószínűleg az opensuse változat is ezt tartalmazza.
Olvasd el, és lehetőleg tartsd be az útmutatót a fórum használatához.
AOO 3.4.1 win7, LibO 4.0 win7.
Avatar
r4zoli
Site Admin
 
Hozzászólások: 850
Csatlakozott: 2008. február 17., vasárnap 4:52
Tartózkodási hely: Budapest


Vissza: Base

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég

cron