JAVA-t nem találja a Base

Adatbázis kezelő

JAVA-t nem találja a Base

HozzászólásSzerző: Poliverzum » 2009. február 27., péntek 16:13

Na sziasztok, gondoltam megtanulom a Base-t is az OOo-ból. Ehhez a Base bevezető 3.0 pdf-et használnám. A leírás tetszik, van benne ugyan néhány nyomdahiba de eddig nagy megelégedéssel olvastam, érthető, köszönet a készítőknek érte!

Sajnos már a legelején gondban vagyok. Létrehoztam az első adatbázisomat "Poliverzum" néven, de amikor a "Táblák"-ra kattintok, ez a hibaüzenet fogad:

"Nem hozható létre kapcsolat a következő adatforrással: "Poliverzum"
No Java installation could be found. Please check your installation!"


Ami szerintem annyit tesz, hogy Java kell neki, de az szerinte nincs telepítve a masinámra.

No most ebben az az érdekes, hogy VAN telepített és minden más esetben tökéletesen működő JAVA-m! Az OOo 2.4.1 verzióját használom jelenleg, s ehhez a Sun Microsystems 1.6.0_02 verziójú Java-ját használom, amit ki is jelez nekem az OOo, ha a Beállításoknál a "Java" részre kattintok, és kiírja a helyét is a rendszerben: /Programs/JRE/jre1.6.0_02

Jelenleg tehát a Java LÁTSZÓLAGOS hiánya miatt nem tudom a Base-t használni. A kérdésem az, miért nincs Javam amikor pedig van (Még az OOo szerint is!), és hogyan lehetne ezen az áldatlan állapoton változtatni?! Előre is köszi a segítséget!

U.I.: Kipróbáltam az OOo 3.0.0 változatával is. Itt ez a hibaüzenet fogad a "Táblák"-ra kattintva:

"Nem hozható létre kapcsolat a következő adatforrással: "Poliverzum"
File input/output error /Users/vz/Poliverzum.odb.properties java.io.IOException: No OutputStream"
Linux másfajta • 2.4.X • Linux másfajta
Poliverzum
Önkéntesek
 
Hozzászólások: 96
Csatlakozott: 2008. február 29., péntek 9:28

Re: JAVA-t nem találja a Base

HozzászólásSzerző: Poliverzum » 2009. február 27., péntek 17:51

Feltettem egy sokkal újabb Java-t, de a hibaüzenetek nem változtak egyik OOo változat esetén sem.
A hozzászólást 2 alkalommal szerkesztették, utoljára Poliverzum 2009. február 28., szombat 11:45-kor.
Linux másfajta • 2.4.X • Linux másfajta
Poliverzum
Önkéntesek
 
Hozzászólások: 96
Csatlakozott: 2008. február 29., péntek 9:28

Re: JAVA-t nem találja a Base

HozzászólásSzerző: r4zoli » 2009. február 27., péntek 18:29

A java máshol működik? Pl. Fájl>Tündérek>Levél.. ?
Olvasd el, és lehetőleg tartsd be az útmutatót a fórum használatához.
AOO 3.4.1 win7, LibO 4.0 win7.
Avatar
r4zoli
Site Admin
 
Hozzászólások: 850
Csatlakozott: 2008. február 17., vasárnap 4:52
Tartózkodási hely: Budapest

Re: JAVA-t nem találja a Base

HozzászólásSzerző: Poliverzum » 2009. február 27., péntek 18:50

Ha a Fájl>Tündérek>Levél-re kattintok, semmi se történik, hibaüzenet viszont nincs.
Linux másfajta • 2.4.X • Linux másfajta
Poliverzum
Önkéntesek
 
Hozzászólások: 96
Csatlakozott: 2008. február 29., péntek 9:28

Re: JAVA-t nem találja a Base

HozzászólásSzerző: Poliverzum » 2009. február 27., péntek 18:54

Pontosítok: A 2.4.1-es OOo alatt nem megy a levéltündér, a 3.0.0-ban jól működik!
Linux másfajta • 2.4.X • Linux másfajta
Poliverzum
Önkéntesek
 
Hozzászólások: 96
Csatlakozott: 2008. február 29., péntek 9:28

Re: JAVA-t nem találja a Base

HozzászólásSzerző: r4zoli » 2009. február 27., péntek 19:03

A 2.4.1 esetében lépj ki az OOO-ból próbáld meg átnevezni a felhasználói könyvtárat /home/<user>/.openoffice.org2 -t más névre. Majd OOo újraindítás, újra létrehozza a könyvtárat alapbeállításokkal, a régiből átmásolhatod a beállításaidat vagy később vissza állíthatod az előző állapotot.

Az OOo honnan származik? Próbálj másik forrrásból feltenni egy másik buildet.

Szerkesztés: Most nézem az angol fórumot és a java beállítások az:
Kód: Egész kijelölése   KinyitásÖsszecsukás
/opt/openoffice.org/basis3.0/presets/config/javasettingsunopkginstall.xml

fájlban van eredetileg és ez helyezi el a felhasználói könyvtárban:
Kód: Egész kijelölése   KinyitásÖsszecsukás
/.openoffice.org/3/user/config/javasettings_Linux_x86.xml

alá. Itt kellene körbe nézni.
Olvasd el, és lehetőleg tartsd be az útmutatót a fórum használatához.
AOO 3.4.1 win7, LibO 4.0 win7.
Avatar
r4zoli
Site Admin
 
Hozzászólások: 850
Csatlakozott: 2008. február 17., vasárnap 4:52
Tartózkodási hely: Budapest

Re: JAVA-t nem találja a Base

HozzászólásSzerző: Poliverzum » 2009. február 27., péntek 19:22

A 2.4.1 esetében kipróbáltam amit mondtál, de semmi nem változott: a friss könyvtárral (az alapbeállításokkal) induló OOo esetén is az a helyzet, hogy a levéltündér nem indul, a Base esetén pedig a hibaüzenet ugyanaz. (Épp emiatt vissza is tértem a régi .openoffice.org2 könyvtárra, mert eszerint nem az a bűnös). Az OOo a hivatalos bináris OxygenOffice rpm-ből van az általam használt GoboLinuxhoz hekkelve. A 3.0.0 OOo is. Muszáj nekem megoldani, hiszen GoboLinuxhoz nem gyártotok csomagot! S eddig semmi baj nem volt egyik OOo-val sem, megelégedéssel használom, de persze a Base része csak most lett kipróbálva, hogy tanulhatnékom támadt az irányába.

Még el is fogadnám azt az érvet, hogy a csomagkészítés közben elszúrtam valamit, ha nem az lenne, hogy a 3.0.0 esetén működik a levéltündér, tehát a JAVA, és még a Base sem azt írja ki hogy nincs telepített JAVA, hanem más a hibaüzenete. Vagyis JAVA az VAN, és MŰKÖDIK! Ja, a JAVA nem egy általam összehekkelt tákolmány, hanem a hivatalos GoboLinux repóból származó bináris csomag, teljesen szabályosan telepítve.
Linux másfajta • 2.4.X • Linux másfajta
Poliverzum
Önkéntesek
 
Hozzászólások: 96
Csatlakozott: 2008. február 29., péntek 9:28

Re: JAVA-t nem találja a Base

HozzászólásSzerző: Poliverzum » 2009. február 28., szombat 11:22

Felraktam az OxygenOffice 3.0.1-et, de teljesen ugyanaz a hibaüzenet, mint a 3.0.0 esetében.

A $HOME/.openoffice.org/3/user/config/javasettings_Linux_x86.xml file tartalma a következő:

<?xml version="1.0" encoding="UTF-8"?>
<!--This is a generated file. Do not alter this file!-->
<java xmlns="http://openoffice.org/2004/java/framework/1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<enabled xsi:nil="true"/>
<userClassPath xsi:nil="true"/>
<vmParameters xsi:nil="true"/>
<jreLocations xsi:nil="true"/>
<javaInfo xsi:nil="false" vendorUpdate="2004-01-30" autoSelect="true">
<vendor>Sun Microsystems Inc.</vendor>
<location>file:///Programs/Sun-JRE/1.6.0_11_bin</location>
<version>1.6.0_07</version>
<features>0</features>
<requirements>1</requirements>
<vendorData>660069006C0065003A002F002F002F00500072006F006700720061006D0073002F00530075006E002D004A00520045002F0031002E0036002E0030005F00310031005F00620069006E002F006C00690062002F0069003300380036002F0063006C00690065006E0074002F006C00690062006A0076006D002E0073006F000A002F00500072006F006700720061006D0073002F00530075006E002D004A00520045002F0031002E0036002E0030005F00310031005F00620069006E002F006C00690062002F0069003300380036002F0063006C00690065006E0074003A002F00500072006F006700720061006D0073002F00530075006E002D004A00520045002F0031002E0036002E0030005F00310031005F00620069006E002F006C00690062002F0069003300380036002F006E00610074006900760065005F0074006800720065006100640073003A002F00500072006F006700720061006D0073002F00530075006E002D004A00520045002F0031002E0036002E0030005F00310031005F00620069006E002F006C00690062002F0069003300380036000A00</vendorData>
</javaInfo>
</java>
Linux másfajta • 2.4.X • Linux másfajta
Poliverzum
Önkéntesek
 
Hozzászólások: 96
Csatlakozott: 2008. február 29., péntek 9:28

Re: JAVA-t nem találja a Base

HozzászólásSzerző: Poliverzum » 2009. február 28., szombat 14:14

Na érdekes dologra jöttem rá. Felraktam a 3.0.0 OOo ANGOL változatát, tehát nem a magyart, azt, ami e link alatt található:
http://ftp.fsf.hu/OpenOffice.org/stable ... -US.tar.gz
ebben állítólag benne van a JRE, azt mondták nekem. Ebben pedig MEGY JÓL a Base! Érdekesség, hogy semmi saját JAVA-t nem találtam ebben az OOo-ban, ugyanazt írja ki a beállításoknál, amit én telepítettem. És jól működik.

Na most ezzel csak az az egy baj van, hogy nem magyar, hanem angol, én pedig a magyar OOo-t szeretném. Tehát vagy a magyar OOo-t kell rávenni hogy menjen a Base, vagy ezt az ánglius OOo-t kéne magyarítani (magyar elválasztás, magyar szövegek a menükben, stb) de fogalmam sincs, ezt hogy lehetne megoldani. Mindenesetre az eddigiek alapján valószínűnek tartom, hogy nem én szúrtam el valamit, hanem a hiba a magyar OOo-ban van.
Linux másfajta • 2.4.X • Linux másfajta
Poliverzum
Önkéntesek
 
Hozzászólások: 96
Csatlakozott: 2008. február 29., péntek 9:28

Re: JAVA-t nem találja a Base

HozzászólásSzerző: r4zoli » 2009. február 28., szombat 14:44

A Novell változattal nekem is problémám van az opensuse alatt, a jelentésből kilépéskor összeomlik az OOo.
Az FSF, Novell változat pedig a go-oo forrásból származik mint az összes linux disztribúcióé is.

A magyar nyelvi csomagot innen töltheted le, http://ftp.fsf.hu/OpenOffice.org_hu/3.0.1/
Olvasd el, és lehetőleg tartsd be az útmutatót a fórum használatához.
AOO 3.4.1 win7, LibO 4.0 win7.
Avatar
r4zoli
Site Admin
 
Hozzászólások: 850
Csatlakozott: 2008. február 17., vasárnap 4:52
Tartózkodási hely: Budapest

Re: JAVA-t nem találja a Base

HozzászólásSzerző: Kklemencz » 2009. március 10., kedd 12:58

Sziasztok!

Hátha tudok segíteni. Nekem is a 2.4 változat van meg.
Nekem sem működött a Tündérek hiába volt feltelepítve a "jre".
Azonban a Hozzáadás/Eltávolításokból feltelepítettem a teljes OpenOffice.org csomagot és láss csodát elindult.
Ms Windows XP • 2.4.X • Ubuntu 8.x
Kklemencz
 
Hozzászólások: 1
Csatlakozott: 2009. március 10., kedd 12:50

Re: JAVA-t nem találja a Base

HozzászólásSzerző: pégé » 2010. február 18., csütörtök 1:37

A probléma ugyanez. Nem segít a full install sem. Csak mindez 3.2-vel, legújabb Javával. A tündérkék engem kevéssé érdekelnek (és azok működnek is Calc-ban, Writer-ben), egész egyszerűen csak szeretnék létrehozni egy táblát a Base-ben, meg egy másikat, köztük kapcsolatot, ilyesmik. De azzal kezdődik, hogy eleve meg sem jelenik semmi a táblanézetnél, rögtön két hibaüzenettel indít: "OO JRE-t igényel, a JRE hibás, telepítsen újat" + "Nem hozható létre kapcsolat ... Nem található Java". Ha megnyitom az OO-val érkező minta-adatbázist (biblio), az működik, már amennyire. (Ott is el lehet jutni a hibaüzenetig.) Beállításokban pedig ott ketyeg, látja a Javát. Most akkor hogyan tovább?
OOO320m12 build 9483 (2010-02-12) / Java 1.6.0_18-b07 / XP sp2
pégé
 
Hozzászólások: 4
Csatlakozott: 2010. február 18., csütörtök 1:20

Re: JAVA-t nem találja a Base

HozzászólásSzerző: r4zoli » 2010. február 18., csütörtök 8:18

Meg kellene próbálni a felhasználói profil átnevezését. [Leírás]Felhasználói profil törlése
Olvasd el, és lehetőleg tartsd be az útmutatót a fórum használatához.
AOO 3.4.1 win7, LibO 4.0 win7.
Avatar
r4zoli
Site Admin
 
Hozzászólások: 850
Csatlakozott: 2008. február 17., vasárnap 4:52
Tartózkodási hely: Budapest

Re: JAVA-t nem találja a Base

HozzászólásSzerző: pégé » 2010. február 18., csütörtök 12:02

Szerintem ne erőltessük ezt a felhasználói profilt, fentebb (de egyébként az éjszaka én is) láttuk, hogy verziótol függetlenül nem az a baj. A tündérek Writerben, Calcban működnek, a Base-ben nem (mondjuk nekem nem hiányoznak). A magyar Base-ben csomó minden más se műxik. Föltettem az angolt, azzal nincs semmi probléma. Meg kicsit másképp is néz ki: több az opció, nincs duplum pl. a field type-listában (meg kicsit gazdagabb is), aminek egy lehulló menüben ott kell lennie (pl. PK.) az ott van, ilyesmik. Szal valami nagyon nem oké, szevasz FSF.hu, a Base nem sikerült...

Ettől függetlenül, köszönöm a gyors reagálást.
OOO320m12 build 9483 (2010-02-12) / Java 1.6.0_18-b07 / XP sp2
pégé
 
Hozzászólások: 4
Csatlakozott: 2010. február 18., csütörtök 1:20

Re: JAVA-t nem találja a Base

HozzászólásSzerző: r4zoli » 2010. február 18., csütörtök 19:15

Most tettem fel az FSF változatot win7-re és minden funkció működik.

Meg kicsit másképp is néz ki: több az opció, nincs duplum pl. a field type-listában (meg kicsit gazdagabb is), aminek egy lehulló menüben ott kell lennie (pl. PK.) az ott van, ilyesmik.

A Base esetében a legkisebb a különbség a Sun és a FSF(go-oo) forrású OOo között, amit írtál az legfeljebb a hibás telepítés eredménye lehet.
Olvasd el, és lehetőleg tartsd be az útmutatót a fórum használatához.
AOO 3.4.1 win7, LibO 4.0 win7.
Avatar
r4zoli
Site Admin
 
Hozzászólások: 850
Csatlakozott: 2008. február 17., vasárnap 4:52
Tartózkodási hely: Budapest

Re: JAVA-t nem találja a Base

HozzászólásSzerző: pégé » 2010. február 18., csütörtök 20:04

Ez esetben a nem túlságos mélységig konfigurálható teleőpítő a pocsék. Bocs.
Én mégis inkább abban a legkisebb különbségben keresném a hiba okát: egy többezer éves legenda szerint egyetlen helytelen betű is elegendő a világvégéhez...
(No meg az is különös, hogy az OO többi része működik remekül, csak a Base-zel van gondban a telepítő...)
OOO320m12 build 9483 (2010-02-12) / Java 1.6.0_18-b07 / XP sp2
pégé
 
Hozzászólások: 4
Csatlakozott: 2010. február 18., csütörtök 1:20

Re: JAVA-t nem találja a Base

HozzászólásSzerző: Vollover » 2010. február 27., szombat 11:02

Sziasztok!

Base tekintetében teljesen kezdő vagyok, de ugyanez a problémám mint a fent leírtak. Van valamilyen megoldás azóta? Java rendesen működik mindennel a rendszeren, de itt ua hibaüzenet mint fent és én sem látom a táblákat.
Oprendszer XP, OOo magyar 3.1, java 1.6.
Angol verzió az egyetlen út?
OpenOffice 3.2 magyar és nincs gnd a java-val (Windows Xp -n)
Vollover
 
Hozzászólások: 2
Csatlakozott: 2010. február 27., szombat 10:59

Re: JAVA-t nem találja a Base

HozzászólásSzerző: pégé » 2010. február 27., szombat 11:35

Hát, próbáld végig a fentieket, aztán ha bejön, jó. Ha nem, akkor még mindig ott van az angol. Az működik. Valahogy biztos lehet magyarítani, langpack a 3.0.1-hez biztos van, attól feljebb nem találtam.
OOO320m12 build 9483 (2010-02-12) / Java 1.6.0_18-b07 / XP sp2
pégé
 
Hozzászólások: 4
Csatlakozott: 2010. február 18., csütörtök 1:20

Re: JAVA-t nem találja a Base

HozzászólásSzerző: Vollover » 2010. február 28., vasárnap 1:20

Közben feltelepítettem az OOo 3.2 magyar verziót és lám megjavult. Most már csak azzal küzdök hogy még életemben nem építettem ilyesmit mint ügyfélnyilvéntartó adatbázis és mostanra teljesen összegyűrtem az arcom, mert folyton hibákat jelez és nemtom azért mert nem értek hozzá vagy mert még van más gondja is.
Szóval nekem a fenti problémát az orvosolni látszik hogy a legfrisebb verzióra újítottam. OOo3.2 magyar. ;)
OpenOffice 3.2 magyar és nincs gnd a java-val (Windows Xp -n)
Vollover
 
Hozzászólások: 2
Csatlakozott: 2010. február 27., szombat 10:59


Vissza: Base

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég

cron