Jelentésnél 2 napot elvesz a dátumból

Adatbázis kezelő

Jelentésnél 2 napot elvesz a dátumból

HozzászólásSzerző: kanyi » 2013. szeptember 2., hétfő 11:38

Sziasztok!

LO 4.0.3.3
Nagyon furcsa dolgot találtam. Van egy munkafüzetből létrehozott adatbázisom. Lekérdezések tök jól mennek, de valamiért a Jelentéstervezőben -2 nap szerepel mindig a dátumnál. Ami még a lekérdezésnél jól jelenik meg, ugyan az a helyes dátum van mint a munkafüzetben. Jelentéstervezőben elszáll. Ez mitől lehet?
Dátum formátum: 2013-01-01 12:12. OK, van időpont is mellette, de ettől még helyesen kéne felismernie, főleg hogy a program egyik része ezt meg is teszi.

üdv,
Attila
Ubuntu 13.10 - LO 4.2.04 • MS Windows 7 - LO 4.2.04
kanyi
Önkéntesek
 
Hozzászólások: 119
Csatlakozott: 2008. március 1., szombat 23:12
Tartózkodási hely: Budapest

Re: Jelentésnél 2 napot elvesz a dátumból

HozzászólásSzerző: r4zoli » 2013. szeptember 2., hétfő 17:28

Ennek az lehet az oka, hogy a Base és a Calc másik kiinduló dátumot használ.
Ha jól emlékszem, a HSQLDB/Base alapdátuma 1899. 12.30. a Calc beállításnál Eszközök>Beállítások>Libreoffice>Calc>Számítás> Dátum alatt valószínűleg a 1900. január 1. van beállítva.
Olvasd el, és lehetőleg tartsd be az útmutatót a fórum használatához.
AOO 3.4.1 win7, LibO 4.0 win7.
Avatar
r4zoli
Site Admin
 
Hozzászólások: 850
Csatlakozott: 2008. február 17., vasárnap 4:52
Tartózkodási hely: Budapest

Re: Jelentésnél 2 napot elvesz a dátumból

HozzászólásSzerző: kanyi » 2013. szeptember 3., kedd 12:55

A hiba így is jelentkezik. :(
A táblázathoz képeset a lekérdezés 2 nappal korábbi dátumot mutat. Attól függetlenül hogy minek állítom a Calc alapértelmezett dátumát.
Viszont AOO 4.0, az Oracle Report Generator kiterjesztéssel helyesen létrehozza.
Ubuntu 13.10 - LO 4.2.04 • MS Windows 7 - LO 4.2.04
kanyi
Önkéntesek
 
Hozzászólások: 119
Csatlakozott: 2008. március 1., szombat 23:12
Tartózkodási hely: Budapest

Re: Jelentésnél 2 napot elvesz a dátumból

HozzászólásSzerző: r4zoli » 2013. szeptember 3., kedd 17:14

Ez egy korábbi hibára emlékeztetett, az AOO-ban, ott javították ezek szerint, a LibO-ban meg nem.
Olvasd el, és lehetőleg tartsd be az útmutatót a fórum használatához.
AOO 3.4.1 win7, LibO 4.0 win7.
Avatar
r4zoli
Site Admin
 
Hozzászólások: 850
Csatlakozott: 2008. február 17., vasárnap 4:52
Tartózkodási hely: Budapest


Vissza: Base

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég