formule =SI(...)

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

formule =SI(...)

Messagepar TrucMuch » 14 Mai 2019 14:38


La modération a écrit:Suppression de Problème avec la dans le titre. Les termes implicites comme Problème sont inutiles car implicites

Bonjour; je n'avais pas beaucoup d'inspiration pour le titre mais vous comprendrez surement :

Pour mon club de sport (j'ai masqué le nom des équipes pour éviter tout problèmes avec les équipes concernées) , j'ai fait le classement de toute nos équipes et le problème se pose pour notre "Equipe 1" qui a une des équipes de son championnat qui a fait forfait générale (en gros cela veut dire que tous ces matchs ne comptes pas et que chaque équipe au lieu de jouer 7 matchs comme dans n'importe quel championnat en a joué 6 selon la règle de notre fédération) et du coup pour avoir le classement exact je supprime les résultat concernant "Equipe 8" dans le calendrier à gauche (c'est l'équipe qui est forfait) mais au lieu que chaque équipe ai 6 matchs joués (colonne K) certaines en ont 3 d'autres 5 , etc..... (cf.tableau 1) alors que le tableau 1 devrait ressembler enfaite au tableau 2 (qui est un copié-coller du tableau 1 que j'ai rempli manuellement pour que vous compreniez l'erreur) et quand on regarde de plus près on se rend compte que c'est la colonne des matchs nul (colonne M) qui pose problème).

Screen 1 : quand je remplace tous les résultats de "Equipe 8" par le score de 14-0
screen1.png
Screen 1

Screen 2 : quand je vide les résultats concernant "Equipe 8" (ce qu'il faut faire d'après le règlement pour avoir le classement exact)
screen 2.png
Screen 2


Les cases exactes qui posent problèmes sont M4;M5;M7 voici donc ce qu'il y a dans ces cases
M4 : =SI($D$4="";0;SI($D$4=$C$4;1;0)+SI($C$8="";0;SI($C$8=$D$8;1;0)+SI($D$12="";0;SI($D$12=$C$12;1;0)+SI($C$20="";0;SI($C$20=$D$20;1;0)+SI($D$25="";0;SI($D$25=$C$25;1;0)+SI($D$30="";0;SI($D$30=$C$30;1;0)+SI($C$34="";0;SI($C$34=$D$34;1;0))))))))
M5 : =SI($D$5="";0;SI($D$5=$C$5;1;0)+SI($C$9="";0;SI($C$9=$D$9;1;0)+SI($D$13="";0;SI($D$13=$C$13;1;0)+SI($C$17="";0;SI($C$17=$D$17;1;0)+SI($D$24="";0;SI($D$24=$C$24;1;0)+SI($C$30="";0;SI($C$30=$D$30;1;0)+SI($D$35="";0;SI($D$35=$C$35;1;0))))))))
M7 : =SI($D$2="";0;SI($D$2=$C$2;1;0)+SI($C$10="";0;SI($C$10=$D$10;1;0)+SI($C$15="";0;SI($C$15=$D$15;1;0)+SI($D$19="";0;SI($D$19=$C$19;1;0)+SI($C$25="";0;SI($C$25=$D$25;1;0)+SI($D$28="";0;SI($D$28=$C$28;1;0)+SI($C$35="";0;SI($C$35=$D$35;1;0))))))))

Ne tenaient pas compte de ma signature elle est erronée c'est enfaite : LibreOffice 6.1 sous Windows 10
LibreOffice 6.1 sous Windows 10
TrucMuch
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 14 Mai 2019 14:18

Re: formule =SI(...)

Messagepar micmac » 14 Mai 2019 15:20

Bonjour,
TrucMuche a écrit:ma signature elle est erronée c'est enfaite : LibreOffice 6.1 sous Windows 10
Accès direct à votre signature pour la corriger.
Dans votre signature vous devez préciser la ou les versions exactes d'OpenOffice ou de LibreOffice et du ou des systèmes utilisés.
Exemple : AOO 4.1.6 (version imposée selon le cas) sous Win7 SP1, Win 8.1, Win 10, MacOS 10.14.4, Ubuntu 18.10...
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 5761
Inscrit le : 28 Août 2010 09:45

Re: formule =SI(...)

Messagepar Noonours » 14 Mai 2019 17:46

Bonjour
Plutôt qu'une copie d'écran, joins une copie de ton fichier dépersonnalisé (cf ma signature) tu multiplieras les chances d'une réponse pertinente :wink:
Noonours

N’HÉSITEZ SURTOUT PAS À JOINDRE UN FICHIER

LibO 6.2.3.2 sous Windows 10
LibO 5.0.6.3 (obligation de version) sous Win 7
Avatar de l’utilisateur
Noonours
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 274
Inscrit le : 11 Mai 2013 01:11
Localisation : Aix en Provence

Re: formule =SI(...)

Messagepar TrucMuch » 14 Mai 2019 18:08

Bon finalement tant pis pour les équipes elles ne risquent pas de passer par là si ça dérange les modos je modifierais le fichier
Pièces jointes
club de sport.ods
(57.77 Kio) Téléchargé 4 fois
LibreOffice 6.1 sous Windows 10
TrucMuch
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 14 Mai 2019 14:18

Re: formule =SI(...)

Messagepar Noonours » 14 Mai 2019 22:07

Bonjour TrucMuch, le forum

Une proposition ci dessous en utilisant la fonction SOMMEPROD (un peu de documentation : l'aide F1 nous envoie ici :wink: )
J'ai renommé des zones correspondantes aux équipes et aux scores (gauche et droite dans ton tableau) pour plus de lisibilité dans les formules.
Tu trouveras le tableau 3 que j'ai ajouté à la suite des deux tiens sur la feuille "Equipe 1 - R2 - Poule A"

Le document en question:

club de sport_MOD.ods
(47.75 Kio) Téléchargé 6 fois


COOordialement,
Noonours

N’HÉSITEZ SURTOUT PAS À JOINDRE UN FICHIER

LibO 6.2.3.2 sous Windows 10
LibO 5.0.6.3 (obligation de version) sous Win 7
Avatar de l’utilisateur
Noonours
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 274
Inscrit le : 11 Mai 2013 01:11
Localisation : Aix en Provence

Re: formule =SI(...)

Messagepar TrucMuch » 17 Mai 2019 19:33

Désolé je répond peut-etre un peu tard mais c'est exactement ce à quoi doit ressembler le tableau , par contre j'ai absolument rien compris à la fonction SOMMEPROD j'essaierai de me renseigner un peu plus .

Merci
LibreOffice 6.1 sous Windows 10
TrucMuch
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 14 Mai 2019 14:18

Re: formule =SI(...)

Messagepar Michel JANZEF » 17 Mai 2019 20:14

Bonjour,
Vous trouverez ici un tutoriel sur la fonction SOMMEPROD.
Domicile :
1- AOo 4.1.6 et LibO 6.1.6.3 (x64) - Windows 10 Famille 1803 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Bureau : LibO 5.1.2.2 (imposée) sous Linux Ubuntu 16.04
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 1977
Inscrit le : 12 Jan 2006 11:04


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 32 invité(s)