graphique en barre intégration d'étiquette de données variation %

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur : Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.
Djo63
Fraîchement OOthentifié
Messages : 3
Inscription : 21 juin 2022 12:06

graphique en barre intégration d'étiquette de données variation %

Message par Djo63 »

Bonjour,
Tout d'abord grand merci de m'accueillir au sein de votre forum :)
Je débute sous LibreOffice, fortement habituée à Excel... Si Calc ne me pose pas de problème, il n'en est pas de même pour l'insertion de graphique !
Je cherche à afficher au dessus de barres d'erreur Y un pourcentage de variation entre deux mois. Et après plusieurs heures de recherche et de "bidouille", je suis bredouille !
Le fichier joint vous éclairera mieux, je pense, qu'une longue rédaction.
Si l'un, l'une d'entre vous possède une solution, un vif remerciement à l'avance !
bien cordialement
Djo
variation mensuelle en %.ods
(42.63 Kio) Téléchargé 7 fois
LibreOffice 7.3 sous Windows 10 pro
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 16274
Inscription : 03 mars 2006 18:02
Localisation : Venise verte

Re: graphique en barre intégration d'étiquette de données variation %

Message par jeanmimi »

Bonjour,
Djo63 a écrit : 21 juin 2022 12:36 Je cherche à afficher au dessus de barres d'erreur Y un pourcentage de variation entre deux mois. Et après plusieurs heures de recherche et de "bidouille", je suis bredouille !
Pour afficher les données, l'idéal serait que ce soit des nombres. La formule affiche des textes alignés à gauche :

Code : Tout sélectionner

=SI(ESTERREUR(I3);"";""&TEXTE(I3/D3;"%"))
Cette formule va afficher des nombres, à formater en pourcentage dans le Format de la cellule :

Code : Tout sélectionner

=SI(ESTERREUR(I2/D2);"";I2/D2)
A tester avec ton fichier où est le Diagramme.
Pièces jointes
variation mensuelle en %.ods
(43.08 Kio) Téléchargé 5 fois
LibreOffice : Version : 7.3.2.2 (x64)(8 avril 2022)
Adoptium JRE ou Oracle JRE (x64), Windows 10, Thunderbird, Firefox
Djo63
Fraîchement OOthentifié
Messages : 3
Inscription : 21 juin 2022 12:06

Re: graphique en barre intégration d'étiquette de données variation %

Message par Djo63 »

Bonjour,

Un grand merci pour cette correction ! :super:
Mais comme LibreOffice ne permet pas l'insertion d'étiquette de données sur sélection de plages de cellule, ou alors je n'ai pas trouvé l'astuce, comment puis je intégrer ces étiquettes de données au dessus des barres d'erreur dans mon graphique ?
Est-ce possible, en dehors d'un copier/coller d'objets ?
Merci encore de votre temps.
bien à vous
Djo
LibreOffice 7.3 sous Windows 10 pro
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 16274
Inscription : 03 mars 2006 18:02
Localisation : Venise verte

Re: graphique en barre intégration d'étiquette de données variation %

Message par jeanmimi »

L'insertion de données se fait sur l'objet du Diagramme sélectionné.
Comme dans le fichier joint, il s'agit plutôt d'un Copier/coller d'une image, il est possible d'insérer une Zone de texte (fond blanc) ou une Forme (fond bleu)
Si les valeurs devaient être automatiques, il serait plus aisé d'avoir le diagramme initial plutôt qu'un Copier/Coller.
Pièces jointes
Insertion.jpg
Insertion.jpg (6.48 Kio) Consulté 47 fois
LibreOffice : Version : 7.3.2.2 (x64)(8 avril 2022)
Adoptium JRE ou Oracle JRE (x64), Windows 10, Thunderbird, Firefox
Djo63
Fraîchement OOthentifié
Messages : 3
Inscription : 21 juin 2022 12:06

Re: graphique en barre intégration d'étiquette de données variation %

Message par Djo63 »

Bonjour,
Oui j'aimerais bien pouvoir automatiser.
En PJ, fichier ad hoc.
Bien cordialement,
Djo
variation mensuelle en %.ods
(37.67 Kio) Téléchargé 3 fois
LibreOffice 7.3 sous Windows 10 pro
Avatar de l’utilisateur
Dolev
PassiOOnné
PassiOOnné
Messages : 607
Inscription : 19 août 2018 07:20

Re: graphique en barre intégration d'étiquette de données variation %

Message par Dolev »

Bonsoir,

On dirait que tu veux faire un diagramme cours :
graph_cours.PNG
graph_cours.PNG (55.62 Kio) Consulté 14 fois
Open Office 4.1.12 sous Windows 7 pro
Répondre