[Résolu] "Borner" entre une valeur mini et maxi

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] "Borner" entre une valeur mini et maxi

Messagepar Jmichel » 23 Juin 2021 13:33

Bonjour,
Apres un calcul, je voudrai afficher la valeur calculée si elle est comprise entre 20 et 25, si la valeur calculée est inferieure a 20, j'affiche 20, si elle est superieure a 25, j'affiche 25.
le tout dans une seule cellule avec une formule imbriquée.
Merci,
Windows10 20H2 OpenOffice 4.1.10
Jmichel
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 23 Juin 2021 13:26

Re: "Borner" entre une valeur mini et maxi

Messagepar Jean-Louis Cadeillan » 23 Juin 2021 14:43

Bonjour et bienvenue sur le forum,
Une solution serait :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(A1<=25;A1>=20);A1;SI(A1<20;20;25))

Cordialement,
Jean-Louis
LibO 7.1.6.2 (x64 avec Java 1.8.0_301) et AOO 4.1.10 (avec Java x32 1.8.0_241), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5236
Inscrit le : 03 Jan 2009 00:56

Re: "Borner" entre une valeur mini et maxi

Messagepar Jmichel » 23 Juin 2021 16:28

Merci beaucoup :D
Windows10 20H2 OpenOffice 4.1.10
Jmichel
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 23 Juin 2021 13:26

Re: [Résolu] "Borner" entre une valeur mini et maxi

Messagepar gerard24 » 24 Juin 2021 07:18

Bonjour,

Un peu après la bataille, mais plus court :

Code : Tout sélectionner   AgrandirRéduire
=MEDIANE(A1;20;25)

A+
OOodidacte
LibreOffice 6.4.5 sous Windows 10.
pour télécharger LibreOffice
Avatar de l’utilisateur
gerard24
ManitOOu
ManitOOu
 
Message(s) : 3159
Inscrit le : 06 Juil 2008 18:08
Localisation : dans le Périgord

Re: [Résolu] "Borner" entre une valeur mini et maxi

Messagepar Jean-Louis Cadeillan » 24 Juin 2021 15:10

Bonjour,
Dans le même esprit :
Code : Tout sélectionner   AgrandirRéduire
=MIN(25;MAX(20;A1))
:wink:
Cordialement,
Jean-Louis
LibO 7.1.6.2 (x64 avec Java 1.8.0_301) et AOO 4.1.10 (avec Java x32 1.8.0_241), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5236
Inscrit le : 03 Jan 2009 00:56


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 8 invité(s)