[Résolu] formule fiche évaluation prof

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] formule fiche évaluation prof

Messagepar Ana92 » 29 Oct 2020 22:59


La modération vous a écrit: Sujet déplacé. Open Calc sont des termes inutiles dans cette section, ils ont été supprimés du titre


Bonjour à tous,

Je n'arrive pas à trouver la solution à mes soucis de formule sur open calc, vous êtes mon dernier recours. :alerte:
J'ai eu beau essayer de regarder sur différentes sources, j'ai toujours un code erreur et j'avoue désespérer :(

Je cherche trois formules :

- pouvoir faire que les cases intitulées "niveau d'acquisition" sur la feuille 2, prennent automatiquement l'intitulé de la ligne "item" sur la feuille 1

- trouver la formule permettant sur la feuille 2 de calculer le niveau moyen de la ligne pour chaque élève ( ce sont des compétences : Maitrise Insuffisante, Maitrise Fragile, Maitrise satisfaisante, Très bonne maitrise ) ( la cerise sur la gâteau serait que les couleurs associées apparaissent comme dans le tableau de la feuille 1 mais j'en demande peut-être beaucoup)

- et enfin qu'une note moyenne (sur 20) apparaissent sur la 3eme colonne de la feuille 2, sachant que le nombre de point associé est défini dans le tableau de la feuille 1 ( 0, 10, 25, 40,50 )

Merci beaucoup de votre aide par avance :super:

Mon niveau de compétence calc est clairement en rouge : insuffisant ! :marto:

Bien à vous
Pièces jointes
EVAL INFORMATIQUE TEST BAD.ods
Fichier sur lequel je travaille
(38.14 Kio) Téléchargé 18 fois
open office 4.1.7
Ana92
Fraîchement OOthentifié
 
Message(s) : 1
Inscrit le : 29 Oct 2020 22:53

Re: formule fiche évaluation prof

Messagepar micmac » 30 Oct 2020 08:24

Bonjour et bienvenue sur le forum,

Dans votre signature, en plus de la version de OpenOffice 4.1.7 que vous indiquées, il est nécessaire d'ajouter La version exacte du système d'exploitation (Windows XP SP3, Vista SP2, Windows 7 SP1, Win 8.1, Win 10, Ubuntu 20.04, macOS 10.15.7 par exemple).
Accès direct à votre signature pour la corriger.

Cordialement.
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 7362
Inscrit le : 28 Août 2010 09:45

Re: formule fiche évaluation prof

Messagepar njhub » 30 Oct 2020 15:32

Bonjour Ana92, le forum

Voyez si la solution proposée en pièce jointe peut vous convenir

1) On fait la somme de chacun des dix items avec cette formule en B5
Code : Tout sélectionner   AgrandirRéduire
=SOMME(SIERREUR(INDIRECT("CONCEPTION EVAL.B"&EQUIV(D5;$'CONCEPTION EVAL'.$A$13:$A$18;0)+12;1);0);SIERREUR(INDIRECT("CONCEPTION EVAL.B"&EQUIV(E5;$'CONCEPTION EVAL'.$A$13:$A$18;0)+12;1);0);SIERREUR(INDIRECT("CONCEPTION EVAL.B"&EQUIV(F5;$'CONCEPTION EVAL'.$A$13:$A$18;0)+12;1);0);SIERREUR(INDIRECT("CONCEPTION EVAL.B"&EQUIV(G5;$'CONCEPTION EVAL'.$A$13:$A$18;0)+12;1);0);SIERREUR(INDIRECT("CONCEPTION EVAL.B"&EQUIV(H5;$'CONCEPTION EVAL'.$A$13:$A$18;0)+12;1);0);SIERREUR(INDIRECT("CONCEPTION EVAL.B"&EQUIV(I5;$'CONCEPTION EVAL'.$A$13:$A$18;0)+12;1);0);SIERREUR(INDIRECT("CONCEPTION EVAL.B"&EQUIV(J5;$'CONCEPTION EVAL'.$A$13:$A$18;0)+12;1);0);SIERREUR(INDIRECT("CONCEPTION EVAL.B"&EQUIV(K5;$'CONCEPTION EVAL'.$A$13:$A$18;0)+12;1);0);SIERREUR(INDIRECT("CONCEPTION EVAL.B"&EQUIV(L5;$'CONCEPTION EVAL'.$A$13:$A$18;0)+12;1);0);SIERREUR(INDIRECT("CONCEPTION EVAL.B"&EQUIV(M5;$'CONCEPTION EVAL'.$A$13:$A$18;0)+12;1);0))


2) Puis on fait la moyenne en C5 en divisant la somme en B5 par le nombre d'items différents de vide et différents de NE
Code : Tout sélectionner   AgrandirRéduire
=SI(B5=0;0;B5/(2,5*NB.SI.ENS(D5:M5;"<>"&"NE";D5:M5;"<>"&"")))


Ana92_EVAL INFORMATIQUE TEST BAD.ods
(30.22 Kio) Téléchargé 17 fois


:wink:
LibreOffice 7.1.1.2/ (x64) FR-YT 05/03/21
OS : Windows 10.0
njhub
Membre cOOnverti
Membre cOOnverti
 
Message(s) : 320
Inscrit le : 18 Juin 2017 06:43
Localisation : 976


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 10 invité(s)