[Résolu] Recherche et renvoi d'élément sur ratio

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Recherche et renvoi d'élément sur ratio

Messagepar Maxou » 16 Oct 2020 19:44

Bonjour,
Je souhaiterais dans le tableau ci-joint faire apparaitre dans la cellule F/G-10/11 le prénom de la personne ayant le plus petit ratio délai d'attente.
En cas d'égalité, j'aimerais que le prénom qui apparaisse soit celui de la personne ayant le plus gros volume individuel parmi celles ayant le plus petit ratio délai d'attente.
Impossible de trouver une combinaison de fonction qui fasse ça...
Merci d'avance de votre aide !
Pièces jointes
Liste d'attente.ods
(11.95 Kio) Téléchargé 17 fois
Dernière édition par Bidouille le 06 Nov 2020 11:48, édité 2 fois.
Raison: Balisage
OpenOffice 4.1.7 sous Windows 10 Pro 64bits
Maxou
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 16 Oct 2020 19:39

Re: Aide avec les fonctions

Messagepar njhub » 16 Oct 2020 20:43

Bonjour Maxou,

Voyez si la solution proposée dans le fichier joint peut vous aider

Maxou_Liste d'attente.ods
(14.52 Kio) Téléchargé 21 fois


:wink:
LibreOffice 7.1.1.2/ (x64) FR-YT 05/03/21
OS : Windows 10.0
njhub
Membre cOOnverti
Membre cOOnverti
 
Message(s) : 320
Inscrit le : 18 Juin 2017 06:43
Localisation : 976

Re: Aide avec les fonctions

Messagepar Maxou » 17 Oct 2020 08:30

Mon openoffice m'indique que votre fichier a été créé par une version plus récente de openoffice que la mienne (4.1.7, qui est pourtant la plus récente sur le site Apache...?)
Du coup ça ne fonctionne pas.
Est-il possible de me renvoyer le fichier en format 4.1.7 ou antérieur ?
Vous remerciant de votre aide,
Cordialement,
Chaïban Maxime.
OpenOffice 4.1.7 sous Windows 10 Pro 64bits
Maxou
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 16 Oct 2020 19:39

Re: Aide avec les fonctions

Messagepar njhub » 17 Oct 2020 08:38

Bonjour Maxou,

Mettez cette fonction en ligne 7, de la colonne B à I (plus petit ratio délai d'attente)

Code : Tout sélectionner   AgrandirRéduire
=SI(B$6=MIN($B$6:$I$6);B$3;"")


En F10/G11 (plus gros volume individuel)

Code : Tout sélectionner   AgrandirRéduire
=INDIRECT(ADRESSE(1;EQUIV(GRANDE.VALEUR(A7:I7;1);A7:I7;0));1)


:wink:
LibreOffice 7.1.1.2/ (x64) FR-YT 05/03/21
OS : Windows 10.0
njhub
Membre cOOnverti
Membre cOOnverti
 
Message(s) : 320
Inscrit le : 18 Juin 2017 06:43
Localisation : 976

Re: Aide avec les fonctions

Messagepar Maxou » 17 Oct 2020 08:53

J'ai compris comment fonctionnait votre tableau et ai pu le transposer sur ma version directement.
C'est parfait merci beaucoup !
OpenOffice 4.1.7 sous Windows 10 Pro 64bits
Maxou
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 16 Oct 2020 19:39


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : njhub et 4 invité(s)