[Résolu]Résultat au lieu d'une cellule vide ou égale à zéro

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu]Résultat au lieu d'une cellule vide ou égale à zéro

Messagepar ledébutant » 03 Juin 2019 08:14


La modération a écrit:Titre modifié : "problème" est inutile dans un titre.
Toutes les questions sur ce forum sont forcément des problèmes. Veillez à faire preuve d'inventivité la prochaine fois.

Bonjour

dans le fichier joint et dans la cellule M3 apparait une écriture alors qu'il n'y a rien dans les cellules J3:K3. Idéalement il ne devrait pas y avoir d’écriture ou seulement 0, je ne parvient pas à faire en sorte.

Se sujet fait suite à un précédent https://forum.openoffice.org/fr/forum/viewtopic.php?f=4&t=60555

Merci par avance de votre aide

Bonne journée
Pièces jointes
ledebutant-2.ods
(13.68 Kio) Téléchargé 16 fois
Dernière édition par ledébutant le 04 Juin 2019 19:50, édité 4 fois.
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49

Re: Problème d'écriture dans formule de calcul demi journée

Messagepar jeanmimi » 03 Juin 2019 09:00

Bonjour,
ledébutant a écrit: Idéalement il ne devrait pas y avoir d’écriture ou seulement 0, je ne parvient pas à faire en sorte.

En modifiant la formule, et avec un formatage de cellule en Nombre :
Code : Tout sélectionner   AgrandirRéduire
=SI(SOMME(D4:K4)=0;"";MAX(J4+0,5;K4+1)-MAX(D4;E4+0,5))
Pièces jointes
ledebutant-2.ods
(13.24 Kio) Téléchargé 14 fois
LibreOffice Version : Version: 6.3.3.2 (x64) (4 novembre 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 15040
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Résultat au lieu d'une cellule vide ou égale à zéro

Messagepar ledébutant » 03 Juin 2019 10:27

Bonjour,

j'ai déjà essayé mais cela ne fonctionne pas,

je souhaite que lorsque je rempli la cellule en D3 ou D4 et que les cellules J3 ou K3 sont vident, alors il n'y a rien en M3 ou M4. C'est plus facile à exprimer par orale que par écrit. je sait pas si ma demande est très explicite.

Merci
Pièces jointes
ledebutant-2.ods
(14.04 Kio) Téléchargé 13 fois
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49

Re: Résultat au lieu d'une cellule vide ou égale à zéro

Messagepar OOotremer971 » 03 Juin 2019 13:29

Boujour,

Code : Tout sélectionner   AgrandirRéduire
=SI(ET($J3="";$K3="");"zéro";"La formule qui va bien")

remplacer "La formule qui va bien" par la vraie formule
et
"zéro" par "0" ou "" mais pas par 0 car une cellule au format date affiche 30/12/99 lorsqu'elle contient le chiffre zéro. Donc si tu veux afficher 0 il faut le mettre entre double quotes pour qu'il soit considéré comme du texte. Si tu veux que la cellule reste vide il faut afficher deux double quotes.

A+
En principe, toujours à jour des dernières versions dites stables
AOO
LibreOffice
Ubuntu
OpenSuse Leap
Avatar de l’utilisateur
OOotremer971
HédOOniste
HédOOniste
 
Message(s) : 2130
Inscrit le : 16 Avr 2010 14:31

[Résolu]: Résultat au lieu d'une cellule vide ou égale à zér

Messagepar ledébutant » 04 Juin 2019 19:49

Super
sa marche, merci beaucoup.
bonne soirée
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : MSN [Bot] et 3 invité(s)