Formulaires et sous-formulaires

Discussions sur le module de base de données Base et plus particulièrement sur le langage SQL ou sur les connexions aux SGBD tiers.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est dédiée au module Base et plus particulièrement sur le langage SQL ou sur les connexions aux SGBD tiers. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.
Pour accélérer les réponses, vous pouvez mettre en ligne votre base en joignant un fichier ODB : comment faire.

Formulaires et sous-formulaires

Messagepar Kokante » 13 Déc 2018 22:55

Bonjour à tous, je suis nouveau !

Je me permets de venir ici car je suis bloqué : je souhaite créer un formulaire accompagné de sous formulaires sous openoffice. J'ai déjà conçu toutes les tables correspondantes et créé les relations. Cependant lorsque j'utilise l'assistant et que j'arrive à la page "utiliser une relation existante", l'option ne m'est pas proposée ! Pourtant la table d'origine qui a servit à la création du formulaire a de multiples relations, et j'ai essayé entre d'autres tables ayant déjà des relations entre elles et l'option fonctionne ! Y-a-t'il une condition que je n'ai pas remplit ?

Merci d'avance pour vos conseils !
OpenOffice 4.1.5 Mac
Kokante
Fraîchement OOthentifié
 
Message(s) : 1
Inscrit le : 13 Déc 2018 22:43

Re: Formulaires et sous-formulaires

Messagepar micmac » 14 Déc 2018 05:37

Bonjour et bienvenue,
Dans votre signature il y a écrit:OpenOffice 4.1.5 Mac

Votre signature est insuffisamment renseignée. Il est nécessaire de préciser la version exacte de votre système (MacOS 10.14.1 par exemple).
J'attire votre attention sur le fait que la dernière version de OpenOffice est AOO 4.1 6. [AOO] Installation AOO 4.1.6 sur MacOS X.

Accès direct à votre signature pour la corriger.

Cordialement
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 5764
Inscrit le : 28 Août 2010 09:45

Re: Formulaires et sous-formulaires

Messagepar jeanmimi » 14 Déc 2018 12:04

Bonjour,
Kokante a écrit:Y-a-t'il une condition que je n'ai pas remplie ?

C'est difficile à dire sans voir la Base.
LibreOffice Version : Version: 6.2.3.2 (x64) (28 avril 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14841
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte


Retour vers Base de données

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 5 invité(s)