[Résolu] Formule STYLE qui ne fontionne pas

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Formule STYLE qui ne fontionne pas

Messagepar cyril260 » 29 Oct 2018 11:57

Bonjour,

Après avoir cherché sur le forum, je me permet de poser cette question. J'essaye d'utiliser la formule dans le manuel
Code : Tout sélectionner   AgrandirRéduire
=A1 + STYLE(SI(A1>3;"rouge";"Standard"))
mais le problème est que la Cellule ne s'affiche pas en rouge et je n'arrive vraiment pas à comprendre pourquoi.
Je vous prie de bien vouloir trouver ci-joint le fichier utilisé et de bien vouloir m'indiquer ce qu'il ne va pas.

Je suis sous Windows XP avec la version OpenOffice 4.1.5 AOO415m1(Build:9789) - Rev. 1817496
2017-12-11 17:25

Merci sincèrement,

Cyril
Pièces jointes
Formule STYLE.ods
(7.55 Kio) Téléchargé 7 fois
Dernière édition par cyril260 le 29 Oct 2018 18:37, édité 1 fois.
OpenOffice 4.1.2
AOO412m3(Build:9782) - Rev. 1709696
2015-10-21 09:53:29 (Mi, 21 Okt 2015)
sous Windows 7 Edition familial premium Service Pack 1

Et
OpenOffice 4.1.5 AOO415m1(Build:9789) - Rev. 1817496
2017-12-11 17:25
sous Windows XP Service Pack 3
cyril260
Membre lOOyal
Membre lOOyal
 
Message(s) : 35
Inscrit le : 29 Nov 2015 17:17

Re: Formule STYLE qui ne fontionne pas

Messagepar jeanmimi » 29 Oct 2018 12:21

Bonjour,
Dans le fichier exemple, je n'ai pas vu le STYLE "rouge".
Est-ce qu'il a été créé ?
Voilà ce que j'obtiens après l'avoir créé :
Pièces jointes
STYLE rouge.png
STYLE rouge.png (3.19 Kio) Consulté 164 fois
LibreOffice Version : 6.2.1.2 (x64) (8 mars 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14832
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Formule STYLE qui ne fontionne pas

Messagepar cyril260 » 29 Oct 2018 13:33

Bonjour jeanmimi et merci pour votre réponse,

Suite à votre message, je ne savais pas qu'il fallait créer un style en plus de la formule, je pensais que la formule suffisait à elle seule et que la couleur "rouge" était déjà incorporé dans OpenOffice. Merci encore !!
Mais savez vous comment Sauvegarder le STYLE car ce dernier disparait à la fermeture et je dois le ressaisir pour qu'il s'applique à nouveau ?
OpenOffice 4.1.2
AOO412m3(Build:9782) - Rev. 1709696
2015-10-21 09:53:29 (Mi, 21 Okt 2015)
sous Windows 7 Edition familial premium Service Pack 1

Et
OpenOffice 4.1.5 AOO415m1(Build:9789) - Rev. 1817496
2017-12-11 17:25
sous Windows XP Service Pack 3
cyril260
Membre lOOyal
Membre lOOyal
 
Message(s) : 35
Inscrit le : 29 Nov 2015 17:17

Re: Formule STYLE qui ne fontionne pas

Messagepar tintin » 29 Oct 2018 13:47

Bonjour,

Le formatage conditionnel doit être appliqué à toute les cellules concernées.
Donc, sélectionnez toutes les cellules où ce formatage conditionnel doit être appliqué et Menu Format > Formatage conditionnel > etc.

Autre possibilité étendre ce formatage aux cellules concernées avec le pinceau de recopie.

Tout sur le formatage conditionnel

Comment clore un sujet correctement lorsqu'il est résolu
AOO 4.1.6 / Mac OS 10.14.4 Mojave / RAM 8Go / Time Machine
Java 1.8.0_201 / Firefox / Safari / Thunderbird
Tutoriels du forum pour MacOS
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 5840
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Formule STYLE qui ne fontionne pas

Messagepar jeanmimi » 29 Oct 2018 13:57

cyril260 a écrit:Mais savez vous comment Sauvegarder le STYLE car ce dernier disparait à la fermeture et je dois le ressaisir pour qu'il s'applique à nouveau ?
Normalement, le Style est embarqué dans le fichier lors de sa sauvegarde, sauf si on choisit de l'enregistrer dans un autre format que .ods
Pièces jointes
Formule STYLE.ods
(8.7 Kio) Téléchargé 4 fois
LibreOffice Version : 6.2.1.2 (x64) (8 mars 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14832
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Formule STYLE qui ne fontionne pas

Messagepar cyril260 » 29 Oct 2018 14:03

Le style est sauvegardé dans le fichier effectivement mais je voudrais l'enregistrer dans Open Office directement, cela est il possible ?
OpenOffice 4.1.2
AOO412m3(Build:9782) - Rev. 1709696
2015-10-21 09:53:29 (Mi, 21 Okt 2015)
sous Windows 7 Edition familial premium Service Pack 1

Et
OpenOffice 4.1.5 AOO415m1(Build:9789) - Rev. 1817496
2017-12-11 17:25
sous Windows XP Service Pack 3
cyril260
Membre lOOyal
Membre lOOyal
 
Message(s) : 35
Inscrit le : 29 Nov 2015 17:17

Re: Formule STYLE qui ne fontionne pas

Messagepar jeanmimi » 29 Oct 2018 14:13

cyril260 a écrit:je voudrais l'enregistrer dans Open Office directement, cela est il possible ?
Oui, bien sûr.
En pratique : tu crées tous les Styles dont tu vas avoir besoin, et tu sauvegardes ton fichier ainsi personnalisé comme Modèle que tu définis Par défaut.
Si difficulté pour le faire, des tutoriels sont à ta disposition ainsi que l'Aide, et les sujets déjà postés dans le Forum.
LibreOffice Version : 6.2.1.2 (x64) (8 mars 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14832
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Formule STYLE qui ne fontionne pas

Messagepar cyril260 » 29 Oct 2018 15:07

Merci encore jeanmimi, j'y suis presque !
Suite à ton message, j'ai enregistré comme modèle tous les styles, et je l'ai défini par défaut.
Les styles se chargent à chaque nouveaux documents (Fichier > Nouveau> Classeur) mais le hic en fait c'est qu'ils ne se chargent pas lorsque je clique directement sur un nouveau fichier (*.ods par exemple), j'ai regardé dans plusieurs tutoriels avant de te déranger à nouveau mais je ne trouve pas, cette option est elle possible directement ou faudrait avoir recours à une une extension?

Merci encore c'est vraiment sympa depuis hier soir je suis dessus
OpenOffice 4.1.2
AOO412m3(Build:9782) - Rev. 1709696
2015-10-21 09:53:29 (Mi, 21 Okt 2015)
sous Windows 7 Edition familial premium Service Pack 1

Et
OpenOffice 4.1.5 AOO415m1(Build:9789) - Rev. 1817496
2017-12-11 17:25
sous Windows XP Service Pack 3
cyril260
Membre lOOyal
Membre lOOyal
 
Message(s) : 35
Inscrit le : 29 Nov 2015 17:17

Re: Formule STYLE qui ne fontionne pas

Messagepar Jeff » 29 Oct 2018 16:57

Bonjour à tous,

cyril260 a écrit:Les styles se chargent à chaque nouveaux documents
J’en déduis que tu as bien ton modèle par défaut.

cyril260 a écrit:ils ne se chargent pas lorsque je clique directement sur un nouveau fichier
Là je ne sais plus quoi en déduire :aie: , est-ce que tu ne veux pas plutôt dire :
"ils ne se chargent pas lorsque je clique directement sur un nouveau fichier existant" :?:

A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.6 sur Xubuntu 18.04_i586 et sur Win 10 pro x64
Avatar de l’utilisateur
Jeff
GourOOu
GourOOu
 
Message(s) : 8002
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: Formule STYLE qui ne fontionne pas

Messagepar cyril260 » 29 Oct 2018 17:10

Bonjour Oukcha et merci pour ta réponse,

cyril260 a écrit:ils ne se chargent pas lorsque je clique directement sur un nouveau fichier
Jeff a écrit:Là je ne sais plus quoi en déduire :aie: , est-ce que tu ne veux pas plutôt dire :
"ils ne se chargent pas lorsque je clique directement sur un nouveau fichier existant" :?:


En fait ce que je voulais dire par nouveau fichier, c'était un fichier téléchargé et que je l'ouvrait pour la première fois.
Pour être plus précis, c'est que si j'ouvre un fichier existant en cliquant directement dessus au format *.csv , *.ods ou autres format compatible, le modèle par défaut ne se charge pas, il se charge uniquement lorsque je procède (Fichier > Nouveau> Classeur).

J'espère avoir été claire :)
OpenOffice 4.1.2
AOO412m3(Build:9782) - Rev. 1709696
2015-10-21 09:53:29 (Mi, 21 Okt 2015)
sous Windows 7 Edition familial premium Service Pack 1

Et
OpenOffice 4.1.5 AOO415m1(Build:9789) - Rev. 1817496
2017-12-11 17:25
sous Windows XP Service Pack 3
cyril260
Membre lOOyal
Membre lOOyal
 
Message(s) : 35
Inscrit le : 29 Nov 2015 17:17

Re: Formule STYLE qui ne fontionne pas

Messagepar Jeff » 29 Oct 2018 17:41

cyril260 a écrit:ce que je voulais dire par nouveau fichier, c’était un fichier téléchargé et que je l'ouvrait pour la première fois

C’est donc un comportement normal, afin que si tu crées plusieurs fichiers avec chacun un style nommé "rouge", mais avec des propriétés différentes (ton de rouge, police en gras, bordures, etc...), les styles ne s’écrasent pas entre eux.

Si, maintenant, tu souhaites écraser un style (ou importer) un style :

  • Ouvre ton fichier-modèle
  • Ouvres ton nouveau fichier
  • Menu Fichier > Modèles > Gérer
  • En affichant "Document" dans les 2 parties de la fenêtre, et en dépliant les arborescences par double-clic, tu dois pouvoir copier ton style :

    AOO_forum.png

A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.6 sur Xubuntu 18.04_i586 et sur Win 10 pro x64
Avatar de l’utilisateur
Jeff
GourOOu
GourOOu
 
Message(s) : 8002
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: Formule STYLE qui ne fontionne pas

Messagepar cyril260 » 29 Oct 2018 17:57

Bonjour Jeff et merci pour ces réponses claires :super:

Cette solution fonctionne :bravo: mais étant donné que je dois vérifier beaucoup de fichier je voulais savoir si cela serait possible à ce que les styles se chargent automatiquement à chaque documents comme si ils étaient partie intégrante d' Open Office Calc comme les styles Résultat, Titre etc ?
OpenOffice 4.1.2
AOO412m3(Build:9782) - Rev. 1709696
2015-10-21 09:53:29 (Mi, 21 Okt 2015)
sous Windows 7 Edition familial premium Service Pack 1

Et
OpenOffice 4.1.5 AOO415m1(Build:9789) - Rev. 1817496
2017-12-11 17:25
sous Windows XP Service Pack 3
cyril260
Membre lOOyal
Membre lOOyal
 
Message(s) : 35
Inscrit le : 29 Nov 2015 17:17

Re: Formule STYLE qui ne fontionne pas

Messagepar Jeff » 29 Oct 2018 18:19

Pas à ma connaissance, car :

Jeff a écrit:si tu crées plusieurs fichiers [...] les styles ne s’écrasent pas entre eux

Et il en va de même pour les styles Résultat, Titre etc qui peuvent être personnalisés pour chaque fichier.

Peut-être faut-il clôturer ce sujet (comment faire), et se tourner du côté des macros afin d’automatiser la tâche...

A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.6 sur Xubuntu 18.04_i586 et sur Win 10 pro x64
Avatar de l’utilisateur
Jeff
GourOOu
GourOOu
 
Message(s) : 8002
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: Formule STYLE qui ne fontionne pas

Messagepar jeanmimi » 29 Oct 2018 18:20

Et ici la deuxième méthode :
https://forum.openoffice.org/fr/forum/v ... le#p252754
cyril260 a écrit:les styles se chargent automatiquement à chaque documents
Automatiquement indique souvent que la solution est dans les Macros.
Dans ce cas, il faut poster ton message dans la section du forum consacrée aux Macros.
LibreOffice Version : 6.2.1.2 (x64) (8 mars 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14832
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Formule STYLE qui ne fontionne pas

Messagepar cyril260 » 29 Oct 2018 18:37

Merci beaucoup pour vos réponses qui m'ont beaucoup aidé, je vais marquer ce sujet comme Résolu et j'essayerai de voir ce soir du côté des macros si cela est possible.
Dans tous les cas je vous remercie sincèrement pour votre aide :super: :super: :super:
OpenOffice 4.1.2
AOO412m3(Build:9782) - Rev. 1709696
2015-10-21 09:53:29 (Mi, 21 Okt 2015)
sous Windows 7 Edition familial premium Service Pack 1

Et
OpenOffice 4.1.5 AOO415m1(Build:9789) - Rev. 1817496
2017-12-11 17:25
sous Windows XP Service Pack 3
cyril260
Membre lOOyal
Membre lOOyal
 
Message(s) : 35
Inscrit le : 29 Nov 2015 17:17


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 8 invité(s)