Filtrage sous calc

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

Filtrage sous calc

Messagepar Warum » 11 Fév 2006 09:33

Bonjour à tous, je me sers des filtres sous calc 2.0.1 mais impossible de les executer dans une macro, par contre il fonctionne très bien sans macro, j ai peut être loupé quelque chose..... d avance Merci
OO.o 2.0.2 WinXP SP2
Warum
Fraîchement OOthentifié
 
Message(s) : 4
Inscrit le : 11 Fév 2006 09:07

Messagepar Papayes » 11 Fév 2006 09:44

Bonjour,
je ne suis pas spécialiste des macros , hélas, mais pour que les Pros puissent te répondre,
il serait utile d'envoyer ta macro en utilisant le service Ci-joint du Forum :
http://oooforum.free.fr/cijoint/
et de coller l'Url correspondant(e?) dans un message de ce fil.
URL ─ sigle signifiant uniform resource locator en anglais, littéralement « repère uniforme de ressource ».
L'usage du féminin ou du masculin pour l'abréviation « URL » (un ou une URL ?) semble assez flottant.:roll:

A+
papayes
"Tout ce qui n'est pas donné est perdu"
Avatar de l’utilisateur
Papayes
Membre fOOndateur
Membre fOOndateur
 
Message(s) : 4154
Inscrit le : 07 Déc 2005 14:55
Localisation : Vic-Fezensac dans le Gers

Filtrage sous calc

Messagepar Warum » 13 Fév 2006 13:26

En espérant une solution
ci joint une copie de la macro

http://oooforum.free.fr/cijoint/fichier ... 012228.ods
OO.o 2.0.2 WinXP SP2
Warum
Fraîchement OOthentifié
 
Message(s) : 4
Inscrit le : 11 Fév 2006 09:07

Filtre et formules

Messagepar sisyphi » 18 Fév 2006 23:47

Salut,

Le comportement du filtre ne semble pas fonctionner correctement lorsque la liste contient des formules renvoyant des valeurs d'erreurs de type #NA.

J'ai effectué le test en comparant 2 listes de données avec la fonction RECHERCHEV. En positionnant un filtre sur la liste, la valeur #NA n'apparaît pas dans le filtre, on a un "blanc". Ce blanc est malgré tout sélectionnable...mais cela prête à confusion.

Avec une liste de ce type :

Résultat de le recherche
Liste 1
Liste 1
#NA
Liste 1

On a un filtre qui affiche :

-tout-
-Standard-
-Top 10-

Liste 1
OOo 2.0.1 Windows Me
sisyphi
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 17
Inscrit le : 09 Fév 2006 19:57


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot] et 14 invité(s)