[Résolu]Procédure d'enregistrement en boucle au lancement

Questions liées au programme de setup ou à l'installation ainsi que des problèmes d'ordre général qui ne sont pas liés à un module spécifique (dictionnaire, impression, etc).

Modérateur: Vilains modOOs

[Résolu]Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 22 Nov 2011 18:32

bonjour,
j'ai eu des problèmes de plantage et récupération de fichiers en boucle; après recherches dans ce forum, j'ai cru trouver la réponse : j'ai effectué la purge des profils (dossier OpenOffice.org) comme expliqué, et j'ai pu utiliser Ooo hier soir sans problème.
Mais aujourd'hui, j'ai voulu réutiliser les fichiers avec lesquels j'avais eu des problèmes (un .doc et un .xls) et là j'ai eu à nouveau les mêmes ennuis, sauf qu'après avoir purgé les profils j'ai été confronté à un blocage complet : quand j'essaie d'accéder à Ooo, je tombe à chaque fois sur la procédure d'enregistrement qui me redemande mes noms, prénoms et initiales, et quand je clique sur "terminer" la fenêtre se ferme sans ouvrir une fenêtre Ooo.
Comment faire pour sortir de ce blocage complet ?
Je n'ai plus accès à aucun de mes documents texte et tableurs.

Merci de votre aide.
Dernière édition par jpjanuel le 06 Déc 2011 11:50, édité 3 fois.
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Re: OpenOffice inacessible

Messagepar Grenouille » 22 Nov 2011 18:42

Bonsoir,

Merci de trouver un titre plus parlant. "OpenOffice" est implicite ici. :D

jpjanuel a écrit:j'ai voulu réutiliser les fichiers avec lesquels j'avais eu des problèmes (un .doc et un .xls) et là j'ai eu à nouveau les mêmes ennuis,

Tu as dû lire aussi qu'il ne faut pas travailler dans ces formats qui sont propriétaires et fermés. Il faut convertir tout de suite tes documents en ODT et ODS.

Purge à nouveau ton profil et fais cette opération.

A+
OpenOffice 4.1.5 et LibreOffice 5.3.4 (par obligation) sous Windows 7
Avatar de l’utilisateur
Grenouille
ManitOOu
ManitOOu
 
Message(s) : 3223
Inscrit le : 13 Jan 2006 17:21
Localisation : Chasseneuil-du-Poitou / Futuroscope

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 23 Nov 2011 12:02

bonjour,
merci pour cette réponse.
J'ai converti mes fichiers .doc et .xls en .ods et .odt (pour celà, il a d'abord fallu que je désinstalle Ooo, puis que je le re-télécharge et le réinstalle, puisque je n'avais plus accès à Ooo).
J'ai pu travailler un peu hier soir sur ces fichiers aux formats Ooo, mais aujourd'hui rebelote : plantage, puis procédure d'enregistrement en boucle au lancement.
Le problème ne vient donc pas des formats de fichiers.
As-tu une solution ?
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Re: Procédure d'enregistrement en boucle au lancement

Messagepar Dude » 23 Nov 2011 12:06

Salut,

OpenOffice 3.3 sous Windows 7

OOo a t-il été installé avec les droits administrateur ?
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 20791
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 23 Nov 2011 20:57

désolé, je ne comprends pas la question...
merci de me donner des explications à la portée d'un utilisateur ordinaire.
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Re: Procédure d'enregistrement en boucle au lancement

Messagepar Dude » 23 Nov 2011 21:07

jpjanuel a écrit:désolé, je ne comprends pas la question...
merci de me donner des explications à la portée d'un utilisateur ordinaire.

Il m'avait semblé que...
jpjanuel a écrit:après recherches dans ce forum

A priori, tu n'as pas trouvé les tutoriels pour l'installation : viewtopic.php?p=147295#p147295&hilit=installation+droit+administrateur
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 20791
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 24 Nov 2011 00:25

re-bonsoir,
merci du tuyau...
mais celà n'a pas marché : j'ai suivi scrupuleusement les directives du tutorial, en particulier j'ai installé Ooo en choisissant "exécuter en tant qu'administrateur".
Mais après installation, quand je lance Ooo, à la fin de la procédure de création du profil, la fenêtre se ferme et Ooo ne s'ouvre pas.
Décourageant...
La seule anomalie que j'ai notée au cours de cette longue manip est, à la fin de la désinstallation, la tentative d'ouverture d'une page internet d'adresse "surveys.services.openoffice.org/deinstall" avec le message "page web inaccessible";
j'ai supposé que ce n'était pas important et je suis passé au téléchargement.

Merci de vos lumières...
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Re: Procédure d'enregistrement en boucle au lancement

Messagepar Ravioli » 24 Nov 2011 06:39

Bonjour,

la tentative d'ouverture d'une page internet d'adresse "surveys.services.openoffice.org/deinstall" avec le message "page web inaccessible"
Oui, ce n'est qu'un questionnaire de satisfaction (bien inutile à mon avis) lors d'une désinstallation. Ce n'est pas bloquant.

Si vous voulez bien répondre à chaque point suivant, peut-être allons-nous mettre en évidence le point bloquant.
  1. Préciser le début du problème :
    jpjanuel a écrit:j'ai eu des problèmes de plantage et récupération de fichiers en boucle

    1. OOo fonctionnait correctement puis l'ouverture d'un des 2 fichiers a provoqué un plantage ? Exact ou non ?

    2. OOo fermé et y compris le Démarrage rapide ( à désactiver car totalement inutile avec un Win7),
      avez-vous des fichiers cachés de 1 ko qui servent au partage des fichiers et qui doivent normalement disparaître à la fermeture du fichier initial du type :
      .~lock.NOM_du_fichier.odt# ou pour calc .~lock.NOM_du_fichier.ods#
      Ces fichiers s'ils persistent provoquent ce genre de problème de récupération systématique lors de la tentative de réouverture de OOo.
      Vous devez les supprimer.

  2. Vérification de votre dernière installation où OOo ne se lance pas :
    1. OOo figure-t-il bien dans Panneau de configuration > Programmes et fonctionnalités ? Oui ou Non
    2. Si Oui et si vous n'avez pas jeté le dossier OpenOffice.org 3.3 (fr) Installation Files du Bureau, avez vous tenté une Réparation de OOo (sélection de OOo dans Programmes et fonctionnalités et Menu > Réparer.
    3. L'icône de lancement a -t-elle été créée sur votre Bureau ?
    4. En cliquant directement sur le programme .exe dans C:\ Program Files(86)\ OpenOffice.org3\program\soffice.exe, OOo se lance-t-il ?

  3. Procédure de désinstallation du OOo défaillant
    Avez-vous après la désinstallation de OOo par Panneau de configuration > Programmes et fonctionnalités procédé à un nettoyage manuel Partie X du Tutoriel ( Sautez le $ D3 "Appliquez le dés-installateur spécial WINDOWS INSTALLER CLEANUP" cas de XP)
    Suppression du dossier OpenOffice.org3 dans C:\ Program Files(86)\ OpenOffice.org3 et de tous les Profils actifs (pas les sauvegardes OldOpenOffice.org) de tous les Utilisateurs et du OpenOffice.org 3.3 (fr) Installation Files sur le Bureau ?

A vous lire,
mais en tout état de cause,
avec Win7, la Restauration du système à une date antérieur à l'apparition du problème devrait tout résoudre.
Mais après la Restauration réussie, il faudra désinstaller OOo et les résidus de Ooo manuellement
réinstaller OOo en tant qu'administrateur, puis faire les MAJ Windows update...
Dernière édition par Ravioli le 24 Nov 2011 12:39, édité 1 fois.
AOO 4.1.1 LibO 4.4.5
Vista SP2, Win7 SP1, Win7 SP1 Pro, Win 8.1.1 Pro, Mac Intel OS X 10.10.5, Ubuntu 12.04 LTS 32 bits, OpenSuse 13.2, Debian 7
& LibO 4.0.6 pour Mac PPC 10.5.8
Avatar de l’utilisateur
Ravioli
GourOOu
GourOOu
 
Message(s) : 7610
Inscrit le : 18 Oct 2007 17:28

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 24 Nov 2011 12:17

merci pour votre aide.
Ravioli a écrit:OOo fonctionnait correctement puis l'ouverture d'un des 2 fichiers a provoqué un plantage ? Exact ou non ?
oui
Ravioli a écrit:avez-vous des fichiers cachés de 1 ko qui servent au partage des fichiers et qui doivent normalement disparaître à la fermeture du fichier initial du type :
j'en avais, mais je les avais supprimés avant de désinstaller
Ravioli a écrit:Vérification de votre dernière installation où OOo ne se lance pas :
OOo figure-t-il bien dans Panneau de configuration > Programmes et fonctionnalités ? Oui ou Non
Si Oui et si vous n'avez pas jeté le dossier OpenOffice.org 3.3 (fr) Installation Files du Bureau, avez vous tenté une Réparation de OOo (sélection de OOo dans Programmes et fonctionnalités et Menu > Réparer.
L'icône de lancement a -t-elle été créée sur votre Bureau ?
En cliquant directement sur le programme .exe dans C:\ Program Files(86)\ OpenOffice.org3\program\soffice.exe, OOo se lance-t-il ?

oui, Ooo figure bien dans Panneau de configuration > Programmes et fonctionnalités
j'ai jeté le dossier OpenOffice.org 3.3 (fr) Installation Files du Bureau, désolé
L'icône de lancement a bien été créée sur mon Bureau
En cliquant directement sur le programme .exe dans C:\ Program Files(86)\ OpenOffice.org3\program\soffice.exe, OOo lance sa procédure de création de profil, mais à la fin de cette procédure il se ferme.

Procédure de désinstallation du OOo défaillant : j'ai bien fait le nettoyage manuel et la suppression des profils, mais je ne me souviens pas d'avoir supprimé le dossier C:\ Program Files(86)\ OpenOffice.org3.

Que me conseillez-vous ?
Une piste m'est revenue à l'esprit : depuis plusieurs mois, j'essaie en vain d'installer la mise à jour de Windows "Service Pack 1 pour ordinateurs à processeurs x64" : la fin de la procédure d'installation (après le redémarrage de l'ordinateur) avorte systématiquement ; j'ai bien essayé de désactiver mon antivirus (Avast) mais il se réactive automatiquement au redémarrage. Ce pb de màj explique peut-être les dysfonctionnements d'Ooo ?
Tout celà est épouvantablement compliqué, j'espère que vous allez pouvoir m'aider à m'en sortir !
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Re: Procédure d'enregistrement en boucle au lancement

Messagepar Ravioli » 24 Nov 2011 12:27

Bonjour,

Voici une réponse complète :super: qui permet de mieux comprendre le blocage.

Si le programme est installé, je pense que le blocage provient peut-être d'Avast qui bloque l'application.
Vérifiez si OOo n'est pas dans sa liste "noire" ( suite à toutes ces manipulations.)

Un moyen de vérifier, c'est de lancer OOo avec Windows en mode sans échec : si OOo se lance, c'est qu'Avast le bloque en mode normal.

Les difficultés d'installation du pack 1 ne devraient pas être la cause directe du non lancement du programme ( puisque OOo fonctionnait avant le plantage).
Vous pouvez désinstaller Avast en utilisant son utilitaire de désinstallation http://www.avast.com/fr-fr/uninstall-utility
en rétablissant momentanément le parefeu Windows du temps de l'installation.
A+
AOO 4.1.1 LibO 4.4.5
Vista SP2, Win7 SP1, Win7 SP1 Pro, Win 8.1.1 Pro, Mac Intel OS X 10.10.5, Ubuntu 12.04 LTS 32 bits, OpenSuse 13.2, Debian 7
& LibO 4.0.6 pour Mac PPC 10.5.8
Avatar de l’utilisateur
Ravioli
GourOOu
GourOOu
 
Message(s) : 7610
Inscrit le : 18 Oct 2007 17:28

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 24 Nov 2011 16:34

merci encore
mais, vraiment désolé : je n'arrive pas à démarrer Windows en mode sans échec ; j'ai beau maintenir la touche F8 enfoncée, Windows démarre toujours en mode normal !
J'ai à nouveau besoin d'aide.
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Démarrer Vista ou Win7 en mode sans échec

Messagepar Ravioli » 24 Nov 2011 18:22

Bonsoir,
jpjanuel a écrit:je n'arrive pas à démarrer Windows en mode sans échec

En fait, il faut pianoter la touche F8 après le bip,

mais je préfère utiliser la méthode suivante :

  1. Menu Démarrer de Win 7 > Exécuter...
    ou encore plus simple Touche Windows + R (la touche Drapeau entre Ctrl et Alt)
  2. La boite de dialogue Exécuter s'ouvre
    Exécuter msconfig.png
    Taper msconfig
    Cliquez sur OK

  3. L'utilitaire de Configuration du système apparaît :
    Configuration du système-Démarrer.png
    Onglet Démarrer
    Dans Options de démarrage , Cocher Démarrage sécurisé et Minimal.
    Valider par Appliquer puis par OK
  4. Une invite de Configuration système
    InviteConfiguration Systeme2.png
    InviteConfiguration Systeme2.png (13.04 Kio) Consulté 10606 fois
    vous propose de Redémarrer l'ordinateur
    Cliquer le Bouton Redémarrer

  5. L'ordinateur redémarre en mode sans échec ( cela prend un certain temps...)

  6. Une fois en mode sans échec, faites vos manipulations.

  7. Puis même procédure mais à l'envers pour revenir au mode normal,
    Décocher Démarrage sécurisé et Valider par OK.
A+
AOO 4.1.1 LibO 4.4.5
Vista SP2, Win7 SP1, Win7 SP1 Pro, Win 8.1.1 Pro, Mac Intel OS X 10.10.5, Ubuntu 12.04 LTS 32 bits, OpenSuse 13.2, Debian 7
& LibO 4.0.6 pour Mac PPC 10.5.8
Avatar de l’utilisateur
Ravioli
GourOOu
GourOOu
 
Message(s) : 7610
Inscrit le : 18 Oct 2007 17:28

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 24 Nov 2011 20:05

merci beaucoup pour ces explications qui m'ont enfin permis de démarrer en mode sans erreur : j'ai pu ainsi constater qu'en mode sans erreur, Ooo fonctionne ; par contre, quand je suis revenu au mode normal, Ooo a bien accepté de s'ouvrir sur mon document texte, mais s'est bloqué au bout de quelques secondes. Ce blocage vient bien d'un autre logiciel : Avast ou autre.

Par ailleurs, cet après-midi j'ai réussi, grâce à vos explications de ce midi, à installer le Service Pack 1 de Windows après avoir désinstallé Avast ; je l'ai ensuite réinstallé. Tout celà a été très long et laborieux, mais je suis très content d'être enfin débarrassé de ce problème : merci encore.

Il reste à résoudre le conflit entre Ooo et Avast (ou autre) ; ce conflit est récent : j'utilisais Ooo et Avast depuis plus d'un an sans problème jusqu'à tout récemment.
pouvez-vous me guider pour résoudre ce conflit ? merci d'avance.
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Re: Procédure d'enregistrement en boucle au lancement

Messagepar richard_g » 24 Nov 2011 22:09

Bonjour.

Personnellement, je n'ai jamais eu de conflit OpenOffice/Avast sous Vista, mais si tu as toujours ce problème avec Win 7, je te suggère d'essayer d'examiner les paramètres d'Avast et de spécifier OpenOffice comme étant un processus de confiance. Je ne garantis rien, mais ça vaut peut-être la peine d'essayer. Pour cela, ouvrir le panneau Avast, Protection résidente, Agent actions suspectes, bouton Réglages Expert, choisir Processus de confiance, et sélectionner le(s) programme(s) avec le bouton Parcourir.

Histoire de t'assurer que c'est bien Avast qui est à l'origine du conflit, tu peux également essayer de le désactiver complètement après avoir démarré Win 7 en mode normal: clic droit sur la boule orange Avast dans la zone de notification, Gestion des agents Avast, et tu choisis la durée de désactivation.

 Ajout : Petite précision: j'utilise Avast antivirus gratuit version 6 avec le pare-feu de Windows. 


A+
Dernière édition par richard_g le 25 Nov 2011 11:35, édité 3 fois.
AOO401 Vista SP2 32 bits
Utilisez la Sauvegarde incrémentale!
richard_g
SuppOOrter
SuppOOrter
 
Message(s) : 1333
Inscrit le : 14 Mai 2009 09:58

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jf.l » 24 Nov 2011 23:18

Bonjour jpjanuel
Votre signature indique windows 7, mais vous semblez utiliser windows 7 x64 SP1 à ce jour. Pensez à mettre votre signature à jour. Editer vos messages précédents pour indiquer les versions du moment pourrait être utile aussi (windows 7 x86 ne fonctionne pas tout à fait comme windows 7 x64, et avant le SP1 ce n'était pas tout à fait pareil...)
Si OOo vous invite à vous enregistrer, c'est que la procédure de premier lancement a échoué, les informations liées n'ont pas été enregistrées, et la procédure reprendra jusqu'à ce que le programme soit satisfait. Pour nettoyer le registre, ccleaner après désinstallation pourrait être utile. Vous avez peut-être sauté une ligne en appliquant les tutoriels.
Pouvez-vous vérifier les droits associés à votre compte utilisateur sur les fichiers de votre profil OOo, ainsi que ceux des clés de registre associées à OOo ?
Pouvez-vous explorer le journal des évènements et nous indiquer si certains d'entre eux évoquent OOo (en général sous le nom "soffice") ou Avast au moment où vous lancez OOo ?
Avez-vous testé une version portable de OOo 3.3 ? Cela vous permettrait de mieux déterminer si le souci est lié à l'utilisation de OOo ou aux conditions particulières de son installation.
Avez-vous testé une réinstallation de OOo 3.2.1, ou de LibO ?
Cordialement,
JFL
Linux Mint 18.1 x64 + LibO 5.4.6 / LibO 5.4.7 + W10 x64
Avatar de l’utilisateur
jf.l
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 430
Inscrit le : 18 Mai 2010 19:49

Re: Procédure d'enregistrement en boucle au lancement

Messagepar Ravioli » 25 Nov 2011 08:53

Bonjour,

C'est bien que richard-g ait pris la relève car je n'ai pas Avast et ne peux vous aider à son sujet.

Il serait bon d'indiquer la version d'Avast que vous possédez,
Avast antivirus ou Avast Internet Sécurity (avec son parefeu http://www.avast.com/fr-fr/internet-security )
et si vous avez réinstallé Avast,
jpjanuel a écrit:après avoir désinstallé Avast

l'avez-vous fait avec son utilitaire déjà indiqué et nettoyé ses préférences,
et avez-vous téléchargé sa dernière version pour faire une ré-installation "propre" ?

L'idée de JF.l d'essayer d'installer LibO 3.4.4, j'allais vous la proposer en dernier recours.
cela permettrait de tester votre installation, (Avast devant créer une nouvelle règle pour LibO).
Windows Première Installation de LibO 3.4.4
Cordialement,
AOO 4.1.1 LibO 4.4.5
Vista SP2, Win7 SP1, Win7 SP1 Pro, Win 8.1.1 Pro, Mac Intel OS X 10.10.5, Ubuntu 12.04 LTS 32 bits, OpenSuse 13.2, Debian 7
& LibO 4.0.6 pour Mac PPC 10.5.8
Avatar de l’utilisateur
Ravioli
GourOOu
GourOOu
 
Message(s) : 7610
Inscrit le : 18 Oct 2007 17:28

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 25 Nov 2011 13:31

bonjour,
je suis très honoré d'avoir 3 spécialistes pour venir à mon secours.
Ma version d'Avast est : Avast 6.0.1289 gratuite ; j'utilise le pare-feu de Windows.
j'ai effectué les tests suggérés par richard-g : j'ai spécifié Ooo comme processus de confiance dans Avast : aucun résultat ; j'ai ensuite désactivé Avast puis lancé Ooo : toujours pas de résultat (plantage à la fin de la procédure d'enregistrement, plus exactement lorsque j'envoie le rapport d'erreur).
Tout celà suggère qu'Avast n'est pas en cause.
Par ailleurs, j'ai mis à jour ma signature comme le demande jf.l, mais je ne sais pas comment la modifier message par message.

Pour le reste, j'y reviendrai plus tard car je suis obligé de m'absenter.
Merci pour votre aide.
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Re: Procédure d'enregistrement en boucle au lancement

Messagepar richard_g » 25 Nov 2011 13:39

Bonjour.

Avast n'est donc pas en cause, ce qui ne me surprend pas vu que je l'utilise depuis longtemps d'abord avec OOo, puis avec LibO, et que je n'ai jamais eu de conflit (actuellement Avast 6.0.1289)
Tu pourrais peut-être tenter une désinstallation de OOo suivie d'un nettoyage complet du PC si tu ne l'as pas déjà fait (profil utilisateur, dossier dans Program Files, et nettoyage du registre avec Ccleaner) puis réinstaller OOo en suivant les tutoriels. Mais je te conseille d'essayer LibO344 comme l'ont suggéré Ravioli et jf.l (voir le lien de Ravioli).

A+
AOO401 Vista SP2 32 bits
Utilisez la Sauvegarde incrémentale!
richard_g
SuppOOrter
SuppOOrter
 
Message(s) : 1333
Inscrit le : 14 Mai 2009 09:58

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 25 Nov 2011 16:15

je suis allé fureter dans le journal des évènements comme suggéré par jf.l, j'ai constaté qu'une application (serveur média Orange) génère énormément d'erreurs, je l'ai désinstallée mais celà ne résoud pas mon problème avec Ooo.
voici un évènement généré par Ooo :
Le programme soffice.bin version 3.3.9556.500 a cessé d’interagir avec Windows et a été fermé. Pour déterminer si des informations supplémentaires sont disponibles, consultez l’historique du problème dans le Centre de maintenance.
ID de processus : 1834
Heure de début : 01ccab6b0c5a4c23
Heure de fin : 5
Chemin d’accès de l’application : C:\Program Files (x86)\OpenOffice.org 3\program\soffice.bin

Au passage, vous pouvez constater que ma version Windows serait x86 et non x64 ; je n'ai pas réussi à trouver la réponse à cette question.

Par ailleurs, je n'ai pas réussi à "vérifier les droits associés à votre compte utilisateur sur les fichiers de votre profil OOo, ainsi que ceux des clés de registre associées à OOo" comme le demande jf.l, celà dépasse mon niveau.
Mais j'ai constaté que dans le dossier du profil Ooo (OpenOffice.org>3), il y a, à côté du dossier "user", un fichier ".lock" de taille = 1 K : faut-il le supprimer ?

Si ces quelques éléments ne suffisent pas à faire avancer le schmilblick, je m'y remettrai ce soir.
Merci en tous cas.
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Re: Procédure d'enregistrement en boucle au lancement

Messagepar richard_g » 25 Nov 2011 16:35

Re-bonjour

jpjanuel a écrit:Au passage, vous pouvez constater que ma version Windows serait x86 et non x64 ; je n'ai pas réussi à trouver la réponse à cette question.


Tu trouveras la réponse (système 32 bits ou système 64 bits) dans le panneau de configuration. Pour Vista, une fois le panneau ouvert, on accède aux détails du système par Système et maintenance -> Système. Cela ne devrait pas être trop différent pour Win 7.

jpjanuel a écrit:Par ailleurs, je n'ai pas réussi à "vérifier les droits associés à votre compte utilisateur sur les fichiers de votre profil OOo, ainsi que ceux des clés de registre associées à OOo" comme le demande jf.l, celà dépasse mon niveau.


J'ai définitivement désactivé les contrôles de compte utilisateur dans Vista, et depuis longtemps ! Même en travaillant sur le compte administrateur, ça me cassait constamment les pieds ! Alors j'imagine ce que ça doit être pour les comptes utilisateurs sans droit d'administrateur... :roll: Pour Win 7, tu devrais trouver ça dans le centre de sécurité, toujours en te baladant dans le panneau de configuration. Fais une recherche sur le forum, je crois qu'on en a parlé : viewtopic.php?p=168346#p168346 .


jpjanuel a écrit:Mais j'ai constaté que dans le dossier du profil Ooo (OpenOffice.org>3), il y a, à côté du dossier "user", un fichier ".lock" de taille = 1 K : faut-il le supprimer ?


Oui. Ce fichier apparait lorsque OOo est ouvert, et il doit disparaître quand on ferme OOo... sauf en cas de plantage! :mrgreen:

Si rien ne marche, passe à LibO344 en suivant le tutoriel de Ravioli pour une première installation. :wink:

A+
AOO401 Vista SP2 32 bits
Utilisez la Sauvegarde incrémentale!
richard_g
SuppOOrter
SuppOOrter
 
Message(s) : 1333
Inscrit le : 14 Mai 2009 09:58

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 26 Nov 2011 19:50

J'ai bien cru hier soir être arrivé au bout de mes peines : en effet, après avoir supprimé le fichier .lock dans le dossier du profil Ooo, j'ai pu lancer Ooo et l'utiliser avec les fichiers sur lesquels il s'était planté, j'ai pu imprimer, modifier des doc, en créer d'autres ; bref, le miracle !
Mais aujourd'hui, j'ai eu à nouveau un plantage quelques secondes après avoir ouvert un document .ods ; je suis allé voir dans le profil : le fichier .lock avait réapparu !
Mon problème n'est donc pas complètement résolu ; nous avons soigné les symptômes, mais pas leur cause...
C'est déjà un résultat fort appréciable, et je remercie vivement tous ceux qui m'ont aidé, mais si quelqu'un peut m'expliquer pourquoi j'ai ces plantages et pourquoi ce fichier .lock réapparait de temps en temps, ce serait parfait.

J'ai bien noté l'idée de passer à LibreOffice, mais j'hésite encore à me lancer dans ce processus complexe, d'autant plus que la dernière version de LibreOffice n'a été publiée que depuis 15 jours.
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jeanmimi » 26 Nov 2011 19:55

ce fichier .lock réapparait de temps en temps
Le ficher .lock est normal, il est créé pour éviter que deux personnes ouvrent et écrivent en même temps dans le même fichier.
Quant à l’installation de LibO, situ sais faire un téléchargement puis un double clic sur un fichier, tu en sais assez pour débuter puis ensuite finaliser avec le tutoriel du forum.
LibreOffice Version : Version: 6.3.0 (x64) (10 août 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14929
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Procédure d'enregistrement en boucle au lancement

Messagepar richard_g » 26 Nov 2011 20:07

Bonjour.

On dirait que ça progresse. :mrgreen:

Pour ce fichier .lock récalcitrant, je n'ai pas trop d'idée. J'espère que d'autres en auront.

Pour l'installation de LibO, ce n'est pas trop compliqué. Le tutoriel est un peu volumineux, mais il répertorie tous les cas possibles. Repère le cas correspondant à ta situation et pour simplifier, tu peux utiliser l'installation standard qui conserve tous les dictionnaires. Attention au lancement de l'installation sous Vista et Win 7: clic-droit sur le fichier .exe et Exécuter en tant qu'administrateur (pas de double-clic sous Vista et Win 7 !!!). LibO cohabite avec OOo sans interférence, les profils utilisateurs étant indépendants. La version actuelle LibO344 n'est pas une nouvelle version: c'est la quatrième mise à jour de la 340 (des corrections de bogues) et elle me parait très stable. Les versions pas très stables sont surtout les x.x.0. :wink:

 Ajout : Piste intéressante soulevée par gerard24 ci-dessous. Avec Vista, j'ai IE7 et j'ai toujours refusé le passage aux versions suivantes proposé dans les mises à jour de Windows. IE9 pourrait donc bien être le programme responsable du conflit puisque l'antivirus n'est apparemment pas en cause. A suivre... 


A+
Dernière édition par richard_g le 27 Nov 2011 20:09, édité 1 fois.
AOO401 Vista SP2 32 bits
Utilisez la Sauvegarde incrémentale!
richard_g
SuppOOrter
SuppOOrter
 
Message(s) : 1333
Inscrit le : 14 Mai 2009 09:58

Re: Procédure d'enregistrement en boucle au lancement

Messagepar gerard24 » 26 Nov 2011 21:45

Bonsoir,

Une autre piste :
Sur le forum anglo-saxon, un certain nombre de messages font état d'incompatibilité avec IE9 avec les mêmes symptômes que toi.
http://user.services.openoffice.org/en/ ... mit=Search
OOodidacte
LibreOffice 6.2.4 sous Windows 10.
pour télécharger LibreOffice
Avatar de l’utilisateur
gerard24
ManitOOu
ManitOOu
 
Message(s) : 3122
Inscrit le : 06 Juil 2008 18:08
Localisation : dans le Périgord

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 28 Nov 2011 16:37

merci pour cette suggestion ; les messages du site anglo-saxons me rappellent mes déboires.
Je n'utilise pas Internet Explorer ; mon navigateur par défaut est Google Chrome ; il arrive cependant que certains liens sur le Net activent par défaut IE, et j'ai vérifié que j'ai bien IE9.
Il est donc possible que mes problèmes viennent d'IE9.

Mais j'ai essayé en vain d'utiliser la procédure standard de désinstallation de programmes : Internet Explorer n'apparait pas dans la liste... (je me souviens qu'autrefois IE était intégré dans Windows, est-ce encore le cas ?)
Il doit y avoir une autre procédure pour désinstaller IE9 ; quelqu'un peut-il me la fournir ?
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Re: Procédure d'enregistrement en boucle au lancement

Messagepar Ravioli » 28 Nov 2011 16:46

Bonjour,

Google est aussi ton ami...
http://windows.microsoft.com/fr-FR/wind ... explorer-9
Pour désinstaller Internet Explorer

Les instructions suivantes s'appliquent à Windows 7 et à Windows Vista.
Cliquez sur le bouton DémarrerImage du bouton Démarrer, tapez Programmes et fonctionnalités dans la zone de recherche, puis cliquez sur Afficher les mises à jour installées dans le volet gauche.
Sous Désinstaller une mise à jour, faites défiler vers le bas jusqu'à la section Microsoft Windows.
Cliquez avec le bouton droit sur Windows Internet Explorer 9, cliquez sur Désinstaller puis, lorsque le système vous invite, cliquez sur Oui.
Cliquez sur l'une des options suivantes :
    Redémarrer maintenant (pour terminer le processus de désinstallation d'Internet Explorer 9 et restaurer la version précédente d'Internet Explorer).
    Redémarrer plus tard (pour attendre le prochain arrêt ou redémarrage de votre ordinateur).

Remarque
Une fois Internet Explorer 9 désinstallé, la version précédemment installée d'Internet Explorer sera disponible sur votre ordinateur. Vous n'avez pas besoin de la réinstaller.


A+
AOO 4.1.1 LibO 4.4.5
Vista SP2, Win7 SP1, Win7 SP1 Pro, Win 8.1.1 Pro, Mac Intel OS X 10.10.5, Ubuntu 12.04 LTS 32 bits, OpenSuse 13.2, Debian 7
& LibO 4.0.6 pour Mac PPC 10.5.8
Avatar de l’utilisateur
Ravioli
GourOOu
GourOOu
 
Message(s) : 7610
Inscrit le : 18 Oct 2007 17:28

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 28 Nov 2011 23:30

merci beaucoup
j'ai désinstallé EI9, et ensuite j'ai pu utiliser Ooo sans problème pendant 2 heures : youpiii !...
mais depuis, j'ai constaté que plusieurs logiciels Windows ne fonctionnent plus : en particulier Windows Mail (les titres des messages s'affichent, mais on ne peut plus les ouvrir) et l'aide Windows.

je cherche en vain comment réparer ce nouveau pb.
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27

Re: Procédure d'enregistrement en boucle au lancement

Messagepar richard_g » 29 Nov 2011 09:56

Bonjour.

jpjanuel a écrit:j'ai constaté que plusieurs logiciels Windows ne fonctionnent plus : en particulier Windows Mail (les titres des messages s'affichent, mais on ne peut plus les ouvrir) et l'aide Windows.


D'où l'intérêt d'utiliser des logiciels libres comme Thunderbird pour le courrier (pub gratuite) :mrgreen:
Pour l'aide Windows, c'est plus embêtant. Je suppose que tes logiciels attendent IE9, ce qui est surprenant car la désinstallation d'IE9 réinstalle en principe IE8. Ça doit pouvoir se régler en bricolant la base de registres, mais avant de te lancer dans ce genre de bricolage, tu devrais te tourner vers un forum Win 7.

 Ajout : Sur Google tu trouveras quantité de références sur les problèmes Windows mail et IE9. Ce qui serait en cause serait la msoe.dll dans le dossier Windows mail, et il faudrait restaurer une ancienne version. J'ai aussi trouvé ce fil sur l'utilisation de Windows mail sur Win 7: h**p://www.chantal11.com/2009/06/utiliser-windows-mail-sous-windows-7/.
Mais comme Ravioli, je suggère l'association Firefox / Thunderbird. 


A+
Dernière édition par richard_g le 29 Nov 2011 11:24, édité 1 fois.
AOO401 Vista SP2 32 bits
Utilisez la Sauvegarde incrémentale!
richard_g
SuppOOrter
SuppOOrter
 
Message(s) : 1333
Inscrit le : 14 Mai 2009 09:58

Re: Procédure d'enregistrement en boucle au lancement

Messagepar Ravioli » 29 Nov 2011 10:14

Bonjour,
+1
richard_g a écrit:D'où l'intérêt d'utiliser des logiciels libres comme Thunderbird pour le courrier

J'ajouterais simplement que j'utilise Thunderbird 8 avec FireFox 8
c'est un couple qui fonctionne très bien.
http://www.frenchmozilla.fr/

Pour l'aide de Windows, je passe par FireFox tout simplement : http://support.microsoft.com/?ln=fr

A+
PS : Mes extensions de FireFox
    Adblock Plus : Anti publicité
    Element Hiding Helper pour Adlock Plus ( Pour d'autres images publicitaires récalcitrantes)
    MD5 Reborned Hasher pour vérifier les sommes MD5 des téléchargements
    All-in-One SideBar pour avoir un panneau latéral bien commode
    Tab Mix Plus pour une gestion complémentaire des Onglets
    SearchWP pour une recherche plus conviviale.
AOO 4.1.1 LibO 4.4.5
Vista SP2, Win7 SP1, Win7 SP1 Pro, Win 8.1.1 Pro, Mac Intel OS X 10.10.5, Ubuntu 12.04 LTS 32 bits, OpenSuse 13.2, Debian 7
& LibO 4.0.6 pour Mac PPC 10.5.8
Avatar de l’utilisateur
Ravioli
GourOOu
GourOOu
 
Message(s) : 7610
Inscrit le : 18 Oct 2007 17:28

Re: Procédure d'enregistrement en boucle au lancement

Messagepar jpjanuel » 29 Nov 2011 16:27

bonjour,
merci pour tous ces tuyaux.
Il se trouve que j'avais déjà eu tout seul le bon réflexe d'installer Thunderbird : j'ai eu de la peine à récupérer mon carnet d'adresses, mais j'y suis finalement parvenu et je suis très content de cette messagerie.
Je conserve précieusement tes conseils.
OpenOffice 3.3 sous Windows 7 x64 SP1
jpjanuel
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 22 Nov 2011 12:27


Retour vers Installation et configuration

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 3 invité(s)