[Résolu] Switchboard inactif

Discussions sur le module de base de données Base et plus particulièrement sur le langage SQL ou sur les connexions aux SGBD tiers.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est dédiée au module Base et plus particulièrement sur le langage SQL ou sur les connexions aux SGBD tiers. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.
Pour accélérer les réponses, vous pouvez mettre en ligne votre base en joignant un fichier ODB : comment faire.

[Résolu] Switchboard inactif

Messagepar Webvidéo » 15 Oct 2019 14:56

Bonjour

J'ai trouvé une application qui ouvre un formulaire lors du lancement de celle-ci.
J'ai voulu reproduire cela dans application personnelle en, recopiant le code mais, cela ne fonctionne pas.
Pourtant, lorsque je teste la macro en pas à pas, ça fonctionne.
Je ne comprends pas, pouvez-vous en trouver la raison et, me l'expliquer ?
P.S. A 66 ans, la compréhension est plus lente, merci.
Cordialement.
Webvidéo
Pièces jointes
Test_Compte famille.odb
Même code mais, pas d'action
(23.58 Kio) Téléchargé 14 fois
TEST switchboard.odb
Le formulaire s'ouvre au démarrage de l'application
(209.24 Kio) Téléchargé 15 fois
Dernière édition par Webvidéo le 15 Oct 2019 16:10, édité 1 fois.
LibreOffice Version: 6.0.7.3
Ubuntu 18.4.3 LTS
Webvidéo
Membre lOOyal
Membre lOOyal
 
Message(s) : 30
Inscrit le : 29 Mars 2011 16:00
Localisation : Belgique

Re: Switchboard inactif

Messagepar Hubert Lambert » 15 Oct 2019 15:33

Bonjour,

Il te faut associer la macro à l'événement "Ouvrir le document" dans Outils -> Personnaliser, onglet Événements.
Cordialement.
AOOo 4.1.7 sur Win10
AOOo 4.1.x sur Linux Mint
LibreOffice 5.x/6.x sur Linux Mint
--
| « Nos défauts devraient nous donner une qualité : l'indulgence pour les défauts des autres » (Rivarol)
Avatar de l’utilisateur
Hubert Lambert
SuppOOrter
SuppOOrter
 
Message(s) : 1159
Inscrit le : 06 Avr 2016 08:26

Re: Switchboard inactif

Messagepar Webvidéo » 15 Oct 2019 16:07

Bonjour Hubert Lambert

Je ne savais pas qu'il fallait suivre ce chemin pour associer la macro.
J'allais dans propriétés du formulaire et événements et c'est pour cela que je ne voyais pas l'association dans l'application qui fonctionnait.

Merci pour votre aide car cela fait quelques heures que je cherche une raison.

Cordialement.

Webvidéo
LibreOffice Version: 6.0.7.3
Ubuntu 18.4.3 LTS
Webvidéo
Membre lOOyal
Membre lOOyal
 
Message(s) : 30
Inscrit le : 29 Mars 2011 16:00
Localisation : Belgique


Retour vers Base de données

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 2 invité(s)