[Issue] Blocage OO 4.1.5 sous MacOS 10.13.x

Discussions sur le module de base de données Base et plus particulièrement sur le langage SQL ou sur les connexions aux SGBD tiers.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est dédiée au module Base et plus particulièrement sur le langage SQL ou sur les connexions aux SGBD tiers. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.
Pour accélérer les réponses, vous pouvez mettre en ligne votre base en joignant un fichier ODB : comment faire.

[Issue] Blocage OO 4.1.5 sous MacOS 10.13.x

Messagepar jpc4 » 07 Avr 2018 10:47

Bonjour,
J'utilise OO version 4.1.3 sans problème avec ma Base "Discothèque Classique". Après mise à jour OO version 4.1.5, quand je lance l'ouverture de ma base, l'application OO se ferme immédiatement. J'ai ensuite installé la nouvelle version de Java "jre-8u161-macosx-x64", mais le problème subsiste.
En désespoir de cause, j'ai donc réinstallé l'ancienne version de Java "javaforosx" et restauré la version OO 4.1.3 et ma base fonctionne de nouveau.
Merci d'avance de vos conseils pour résoudre cette difficulté.
Cordialement.
jpc4
Dernière édition par micmac le 19 Nov 2018 17:37, édité 5 fois.
Raison: Ajout de l'icône flamme
OpenOffice 4.1.3 sous MacOS 10.13.4
jpc4
NéOOphyte
NéOOphyte
 
Message(s) : 92
Inscrit le : 13 Sep 2015 16:07

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar tintin » 07 Avr 2018 11:24

Bonjour,
jpc4 a écrit:OO 4.1.5 sous OS 10.13.4

votre signature a écrit:OpenOffice 4.1.3 sous MacOS 10.13.3

Accès direct à votre signature pour la corriger.

Donc depuis votre message du 05 février 2018 rien n'a changé.

Vous installez, désinstallez et réinstallez sans dire comment vous faites.
Lisez [Java] Installation du JRE 8.0_x pour MacOS X
[AOO] Installation AOO 4.1.5 sur MacOS X
et éventuellement
[AOO] Désinstaller et Réinstaller proprement sur MacOS X

S'il s'agit d'une base en particulier, joignez-la vous faciliterez la compréhension : Comment joindre un fichier
De façon tout à fait exceptionnelle, et comme cela se pratique occasionnellement en section Récupération de documents, si le fichier dépasse les 500 Ko acceptés vous pouvez le joindre en passant uniquement par le site :Cjoint
AOO 4.1.6 / macOS 10.14.6 Mojave
JRE-8u221 / Firefox / Safari / Thunderbird / Time Machine
Tutoriels du forum pour macOS
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6116
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar jpc4 » 07 Avr 2018 13:21

Merci de votre réponse :-)

Concernant Java, j'ai téléchargé le version "jre-8u161-macosx-x64.dmg". Je lance, montage du disque, double-click sur le fichier, mot de passe administrateur, redirection vers le site Java, vérification MAJ OK.

Concernant OO 4.1.5, j'ai téléchargé la version "Apache_OpenOffice_4.1.5_MacOS_x86-64_install_fr.dmg". Je lance l'image disque, puis transfert du fichier OpenOffice dans le dossier Applications, j'accepte le remplacement de l'ancien fichier par le nouveau, je lance OpenOffice 4.1.5, je retrouve toutes les informations précédentes dans Préférences. Base propose d'ouvrir fichier récent "Discothèque", je clique, et OpenOffice quitte immédiatement.

Je vous envoie ma base séparément par le site Cjoint.

Cordialement.

jpc4
OpenOffice 4.1.3 sous MacOS 10.13.4
jpc4
NéOOphyte
NéOOphyte
 
Message(s) : 92
Inscrit le : 13 Sep 2015 16:07

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar jpc4 » 07 Avr 2018 13:27

Avec le lien du fichier Cjoint
https://www.cjoint.com/c/HDhmz4UFg0z
jpc4
OpenOffice 4.1.3 sous MacOS 10.13.4
jpc4
NéOOphyte
NéOOphyte
 
Message(s) : 92
Inscrit le : 13 Sep 2015 16:07

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar tintin » 07 Avr 2018 14:52

La base plante à l'ouverture.
En désactivant les macros elle s'ouvre.
Je pense qu'il faut voir avec les spécialistes macros.
AOO 4.1.6 / macOS 10.14.6 Mojave
JRE-8u221 / Firefox / Safari / Thunderbird / Time Machine
Tutoriels du forum pour macOS
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6116
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar jpc4 » 07 Avr 2018 15:15

OK, merci :-)
Comment je fais pour voir avec les spécialistes macro ? Je reposte mon message à un autre endroit du forum ?
jpc4
OpenOffice 4.1.3 sous MacOS 10.13.4
jpc4
NéOOphyte
NéOOphyte
 
Message(s) : 92
Inscrit le : 13 Sep 2015 16:07

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar tintin » 07 Avr 2018 15:57

Bonjour,

Pour moi - mais je ne sais pas tout - au regard de ce que j'ai constaté, votre problème relève des macros et non de MacOS.
Je vous suggère d'ouvrir un nouveau sujet dans la section Macros et API avec le balisage [Base] et un titre explicite, d'y mettre un lien vers le présent fil et ici, le lien vers le nouveau.

Cordialement
AOO 4.1.6 / macOS 10.14.6 Mojave
JRE-8u221 / Firefox / Safari / Thunderbird / Time Machine
Tutoriels du forum pour macOS
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6116
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar jeanmimi » 07 Avr 2018 17:26

Bonjour,
Que les Macros soient activées, ou pas, la Base s'ouvre sans problème sur ma configuration.
Ouverture Base.png
Ouverture Base.png (5.13 Kio) Consulté 1138 fois

Puis le formulaire Menu s'ouvre, après 3 secondes d'attente.
Affcihage Formulaire après l'ouverture de la Base.png
LibreOffice Version : Version: 6.3.0 (x64) (10 août 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14929
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar jpc4 » 07 Avr 2018 17:31

Merci Tintin,
Le lien vers le sujet exposé dans la section Macros et API :
https://forum.openoffice.org/fr/forum/viewtopic.php?f=8&t=57573#p310936
Cordialement.
jpc4


La modération a écrit:lien devenu inutile. Ce nouveau sujet a été classé comme doublon
OpenOffice 4.1.3 sous MacOS 10.13.4
jpc4
NéOOphyte
NéOOphyte
 
Message(s) : 92
Inscrit le : 13 Sep 2015 16:07

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar tintin » 07 Avr 2018 17:44

Bonjour,

Bon, je confirme qu'au lancement et activation des macros il y a ouverture puis fermeture après une seconde. Le fichier .lck reste présent.
Suppression du fichier .lck, > relance de la base > Désactivation des macros > La base s'ouvre.

Je n'ai aucun problème avec mes Bases, ma configuration Java est correcte et la sécurité des macros sur Moyen

Voir ce fil [Issue] Crash AOO 4.1.5 avec macro autoexec sous MacOS

Pas de plantage sur LibreOffice avec la base de jpc4
Dernière édition par tintin le 07 Avr 2018 17:52, édité 2 fois.
AOO 4.1.6 / macOS 10.14.6 Mojave
JRE-8u221 / Firefox / Safari / Thunderbird / Time Machine
Tutoriels du forum pour macOS
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6116
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar jeanmimi » 07 Avr 2018 17:48

tintin a écrit:Pas de plantage sur LibreOffice
Une question : est-ce que le code des Macros est totalement compatible avec le Basic de AOO, puisqu'il me semble avoir lu qu'il y a maintenant des différences.
LibreOffice Version : Version: 6.3.0 (x64) (10 août 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14929
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar tintin » 07 Avr 2018 17:51

Tout ce que je peux dire c'est que pour LibreOffice, la combinaison JDK6 + JRE 8 ne fonctionne pas.
Il faut installer JDK8 sur un Mac.
J'ai donc JDK6 + JRE 8 pour OpenOffice et JDK8 pour LibreOffice.
AOO 4.1.6 / macOS 10.14.6 Mojave
JRE-8u221 / Firefox / Safari / Thunderbird / Time Machine
Tutoriels du forum pour macOS
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6116
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar jpc4 » 07 Avr 2018 18:08

Bonjour jeanmimi,
Désolé, je n'y entends rien à toutes ces initiales : NéOOphyte, c'est écrit :-)
Que faut-il donc que j'installe sur mon Mac ? Qu'est-ce que JDK6, JDK8 et JRE8 ?
jpc4
OpenOffice 4.1.3 sous MacOS 10.13.4
jpc4
NéOOphyte
NéOOphyte
 
Message(s) : 92
Inscrit le : 13 Sep 2015 16:07

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar tintin » 07 Avr 2018 18:23

Vous n'avez probablement pas lu ce message où je donne le lien [Java] Installation du JRE 8.0_x pour MacOS X.
AOO 4.1.6 / macOS 10.14.6 Mojave
JRE-8u221 / Firefox / Safari / Thunderbird / Time Machine
Tutoriels du forum pour macOS
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6116
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar jpc4 » 07 Avr 2018 19:25

OK, pigé pour les abréviations.
Donc, nouvel essai, j'installe Java 8 Update 161 (même procédure, qui se termine dans le navigateur avec la vérification de la version Java et les félicitations d'Oracle).
Puis téléchargement de l'ancien moteur Java 6 sur le site Apple et installation réussie du paquet.
Puis installation Apache OpenOffice 4.1.5, lancement de l'application, RAS, puis ouverture Base Discothèque et plantage :-(
Puis restauration Apache OpenOffice 4.1.3 depuis Time Machine, la Base Discothèque fonctionne :-)
jpc4
OpenOffice 4.1.3 sous MacOS 10.13.4
jpc4
NéOOphyte
NéOOphyte
 
Message(s) : 92
Inscrit le : 13 Sep 2015 16:07

Re: Blocage OO 4.1.5 sous OS 10.13.4

Messagepar micmac » 08 Avr 2018 07:35

Bonjour,

Ce comportement semble relever de l'Issue 127646 - Base crashes with macro autoexec comme supposé dans le message de tintin
Dans ce cas, veuillez baliser Image[Issue] le titre du premier message de ce fil.
Dans votre signature vous devez préciser la ou les versions exactes d'OpenOffice ou de LibreOffice et du ou des systèmes utilisés.
Exemple : AOO 4.1.6 (version imposée selon le cas) sous Win7 SP1, Win 8.1, Win 10, macOS 10.14.5, Ubuntu 18.10...
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 5970
Inscrit le : 28 Août 2010 09:45

Re: [Issue] OO 4.1.5 sous OS 10.13.4

Messagepar jpc4 » 08 Avr 2018 08:51

Bonjour,
En attendant une nouvelle MAJ d'OO réglant ce problème de macro autoexec, est-ce que je peux contourner le problème en utilisant ma Base avec LibreOffice plutôt qu'avec OpenOffice ?
jpc4
OpenOffice 4.1.3 sous MacOS 10.13.4
jpc4
NéOOphyte
NéOOphyte
 
Message(s) : 92
Inscrit le : 13 Sep 2015 16:07

Re: [Issue] OO 4.1.5 sous OS 10.13.4

Messagepar jeanmimi » 08 Avr 2018 09:09

jpc4 a écrit:contourner le problème en utilisant ma Base avec LibreOffice

C'est possible en attendant la résolution de l'issue.
Dans ce fil de messages, nous sommes deux a avoir testé ta Base avec LO sans difficulté.
LibreOffice Version : Version: 6.3.0 (x64) (10 août 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14929
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: [Issue] OO 4.1.5 sous OS 10.13.4

Messagepar micmac » 08 Avr 2018 10:36

Il ne suffit pas d'attendre, il faut voter pour faire avancer la résolution de cette régression.
Reporter un bogue, demander une amélioration ou voter

Les deux suites cohabitent sans problème.
Suivre [LibO] Installation de LibreOffice sur MacOS X
Dans votre signature vous devez préciser la ou les versions exactes d'OpenOffice ou de LibreOffice et du ou des systèmes utilisés.
Exemple : AOO 4.1.6 (version imposée selon le cas) sous Win7 SP1, Win 8.1, Win 10, macOS 10.14.5, Ubuntu 18.10...
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 5970
Inscrit le : 28 Août 2010 09:45

Re: [Issue] OO 4.1.5 sous OS 10.13.4

Messagepar jpc4 » 08 Avr 2018 12:25

OK, j'ai créé une connexion à Bugzilla et mis 2 votes sur l'issue 127646.
Merci.
jpc4
OpenOffice 4.1.3 sous MacOS 10.13.4
jpc4
NéOOphyte
NéOOphyte
 
Message(s) : 92
Inscrit le : 13 Sep 2015 16:07

Re: [Issue] OO 4.1.5 sous MacOS 10.13.4

Messagepar tintin » 09 Avr 2018 09:57

Bonjour,

AOO 4.2.0 téléchargeable ici pour essais ne donne pas de meilleur résultat pour l'instant avec cette même base.
https://bz.apache.org/ooo/show_bug.cgi?id=127646#c13
AOO 4.1.6 / macOS 10.14.6 Mojave
JRE-8u221 / Firefox / Safari / Thunderbird / Time Machine
Tutoriels du forum pour macOS
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6116
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: [Issue] OO 4.1.5 sous MacOS 10.13.4

Messagepar jpc4 » 09 Avr 2018 13:38

Bonjour,
Effectivement AOO 4.2.0 plante à l'ouverture de ma base.
jpc4
OpenOffice 4.1.3 sous MacOS 10.13.4
jpc4
NéOOphyte
NéOOphyte
 
Message(s) : 92
Inscrit le : 13 Sep 2015 16:07

Re: [Issue] OO 4.1.5 sous MacOS 10.13.4

Messagepar CrazyDams » 21 Sep 2018 13:04

Bonjour,

Je rencontre également ce problème de lancement automatique d'une macro à l'ouverture d'un document. Lorsque je teste ma base sur mac tout plante, alors que cela fonctionne parfaitement sur Windows. Je viens donc de voter sur bugzilla pour l'issue

https://bz.apache.org/ooo/show_bug.cgi?id=127646

Pour l'instant il n'y a que 6 votes...

Merci d'aider en votant pour résoudre ce problème.
Merci à tous et à toutes
Apache OpenOffice 4.1.5
Windows 8.1 64 bits
CrazyDams
Membre lOOyal
Membre lOOyal
 
Message(s) : 34
Inscrit le : 27 Août 2018 07:54

Re: [Issue] OO 4.1.5 sous MacOS 10.13.x

Messagepar tintin » 19 Nov 2018 16:44

Bonjour,

Ce dysfonctionnement n'est pas réglé avec AOO 4.1.6
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6116
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: [Issue] OO 4.1.5 sous MacOS 10.13.x

Messagepar jpc4 » 19 Nov 2018 17:05

Bien noté, je continue à utiliser OO 4.1.3 en attendant :(
A +
OpenOffice 4.1.3 sous MacOS 10.13.4
jpc4
NéOOphyte
NéOOphyte
 
Message(s) : 92
Inscrit le : 13 Sep 2015 16:07


Retour vers Base de données

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 4 invité(s)