[Résolu]Impossible d'obtenir un rapport en mode Ebauche

Discussions sur le module de base de données Base et plus particulièrement sur le langage SQL ou sur les connexions aux SGBD tiers.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est dédiée au module Base et plus particulièrement sur le langage SQL ou sur les connexions aux SGBD tiers. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.
Pour accélérer les réponses, vous pouvez mettre en ligne votre base en joignant un fichier ODB : comment faire.

[Résolu]Impossible d'obtenir un rapport en mode Ebauche

Messagepar kikibelux » 12 Sep 2015 20:38

Bonsoir à tous,

j'ai parcouru ce superbe forum avant de poser ma question; j'ai en fait le même problème que ce poste ici : https://forum.openoffice.org/fr/forum/viewtopic.php?f=9&t=41573&p=227571&hilit=java.lang.IncompatibleClassChangeError#p227571

N'ayant plus vraiment créer une DB sous Base depuis que j'ai abandonné MS, je me suis dit que j'avais certainement oublié qqchose...
J'ai donc bien le créateur de rapport (extension) installé, j'ai bien le java installé de 1.6 à 1.9; sur le fil cité plus haut, j'ai utilisé la db en téléchargement pour tester mon " système' et j'ai LES mêmes erreurs :

Code : Tout sélectionner   AgrandirRéduire
Statut SQL: S1000
Une erreur est survenue pendant la création du rapport.

Une exception de type com.sun.star.lang.WrappedTargetException est survenue.

caught a java.lang.IncompatibleClassChangeError


Je ne vois pas trop ce que je peux faire.... notez que j'ai les même problème sur la même version de LO sous Ubuntu 14.04 avec l'environnement java 1.7. ( sur mon ordi portable)

Comment puis-je obtenir "ce rapport" ?

Un grand merci ( nb signature à jour)
Dernière édition par kikibelux le 06 Nov 2015 18:11, édité 2 fois.
Libo
Version: 5.2.2.2
Locale : fr-FR (fr_FR.UTF-8)
ubuntu 16.4
kikibelux

Portable ubuntu 17.4 LO 5.4
ancienne
LiBo
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
Ubuntu 12.04
kikibelux
kikibelux
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 97
Inscrit le : 14 Août 2007 10:20

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar Piaf » 12 Sep 2015 22:36

Bonsoir
Dans ta signature, précise que tu utilises Libre Office.
kikibelux a écrit:donc bien le créateur de rapport (extension) installé
Sous LibO la gestion des rapports est directement intégrée dans Base, tu n'as donc pas d'extension particulière à installer.
A+
Libre Office Version: 6.1.6 et Apache OpenOffice 4.1.6 Sur Xubuntu 18.04 AMD64
Piaf
GourOOu
GourOOu
 
Message(s) : 5622
Inscrit le : 25 Nov 2011 19:07
Localisation : Guyane

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar kikibelux » 12 Sep 2015 23:42

Le principal n'y était pas dans la signature...
SI je n'active pas cette extension, je n'ai pas la possibilité de créer un rapport en mode ébauche...
De plus, sans cette extension, il n'ouvre même pas les rapports crées ...
j'ai donc supposé que j'en ai besoin !

Quid donc ?

Merci
Libo
Version: 5.2.2.2
Locale : fr-FR (fr_FR.UTF-8)
ubuntu 16.4
kikibelux

Portable ubuntu 17.4 LO 5.4
ancienne
LiBo
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
Ubuntu 12.04
kikibelux
kikibelux
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 97
Inscrit le : 14 Août 2007 10:20

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar jeanmimi » 13 Sep 2015 09:39

Bonjour,
Tu peux joindre ta base pour tester, comme ça tu sauras si ton problème vient de ta base, ou de ton installation.
LibreOffice Version : Version: 6.3.1.2 (x64) (7 septembre 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14945
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar kikibelux » 13 Sep 2015 11:18

bonjour,

Merci de prendre mon cas en considération.
voici une version du début de la base, le rapport1 cause le problème.
Pièces jointes
jc15-pub.odb
base-test
(8.42 Kio) Téléchargé 45 fois
Libo
Version: 5.2.2.2
Locale : fr-FR (fr_FR.UTF-8)
ubuntu 16.4
kikibelux

Portable ubuntu 17.4 LO 5.4
ancienne
LiBo
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
Ubuntu 12.04
kikibelux
kikibelux
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 97
Inscrit le : 14 Août 2007 10:20

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar jeanmimi » 13 Sep 2015 15:17

J'arrive à éditer ton Rapport1 sans difficulté.
Évidemment, comme il n'y a pas de données dans les tables, la création du Rapport ne donne qu'une page vide.
Tes Tables devraient avoir une clé primaire de Type INTEGER en Auto-Valeur.
Pièces jointes
Rapport1_Mode_Edition.png
LibreOffice Version : Version: 6.3.1.2 (x64) (7 septembre 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14945
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar kikibelux » 13 Sep 2015 15:29

et bien ?

Il n'y a pas de données...ça c'est ok !

Mais toutes mes tables ont un champs "id, clé en integer...qui est une clé...

Vous ne les voyez pas ?

MERCI
Libo
Version: 5.2.2.2
Locale : fr-FR (fr_FR.UTF-8)
ubuntu 16.4
kikibelux

Portable ubuntu 17.4 LO 5.4
ancienne
LiBo
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
Ubuntu 12.04
kikibelux
kikibelux
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 97
Inscrit le : 14 Août 2007 10:20

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar jeanmimi » 13 Sep 2015 15:58

Si je les vois, mais je parlais de clés de Type INTEGER en Auto-Valeur, pas avec une valeur à entrer dans la clé pour chaque enregistrement.
Pièces jointes
jc15-pub_v2.odb
(19.19 Kio) Téléchargé 30 fois
LibreOffice Version : Version: 6.3.1.2 (x64) (7 septembre 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14945
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar kikibelux » 13 Sep 2015 18:14

Je viens de tester votre base, et j'ai le même soucis !

Impossible d'ouvrir le rapport !

Que puis-je faire ?

Serait-ce un bogue dans Ma distribution ?

Merci
Libo
Version: 5.2.2.2
Locale : fr-FR (fr_FR.UTF-8)
ubuntu 16.4
kikibelux

Portable ubuntu 17.4 LO 5.4
ancienne
LiBo
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
Ubuntu 12.04
kikibelux
kikibelux
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 97
Inscrit le : 14 Août 2007 10:20

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar jeanmimi » 13 Sep 2015 18:50

kikibelux a écrit:Serait-ce un bogue dans Ma distribution ?

Ici : https://forum.openoffice.org/fr/forum/v ... 41&t=42220
Papayes décrit comment installer les versions officielles plutôt que celles des distributions.

Un coup d’œil sur le rapport que j'ai créé :
Rapport_Aperçu.png
Rapport_Aperçu.png (3.29 Kio) Consulté 2173 fois
LibreOffice Version : Version: 6.3.1.2 (x64) (7 septembre 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14945
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar kikibelux » 13 Sep 2015 19:31

oui ! c'est ce que je voudrais faire, mais créé avec quel outil ébauche ou ?

J'ai fait mon installation avec les ppa "génériques...

9a voudrais dire qu'ils ne sont pas bons ?

Et Aussi MERCI !
Libo
Version: 5.2.2.2
Locale : fr-FR (fr_FR.UTF-8)
ubuntu 16.4
kikibelux

Portable ubuntu 17.4 LO 5.4
ancienne
LiBo
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
Ubuntu 12.04
kikibelux
kikibelux
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 97
Inscrit le : 14 Août 2007 10:20

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar kikibelux » 13 Sep 2015 20:47

Le modérateur a écrit: :alerte: Avec autant de messages à votre compteur, il faut encore vous le rappeler ?
Veuillez ne pas poster plusieurs messages à la suite !
Si vous devez ajouter un complément d'information, le bouton "Editer" à la droite du message permet d'y remédier.
En attendant une prochaine réponse, vous pouvez participer également en répondant à d'autres questions sur notre forum.

et bien voilà !

J'ai installé la version depuis les tar.gz et cela fonctionne !

Juste un problème d'interface dans gnome fallback, aucun icone, mais bon ce n'est pas trop grave, je vais le faire à la main( je dois refaire l'install...)
Avant de conclure et de changer l'icône, je testerai demain sur ma machine en Ubuntu 14.4 toute fraîche avec le ppa si le problème persiste. ( si je me souviens bien l'install est propre directement depuis le ppa)

Merci
Libo
Version: 5.2.2.2
Locale : fr-FR (fr_FR.UTF-8)
ubuntu 16.4
kikibelux

Portable ubuntu 17.4 LO 5.4
ancienne
LiBo
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
Ubuntu 12.04
kikibelux
kikibelux
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 97
Inscrit le : 14 Août 2007 10:20

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar kikibelux » 16 Sep 2015 17:33

je viens de regarder la même base de données ouverte sur Ubuntu 14.04 avec le ppa générique pour Libo ne me permet même pas d'éditer le rapport.
Le java est : 1.7.0_79 (pour i386)

Serait-ce la version de java ?
rapport builder n'est pas installé.


les infos version sont :
Libo
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
Libo
Version: 5.2.2.2
Locale : fr-FR (fr_FR.UTF-8)
ubuntu 16.4
kikibelux

Portable ubuntu 17.4 LO 5.4
ancienne
LiBo
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
Ubuntu 12.04
kikibelux
kikibelux
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 97
Inscrit le : 14 Août 2007 10:20

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar jeanmimi » 16 Sep 2015 19:52

kikibelux a écrit:rapport builder n'est pas installé.
Soit tu installes cette extension,
soit tu télécharges et installes la version de LO officielle, avec Report Builder intégré, depuis le site de téléchargement :
https://fr.libreoffice.org/download/libreoffice-fresh/
LibreOffice Version : Version: 6.3.1.2 (x64) (7 septembre 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14945
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar kikibelux » 16 Sep 2015 19:53

Je pense prendre la seconde solution !

Ne faudrait-il pas faire remonter l'information au gestionnaire du PPA ?
Libo
Version: 5.2.2.2
Locale : fr-FR (fr_FR.UTF-8)
ubuntu 16.4
kikibelux

Portable ubuntu 17.4 LO 5.4
ancienne
LiBo
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
Ubuntu 12.04
kikibelux
kikibelux
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 97
Inscrit le : 14 Août 2007 10:20

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar jeanmimi » 16 Sep 2015 20:04

kikibelux a écrit:Ne faudrait-il pas faire remonter l'information au gestionnaire du PPA ?
Oui, certainement, tu peux le faire.
Il te répondra peut-être que c'est une histoire de Licence.
LibreOffice Version : Version: 6.3.1.2 (x64) (7 septembre 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 14945
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Impossible d'obtenir un rapport en mode Ebauche

Messagepar kikibelux » 06 Nov 2015 18:03

La solution a été de prendre les fichiers gz disponibles sur le site
Sujet cloturé
Merci à tous pour votre aide.
Libo
Version: 5.2.2.2
Locale : fr-FR (fr_FR.UTF-8)
ubuntu 16.4
kikibelux

Portable ubuntu 17.4 LO 5.4
ancienne
LiBo
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
Ubuntu 12.04
kikibelux
kikibelux
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 97
Inscrit le : 14 Août 2007 10:20


Retour vers Base de données

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 5 invité(s)